none
Custom Field Values Intermittently Disappear During Publish RRS feed

  • Question

  • Background:

    I have a team of about 18 project managers who are managing a portfolio of approximately 110 active projects.  There are approximately 40 people, including the project managers, submitting timesheets on a weekly basis.  10 of the project managers are based in the US while the remaining 30 users are located in Ukraine.

    We're running Project Professional through Office 365, v15.0.9999.1000.

    The Problem

    I've defined a number of enterprise custom fields to capture information about the projects (things like project bill type and status, price and hours sold, invoice number to link to our CRM system, comments, etc.).  In any case, with disappointing frequency, the data in the custom fields, some of which are mandatory, disappears during the publish process. It seems to happen to the Ukrainian project managers more often than to those based in the US.  It seems to pretty clear to me that the upload/synchronization process has some inherent unreliability (also causing occasional corruption of projects saved on the server).

    Questions:

    1. Is there anything that I can do to eliminate or reduce the frequency of these problems?
    2. Is Microsoft aware of these problems and is there any plan to improve the reliability of client-server communications?

    Wednesday, October 18, 2017 1:50 PM

All replies

  • Where are this enterprise custom fields being create

    1) In the configuration setting of PWA.  That's good and that's place place it should be done

    2) In project professional client.   Then this may be local custom fields and they are not saved to PWA.

    If you can reproduce this behavior, then it would be a bug and you can report it to Microsoft by opening a ticket.  Microsoft will not fix a bug, unless you can reproduce it.  Thus they can d


    Michael Wharton, MVP, MBA, PMP, MCT, MCTS, MCSD, MCSE+I, MCDBA
    Website http://www.WhartonComputer.com
    Blog http://MyProjectExpert.com contains my field notes and SQL queries

    Wednesday, October 18, 2017 9:36 PM
    Moderator
  • The fields are being created in the PWA Server Settings. Definitely not in the project professional client.

    It's not reliably reproducible. It's intermittent. It happens more often with users who are in Kiev as compared to those who are in the US, so I suspect that it's related to some internet communications issue.


    Monday, October 23, 2017 11:35 AM