getting 401 with RSWindowsNegotiate with network service user for SSRS


  • I am an internal user in Microsoft. I have a SSRS set up from a Sql Server 2008 R2 Enterprise edition. I have used the RSWindows Negotiate and Rs Windows NTLM spearately in the rsreportingserviceconfig file and restarted the server a number of times.  

    The windows account it is running under is the network service but whenver the I access the report manager URL from a broswer outside, I always get the same error : 3 times it asks for credentials  and then the screen goes blank. 

    I tried using the service as a domain account but the problem with that is, the kerberos authentication fails and as per some documents, I am supposed to register the SPN for the same.

    Since I dont have permission to set the SPN , I was trying the non Kerberos way and I keep getting this 401 errors. 

    Sunday, September 01, 2013 6:07 PM


  • Hi Parag,

    What do you mean by saying “from a browser outside”? Do you mean accessing the report manager from a machine that is not the report server or Reporting Services instance server?  Which browser do you use the access the report manager? Please try the following steps:

    1. Set the Services Account to Network Service from the Reporting Services Configuration Manager, and check the rsreportserver.config file to ensure the authentication is set to use RSWindowsNTLM authentication.
    2. Browse the report manager use Internet Explorer and launch it as administrator.
    3. Add the http://<ServerName> URL to the trusted sites list in IE.

    Mike Yin

    If you have any feedback on our support, please click here

    Mike Yin
    TechNet Community Support

    Tuesday, September 03, 2013 1:45 PM