locked
windows process activation service RRS feed

  • Question

  • Hi,

     

    Try to start windows process activation service, however it does not seen to be successful. It keep fail. From the event viewer report few id as 5005, 5036 and 5189.

    I also have try to resolve the issue using the guideline given by Microsort on the reported id, however it also not helpful. Below is the error message I receive when I try to start the services manually.

    A system error has occurred

    System error 6801 has occur

    Transaction support within the specified resources manager is not started or was shut down due to an error.

    Really need a solution to resolve this issue. Thank you.

     

     

    Regards,

    Ivy


    Ivy
    Wednesday, January 12, 2011 6:35 PM

Answers

  • Hi Ivy,

     

    Thank you for the reply.

     

    Now I suggest trying below:

     

    1.    Back up applicationHost.config to a safe place. It is recommend to copy all folder and files under the C:\Windows\System32\inetsrv\backup to the safe place too. Remove the IIS from the server.

    2.    From Control Panel\Programs and Features, in the Tasks panel, choose Turn Windows features on or off.

    3.    Uncheck all of IIS.

    4.    Uncheck Windows Process Activation Service (WAS), down further in the list of features.

    5.    The only way to truly completely remove IIS and all the config settings is to uninstall WAS as well.

    6.    After you have done the above, reboot the server.

    7.    Reinstall IIS7 on the server.

    8.    Then when the server comes back up go ahead and add back the IIS components, you will not have to recheck Windows Process Activation Service, it will automatically get added when you reinstall IIS.

    9.    Once IIS is completely reinstalled attempt to browse the default website and test Application Pool Custom Identity.

    10. Open the applicationHost.config file under the C:\Windows\System32\inetsrv\config.

    11. Copy the <configProtectedData><providers>... </providers></configProtectedData> session and paste it into old applicationHost.config(step one).

    12. Backup current applicationHost.config file:

     

    a)     Click on Start, go to Programs -> Accessories-> Command Prompt, right click on Run as administrator “

    b)     Go to the IIS7 directory. This is located in the %WINDIR%\System32\InetSrv directory by default. The configuration files are stored in the InetSrv\Config directory. Backup the applicationHost.config file by creating a backup object with the aid of the APPCMD command-line tool.

     

    cd /d %windir%\system32\inetsrv

    appcmd add backup NewConfigBackup

     

    13. Copy the old applicationHost.config(step 1 and 8) to replace the new applicationHost.config under the C:\Windows\System32\inetsrv\config

    14. Reset IIS (iisreset ) in Command Prompt with Run as Administrator.

     

    Then please test the result.

     

    If the issue persists, as this issue could be closely related to IIS, I suggest further discussing it in our IIS fourm:

     

    http://forums.iis.net/

     

    Tim Quan

    TechNet Subscriber Support in forum

    If you have any feedback on our support, please contact tngfb@microsoft.com  

    ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.  

    • Marked as answer by Tim Quan Monday, January 24, 2011 1:37 AM
    Thursday, January 20, 2011 7:16 AM

All replies

  • Hello,

    would be nice if you have specified the OS version that you are using, makes it a bit easier to see about solutions, so start with:

    http://social.answers.microsoft.com/Forums/en-US/w7performance/thread/fba64f34-4c16-4551-82d7-f22169be0d97

    http://support.microsoft.com/kb/939615

    http://support.microsoft.com/kb/939399

    And if they doesn't help, then give more information about when it happens, on which OS version(including SP/patch level) or what you are doing that result in this message.


    Best regards Meinolf Weber Disclaimer: This posting is provided "AS IS" with no warranties or guarantees , and confers no rights.
    Wednesday, January 12, 2011 9:45 PM
  • Hi,

     

    I have try all the solution that been provide. Anyhow it still could not resolve the issue. The OS that I using is Windows Server 2008 R2. I not sure what has result this message.

    I try to on the services yesterday, however not manage to do so. I start to troubleshooting it by looking on the event viewer and so on. Then only figure out it occur the same error message start from few days ago.

    I have also ask around my colleagues and they mention they didn't make any changes to this server as well.

    Thank you.

     

    Regards,

    Ivy


    Ivy
    Wednesday, January 12, 2011 11:43 PM
  • Hi,

     

    Could you please paste the contents in the error event logs?

     

    Are you running IIS?

     

    Tim Quan

    TechNet Subscriber Support in forum

    If you have any feedback on our support, please contact tngfb@microsoft.com  

    ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.  

     

    Thursday, January 13, 2011 2:56 AM
  • Hi,

    Yes, i have enable the IIS. Below is the error event logs:

    Log Name:      System
    Source:        Microsoft-Windows-WAS
    Date:          1/13/2011 2:56:07 AM
    Event ID:      5005
    Task Category: None
    Level:         Error
    Keywords:      Classic
    User:          N/A
    Computer:      EMWADFL2.iem.ibiden.local
    Description:
    Windows Process Activation Service (WAS) is stopping because it encountered an error. The data field contains the error number.

    Log Name:      System
    Source:        Microsoft-Windows-WAS
    Date:          1/13/2011 2:56:07 AM
    Event ID:      5036
    Task Category: None
    Level:         Error
    Keywords:      Classic
    User:          N/A
    Computer:      EMWADFL2.iem.ibiden.local
    Description:
    The configuration manager for Windows Process Activation Service (WAS) did not initialize. The data field contains the error number.

    Log Name:      System
    Source:        Microsoft-Windows-WAS
    Date:          1/13/2011 2:56:07 AM
    Event ID:      5189
    Task Category: None
    Level:         Error
    Keywords:      Classic
    User:          N/A
    Computer:      EMWADFL2.iem.ibiden.local
    Description:
    The Windows Process Activation Service failed to generate an application pool config file for application pool '*'. The error type is '0'. To resolve this issue, please ensure that the applicationhost.config file is correct and recommit the last configuration changes made. The data field contains the error number.

    Thank you.

     

    Regards,

    Ivy

     

     


    Ivy
    Thursday, January 13, 2011 3:03 AM
  • Hi,

     

    Then I suggest installing the hotfixes from the following sites:

     

    http://support.microsoft.com/kb/971047/en-us

    http://support.microsoft.com/kb/975443/en-us

     

    Tim Quan

    TechNet Subscriber Support in forum

    If you have any feedback on our support, please contact tngfb@microsoft.com  

    ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.  

    • Marked as answer by Tim Quan Tuesday, January 18, 2011 1:28 AM
    • Unmarked as answer by Tim Quan Wednesday, January 19, 2011 12:13 PM
    Thursday, January 13, 2011 7:04 AM
  • Any update?
    Monday, January 17, 2011 2:51 AM
  • Hi,

     

    It could not solve the issue, the services could not be start and also I could not install the patch.

    Thank you.

     

    Regards,

    Ivy Wu


    Ivy
    Wednesday, January 19, 2011 5:52 AM
  • Hi Ivy,

     

    Thank you for the reply.

     

    Now I suggest trying below:

     

    1.    Back up applicationHost.config to a safe place. It is recommend to copy all folder and files under the C:\Windows\System32\inetsrv\backup to the safe place too. Remove the IIS from the server.

    2.    From Control Panel\Programs and Features, in the Tasks panel, choose Turn Windows features on or off.

    3.    Uncheck all of IIS.

    4.    Uncheck Windows Process Activation Service (WAS), down further in the list of features.

    5.    The only way to truly completely remove IIS and all the config settings is to uninstall WAS as well.

    6.    After you have done the above, reboot the server.

    7.    Reinstall IIS7 on the server.

    8.    Then when the server comes back up go ahead and add back the IIS components, you will not have to recheck Windows Process Activation Service, it will automatically get added when you reinstall IIS.

    9.    Once IIS is completely reinstalled attempt to browse the default website and test Application Pool Custom Identity.

    10. Open the applicationHost.config file under the C:\Windows\System32\inetsrv\config.

    11. Copy the <configProtectedData><providers>... </providers></configProtectedData> session and paste it into old applicationHost.config(step one).

    12. Backup current applicationHost.config file:

     

    a)     Click on Start, go to Programs -> Accessories-> Command Prompt, right click on Run as administrator “

    b)     Go to the IIS7 directory. This is located in the %WINDIR%\System32\InetSrv directory by default. The configuration files are stored in the InetSrv\Config directory. Backup the applicationHost.config file by creating a backup object with the aid of the APPCMD command-line tool.

     

    cd /d %windir%\system32\inetsrv

    appcmd add backup NewConfigBackup

     

    13. Copy the old applicationHost.config(step 1 and 8) to replace the new applicationHost.config under the C:\Windows\System32\inetsrv\config

    14. Reset IIS (iisreset ) in Command Prompt with Run as Administrator.

     

    Then please test the result.

     

    If the issue persists, as this issue could be closely related to IIS, I suggest further discussing it in our IIS fourm:

     

    http://forums.iis.net/

     

    Tim Quan

    TechNet Subscriber Support in forum

    If you have any feedback on our support, please contact tngfb@microsoft.com  

    ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.  

    • Marked as answer by Tim Quan Monday, January 24, 2011 1:37 AM
    Thursday, January 20, 2011 7:16 AM
  • Hi,

     

    Noted and I will act accordingly. Anyhow, i only manage to do it by this weekend. As i need to schedule for server downtime.

    Thank you.


    Regards,

    Ivy


    Ivy
    Monday, January 24, 2011 10:57 AM
  • I have a similar issue, is it possible to add and remove the IIS role on an SBS server?

    Adam Graham

    Friday, September 7, 2012 12:50 PM
  • Hi I am experiencing a similar problem with windows 2008 R2. When I try to uninstall IIS and WAS I am getting error 0x80070643. Please can you let me know how to solve this.

    Thanks

    Reddy


    Wednesday, August 21, 2013 6:50 AM
  • I had the same problem and tried almost everything suggested here without any success.

    Then, scheduled CHKDSK /F C: on next reboot. This did the trick for me.

    Jeevan

    Thursday, November 21, 2013 8:49 AM
  • thanks! this solved the problem for me
    Thursday, July 24, 2014 9:21 PM