locked
How to setup RemoteApp mode for some application in Windows 10 Professional RRS feed

  • Question

  • Hi all,

    how to deal with RemoteApp mode in Windows 10 Professional? I tryied to follow instructions to setup application for RemoteApp mode under Windows 7 (published on geekswithblogs.net) but without success. Problem is that there is no such entry

    • HKLM/SOFTWARE/Microsoft/Windows NT/CurrentVersion/Terminal Server/TSAppAllowList

    in registry. When I add these entry by hand and follow next instructions, I cannot connect to remote application because window closed immediately after login. Normal remote desktop is working fine.

    Can you suggest some resources or guide to setup and use RemoteApp mode in Windows 10 Professional?

    Many thanks for any idea.

    Best regards,

    Ondrej Nemecek.

    Tuesday, January 19, 2016 1:21 PM

Answers

  • Hi Ondrej,

    How did you do that exactly?

    Since I have no Windows 10 pro lab machine, i done the test on my Windows 10 Enterprise version 1511 lab machine, it works fine.

    Here is my steps:

    1. Locate to this entry:

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Terminal Server\TSAppAllowList

    2. Navigate to fDisabledAllowList value in the right pane, set its value as "1".

    3. Add new key under TSAppAllowList, named Applications.

    4. Add new key under Applications, named anything you want(here is "123456").

    5. Create two new String Values for "123456", named "Name" and "Path". Their value are as below:

    After that, Remote connection to that host computer from your guest computer.

    Make sure the connection is fine. And then save the RDP connection to a RDP file.

    Open the RDP file with the Notepad, and then modify and add those 4 entries:

    1. Modify remoteapplicationmode:i:0  to  remoteapplicationmode:i:1

    2. Add remoteapplicationprogram:s:Notepad

    3. Add disableremoteappcapscheck:i:1

    4. Add alternate shell:s:rdpinit.exe

    Afterward, save the RDP file, double click it would launch the RemoteAPP.


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.


    Wednesday, January 20, 2016 3:02 AM

All replies

  • Hi Ondrej,

    How did you do that exactly?

    Since I have no Windows 10 pro lab machine, i done the test on my Windows 10 Enterprise version 1511 lab machine, it works fine.

    Here is my steps:

    1. Locate to this entry:

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Terminal Server\TSAppAllowList

    2. Navigate to fDisabledAllowList value in the right pane, set its value as "1".

    3. Add new key under TSAppAllowList, named Applications.

    4. Add new key under Applications, named anything you want(here is "123456").

    5. Create two new String Values for "123456", named "Name" and "Path". Their value are as below:

    After that, Remote connection to that host computer from your guest computer.

    Make sure the connection is fine. And then save the RDP connection to a RDP file.

    Open the RDP file with the Notepad, and then modify and add those 4 entries:

    1. Modify remoteapplicationmode:i:0  to  remoteapplicationmode:i:1

    2. Add remoteapplicationprogram:s:Notepad

    3. Add disableremoteappcapscheck:i:1

    4. Add alternate shell:s:rdpinit.exe

    Afterward, save the RDP file, double click it would launch the RemoteAPP.


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.


    Wednesday, January 20, 2016 3:02 AM
  • I am having the same issue on windows 10. I have followed theses steps but the app immediately closes after login.

    The tsappallowlist wasn't there originally. I had the manually enter the registry entries in.

    Tuesday, February 2, 2016 7:22 PM
  • Thanks for response. We follow your instructions with success in Windows 10 Ultimate, but it it fails in Windows 10 Professional. There is no Terminal server key in registry and when I import  key from Windows 10 Ultimate the application close immediately after login. See attached key at the end of my message

    Is there something special in Windows 10 Professional?

    Thanks for any informations.

    Best regards,
    Ondrej.

    ___

    I used these reg:

    Windows Registry Editor Version 5.00
    
    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Terminal Server]
    
    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Terminal Server\TSAppAllowList]
    "CentralLicensing"=dword:00000000
    "CertificateExpiresOn"=""
    "CertificateIssuedBy"=""
    "CertificateIssuedTo"=""
    "CustomRDPSettings"="authentication level:i:2"
    "fDisabledAllowList"=dword:00000001
    "fHasCertificate"=dword:00000000
    "LicenseServers"=hex(7):00,00
    "LicensingType"=dword:00000005
    
    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Terminal Server\TSAppAllowList\Applications]
    
    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Terminal Server\TSAppAllowList\Applications\Notepad]
    "Name"="Notepad"
    "Path"="c:\\windows\\system32\\Notepad.exe"
    

    Monday, February 15, 2016 4:01 PM
  • Any idea to this issue?
    Thursday, March 10, 2016 5:11 PM
  • Terminal Services's RemoteApp support in the Terminal Server is only supported in the following Windows 10 editions:

    • Ultimate
    • Enterprise
    • Education

    RemoteApp server is not available for Windows 10 Professional which appear to be what you say your using. It is also not included in Home or Starter.

    • Proposed as answer by Mod John UK Monday, May 1, 2017 3:13 PM
    Monday, May 1, 2017 3:12 PM
  • Dear all,
    Seems to have been modified with Windows 10 Pro Creators Update. I use a server on Windows 10 Pro, and after creating a remoteapp (helped with RemoteApp Tool as Program Tab is not available anymore in Win 10 :(  ), it works very well.

    But ... port forwarding is not working. It is well set up on the RDP file, but doesn't work. Tricky part:

       - 1: if I launch a standard RDP connexion (with same settings), port forwarding is ok

       - 2: If I launch then the RDP with RemoteApp, port forwarding is not working

       - 3: If I then come back to the standard RDP connexion, port forwarding will not work anymore. I need to restart the server to have the functionality to come back.

    I've searched on the net for similar issue, but no clue yet. Would you have an idea?

    Hoping the info Win10 pro is now supporting RemoteApp will help some of you, thank you for your help, best regards,

    Ptitwill

    • Proposed as answer by skewdrv Saturday, January 18, 2020 11:56 AM
    Thursday, October 5, 2017 9:01 PM
  • [HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows NT\Terminal Services]
    "fAllowUnlistedRemotePrograms"=dword:00000001
    Saturday, November 11, 2017 8:50 PM