none
Unable to authenticate valid link/credentials for Excel Power Query web data source RRS feed

  • Question

  • Hi,

     

    I'm using Power Query in Excel to obtain issues from Jira via a web data source. The source and subsequent query have previously worked fine using the same credentials (reinforced by 29 day old cached results) but it will no longer refresh, reporting "We couldn't authenticate with the credentials provided. Please try again."

     

    If I paste the source link into a browser, the .csv file is successfully downloaded.

     

    If I attempt to recreate the query in Excel by adding data from web, specifying the Jira .csv link and configuring "basic" credentials (my Jira login details) in the "Access Web content" dialog, the error persists, indicating "use anonymous access for this web content" (which is counterintuitive given the requirement to login and doesn't help). When I click "Basic" again, all of my previously entered credentials have been cleared. Re-entering them doesn't help.

     

    I can't find much in the way of information relating to this functionality around the web. Hopefully somebody can point me in the right direction or acknowledge that this is a known issue / provide a fix eta.

    Wednesday, November 7, 2018 8:46 AM

Answers

All replies

  • Hey! I highly suggest that you use a tool like fiddler to figure out what type of error you’re getting from the data source and why it is happening. Perhaps the JIRA folks updated their security and the credentials need to be encoded in a particular way or they need to be part of the header for example. I haven’t read their documentation so I wouldn’t be able to say how things should look like, but you’d start by figuring out the response that you get from jira and if perhaps you need to tune your Web.Contents formula to create the specific call that jira expects. You could also create a custom connector in the event that you need even more control over how the Query is being created and sent.
    Wednesday, November 7, 2018 1:51 PM
  • Hi S G. Can you share the formula text of the problematic query (with any sensitive data removed, of course)?

    Ehren

    Thursday, November 8, 2018 9:02 PM
    Owner
  • I get same problem connecting an Excel Pivot Table using ODATA (web service) to Microsoft Dynamics NAV 2016. 

    I always work remotely through a VPN, and thats why I have always have to change my credentials in Excel when trying to connect.

    I have been doing it regularly, but now I am not able to do it. I get this error:

    We couldn't authenticate with the credentials provided. Please try again

    I use windows authentication.

    It is funny I have older excel sheets with other odata connections and those work fine.

    It is also funny I can paste the web service URL (using Chrome) and after authenticating (username and password) the query works fine!

    this is the webservice:

    http://servername.com:7048/DynamicsNAV90/OData/Company('mycompany')/myquery

    Tuesday, November 20, 2018 5:55 AM
  • Hi Antonio. Can you share the M formula text that you're using to access that webservice URL? Is it Web.Contents? OData.Feed? Something else? Thanks!

    Ehren

    Tuesday, November 20, 2018 6:36 PM
    Owner
  • Solved! Seems like last excel update cannot resolve servername.com.

    I just replaced it by server ip and it is working again!

    Wednesday, November 21, 2018 7:20 AM