RDP W2008x86 Connection error


  • I am having difficulty connecting to some recently built W2008x86 servers with RDP. The wierd part is that it works if I use a RDP third party tool like "Remote Desktop Manager". It just fails if I use MSTSC. Here is the scenario:

    Remote Desktop Client is 6.1.7601 on a W7 workstation with SP1

    I RDP (using MSTSC) to ServerA and I get "This computer can't connect to the remote computer"

    I do the same thing through Remote Desktop Manager (or RDPDesk) and it works fine.

    I see no errors on the server, no failed logons etc. The target server has the "Allow connections from computers running any version of Remote Desktop(Less Secure)" turned on, however, I tried the more secure option and had the same result.

    I actually have another server built at the same time with the same image and have no problem with it. It works both from mstsc and with a Deskop Manager program.

    I have a W2012 box with Remote Desktop Client 6.2.9200  so I tried using the 6.2 client to connect. I get the same failure with the 6.2 client.  So it seems to be something in the server but I can't figure out what.

    We have had this once before and it was also with a W2008x86 server so I think that is one relevant variable but I really would like to fix the problem.

    Anyone have any thoughts or ideas?




    Friday, October 18, 2013 8:00 PM


  • hi, at first try a qwinsta, does the RDP listener is in a listen state ? (a netstat -a by checking the port 3389 do the job too)

    If yes, any new update done ?

    or I would check for any licencing issue. You can clear the licence the computer got before retriing to connect. (Removing HKEY_LOCAL_MACHINE\Software\Microsoft\MSLicensing and re-run MSTSC as an admin)

    Regards, Philippe

    Saturday, October 19, 2013 2:59 AM

All replies