none
Cannot connect to Data Source in PPS Dashboard Designer RRS feed

  • Question

  •  

    Hi,

     

    I'm a beginner in PPS Monitoring and I'm trying to connect a Data Source (SQL2K5 database and AS2K5 Cube). I get the following error :

     

    The PerformancePoint Server could not connect to the specified data source. Verify that either the current user or application pool user has Read permissions to the data source, depending on your security configuration. Also verify that all required connection information is provided and correct.

     

     

    I looked up for this error and I found 2 workarround for this issue :

     

    1- In the application pool Identity tab, change the Network Service account to a domain account and grant the new account membership to the BPMDeveloper role in PPSMonitoring system database

     

    2- keep Network Service account and grant him a db_datareader privilege to the DB I'm trying to access.

     

     

    Both workarround didn't work. Do you have any other solution for this issue?

     

    Do you have any example of connection strings?

     

    Regards

     

    Sami ASSI

    Wednesday, March 19, 2008 8:40 AM

Answers

  • Yes I think that is your problem.

    You don't have configured access to your OLAP database on SSAS.

    You can achieve this by using SSMS and connect to SSAS.

    Then on your OLAP database add your application pool account to any of roles.

    Configured roles (if any exists) are located in Databases Tree in the following location:

    Databases/YourDatabaseName/Roles

     

    More details you will find here

    http://msdn2.microsoft.com/en-us/library/ms175386.aspx

     

    You can also check if there are any problems with lack permissions by launching SQL Server Profiler (connect to Analysis Services).

    There will be errors visible while accessing your OLAP database from PPS.

     

    I hope this helps.

     

    Best regards,

    Radoslaw Lebkowski

     

     

    Wednesday, March 19, 2008 1:07 PM

All replies

  •  

    Hello Sami,

     

    In default settings PPS Monitoring use application pool identity account to access your data sources (e.g. OLAP database).

    So you need to add required permissions to your OLAP or other database for this account.

    Account used to connect to data source depends on it whether you use Dasboard Designer, Preview Site or MOSS site.  MOSS site application pool identity is used to make connections once a dashboard has been deployed to SharePoint.

     

    More details you will find here:

    http://nickbarclay.blogspot.com/2007/11/pps-data-source-connection-problems.html

     

     

    Best Regards,

    Radoslaw Lebkowski

     

    Wednesday, March 19, 2008 9:38 AM
  • Sundar, Aseem, Jon, Greg

     

    How about making a sticky "Cannot connect to Data Source in PPS Dashboard Designer" with a link to Nick's post?

     

    Cheers

     

    Tim

     

     

    Wednesday, March 19, 2008 10:04 AM
  • That's exactly where I went and read about this problem.

     

    In fact, after posting message, I searched for correct Connection String syntaxing and found the correct syntax for it (www.connectionstring.com). so I succeeded in connecting via ODBC. But I still don't know the syntax for Multidimenstional connection.

     

    Does anybody have an idea ?

     

    Sami
    Wednesday, March 19, 2008 11:47 AM
  • Hmm,

    While creating a Data Source based on OLAP database (SSAS) in Dasboard Designer you can use both Standard Connection option (without need to prepare any connection string) and Connection String like this below:

     

    Provider=msolap.3;Datasource=MySSASServerName;Initial Catalog=MySSASDBName;

     

     

    More details about connection strings to Analysis Services you can find here:

    http://www.ssas-info.com/analysis-services-articles/63-connectivity/102-analysis-services-2000-and-2005-connection-string-properties

     

     

    Best regards,

    Radoslaw Lebkowski

    Wednesday, March 19, 2008 11:57 AM
  •  

    Thanks for you reply,

     

    I tried both ways, but it still doesn't work, even with the connection string you provided me with.

     

    Maybe I should grant the Network Service account the necessary priviliges, but where can I do that in AS? Unlike Database Engine, I don't have a Security folder in which I can create/add users and grant permissions.

     

    Thanks

     

    Sami

    Wednesday, March 19, 2008 12:42 PM
  • I found It !!!

     

    I added the Network Service account in the Role memership in the selected AS Catalogue.

     

    Thank you all for your help.

     

    Regards.

     

    Sami ASSI

     

    Wednesday, March 19, 2008 1:06 PM
  • Yes I think that is your problem.

    You don't have configured access to your OLAP database on SSAS.

    You can achieve this by using SSMS and connect to SSAS.

    Then on your OLAP database add your application pool account to any of roles.

    Configured roles (if any exists) are located in Databases Tree in the following location:

    Databases/YourDatabaseName/Roles

     

    More details you will find here

    http://msdn2.microsoft.com/en-us/library/ms175386.aspx

     

    You can also check if there are any problems with lack permissions by launching SQL Server Profiler (connect to Analysis Services).

    There will be errors visible while accessing your OLAP database from PPS.

     

    I hope this helps.

     

    Best regards,

    Radoslaw Lebkowski

     

     

    Wednesday, March 19, 2008 1:07 PM
  • hehe you were faster Smile

    great

     

    Wednesday, March 19, 2008 1:08 PM
  • Hello, all

     

    I have a problem connecting to AS 2005 from PPS which I think is different from all of the above mentioned. We have been using PPS data source and reports, scorecards, etc for some time now. The application pool account of PPS has been set to a domain account, has been given permissions on the cube we try to use in reports. Everything worked fine for a couple of weeks. The tricky part is that the team responsible for making modifications to the AS 2005 cube is still improving the cube. The current problem is that after the cube has been processed 2 days ago, PPS cannot connect to the AS 2005 cube. Permissions and roles in the cube are the same as before (have checked that). When creating a data source in PPS, the server name and the database name work fine (databases are displayed in the drop down list) but there are no cubes listed to chose from. There is also no error in any logs.

    If we try to use the old data source (containing the proper cube name), the following error is logged in the application log:

     

    System.ArgumentException: The '<cubeName>' object was not found.

    Parameter name: index

    at Microsoft.AnalysisServices.AdomdClient.CubeCollectionInternal.get_Item(String index)

    at Microsoft.AnalysisServices.AdomdClient.AdomdConnection.GetObjectData(SchemaObjectType schemaObjectType, String cubeName, String uniqueName)

    at Microsoft.AnalysisServices.AdomdClient.Member.PopulateParentLevel()

    at Microsoft.AnalysisServices.AdomdClient.Member.get_ParentLevel()

    at Microsoft.PerformancePoint.Scorecards.DataSourceProviders.OlapUtils.GetMemberFromAdomdMember(Member adomdMember, Member previousMember)

    at Microsoft.PerformancePoint.Scorecards.DataSourceProviders.OlapUtils.ExecChildrenQuery(String queryToRun)

    at Microsoft.PerformancePoint.Scorecards.DataSourceProviders.AdomdDataSourceProvider.QueryMembers(String expression)

    at Microsoft.PerformancePoint.Scorecards.DataSourceProviders.AdomdDataSourceProvider.QueryTimeIntelligenceMembers(DateTime currentTime, String formula)

    at Microsoft.PerformancePoint.Scorecards.Server.PmServer.QueryTimeIntelligenceInternal(DataSource dataSource, DateTime currentTime, String formula)

    at Microsoft.PerformancePoint.Scorecards.Server.PmServer.QueryTimeIntelligence(Guid dataSourceId, DateTime currentTime, String formula)

     

    The cube name and/or id has not been changed but even if they have, this should not be a reason for the cube not displaying in the drop down list when creating a data source.

    Any help or advice is appreciated!

     

    Thanks!

    Wednesday, July 2, 2008 1:00 PM
  • An update: The issue above turned out to be the cube not being completely processed. Reprocessing the cube solved everything.

     

    Thanks!

    Thursday, July 3, 2008 6:32 AM