locked
Unable to disable write caching on my HDD even tho Manufacturer says its supported RRS feed

  • Question

  • Hello

    I am trying to make my 2008R2 Ent box a DC and when DC promo it hangs for ages and just stops working. I have read this thread (very useful thanks)http://social.technet.microsoft.com/Forums/en-US/windowsserver2008r2general/thread/afeac12b-c7d7-44e4-88cd-4e44dfa48f75?prof=required and I know its to do with write-caching on the disk policy settings.

    However when I try and disable it Windows just gives me the error "windows could not change the write-caching setting for the device". So I went to the OEM website for my HDD and it looks like it is supposed to support it. I have tried to change my BIOS settings from IDE to AHCI mode but my machine just BSOD's when I do that so I am now stuck.

    So I am at a loss here and wouldn't mind some advice on what HDD's DO actually support this as I can't seem to find one on-line where the tech specs say Yes this device supports "turning off" write caching. Most support it ON but not OFF!!

    Thanks in advance

    Andy

    MSI 975X Platinum MOBO, 8GB DDR2 800Mhz ram, Intel Core 2 Duo 6600 2.49Ghz HDD WDC WD1600AVJS-63WNA0

    Friday, June 18, 2010 8:52 AM

Answers

  • This is a somewhat tricky issue, do you have a support contract with the
    manufacturer? You may be able to open a support case.
     

    -- Mike Burr
    Friday, June 18, 2010 5:41 PM
  • Hi Mike

    I managed to get this sorted. It was the BIOS version it seems. I upgraded the bios to latest version changed the SATA mode to ACHI and then it all started fine. I managed to turn off write caching and now I have a 2008 R2 AD server all working Hurrah :)

    Regards

    Andy

    • Marked as answer by AndyW77 Monday, June 28, 2010 9:58 AM
    Monday, June 28, 2010 9:57 AM

All replies

  • This is a somewhat tricky issue, do you have a support contract with the
    manufacturer? You may be able to open a support case.
     

    -- Mike Burr
    Friday, June 18, 2010 5:41 PM
  • Hi Mike

    I managed to get this sorted. It was the BIOS version it seems. I upgraded the bios to latest version changed the SATA mode to ACHI and then it all started fine. I managed to turn off write caching and now I have a 2008 R2 AD server all working Hurrah :)

    Regards

    Andy

    • Marked as answer by AndyW77 Monday, June 28, 2010 9:58 AM
    Monday, June 28, 2010 9:57 AM