locked
Bitlocker stuck at 0%, says drive "needs conversion" RRS feed

  • Question

  • Hello everybody,

    I just reinstalled Vista Ultimate x64, and got everything set up for BitLocker encryption. I saved the key, restarted, then BitLocker says that drive C: is being encrypted; however, it never goes past 0%.

    I have also tried to skip the "Run Bitlocker system check" option, but I get an error saying that not enough space is available. I find that extremely hard to believe, since I have 14.4 out of 30 GB free on my system drive.

    When BitLocker says the drive is being encrypted, if I check the BitLocker screen from Control Panel / Security / BitLocker, next to my system drive it says "needs conversion". What does that mean?

    I had BitLocker working before reinstalling Vista, and I do not have a clue as to why it is not working now. Does anyone have any idea or solution?

    My hard drive setup is as follows (should it be relevant) :

    - nForce 4 Controller

    - 2 X Western Digital Caviar 160 GB HDD's in RAID 0

    Thanks in advance for any help.

    Sincerely,

    Alex G.

     

    Wednesday, March 7, 2007 9:11 PM

All replies

  • Hi,

    I am having the same problem. I have 2 SATA drives in RAID 0 (Fujitsu Siemens laptop Amilo Xi 1554). I tried also without RAID array but it didn't helped. I would really want this issue to be solved. Can someone help us?

    Pictures about the problem:

    http://img167.imageshack.us/img167/4748/bitlockererrorcr5.png
    http://img219.imageshack.us/img219/7908/bitlockererror2jp2.png

    My specs:

    • Windows Vista Ultimate (64-bit) RTM
    • Chipset (on board) Intel Mobile 945PM Express ChipsetMobile Intel® 945PM + ICH7M (v8.1.1.1010)
    • RAID Controller - VIA VT6421 RAID Controller driver and VIA RAID Config Utility (v5.40A)
    • 2 x Western Digital 160GB SATA
    • Filesystem: NTFS
    Saturday, March 10, 2007 9:17 PM
  • Raid 0 is a problem with bitlocker as every time the os starts it will see drives changed as the data is spanned accross 2 drives.

    I would use 1 drive for bitlocker and span data drive only

     

    Wednesday, March 14, 2007 4:18 PM
  • Hello JAYTF,

        I am glad to finally hear from someone. I was suspencting that my RAID arrangement could have something to do with it, but I am still puzzled. The same setup worked just fine before. My Vista caught a cold and I decided to reinstall it. I only started experiencing this problem after reinstalling.

        There are two reasons preventing me from using a separate drive for bitlocker: I only have 2 hard drives, and I need the extra speed provided by RAID on my Windows drive.

        With that being said, I am wondering it it's some sort of setting I need to make, or if I will need to wait for a BitLocker update.

    Sincerely,

    Alex G.

    Just in case this might help, I've checked Event Viewer and found the following warnings related to BitLocker:

    "An attempt to automatically restart conversion on volume C: failed."

    "Metadata commit: Metadata update could not be flushed."

    Anyone knows what that means, and if there is a way to "fix" these errors?

    Wednesday, March 14, 2007 8:10 PM
  • Everyone,

    I really need a solution and do not know where else to turn. I've searched the entire Internet, and came up with nothing. If you have the slightest clue on how to fix this, or what those errors mean, please take a few minutes to explain.

    Thanks in advance!

    Sincerely,

    Alex G.

    Thursday, March 22, 2007 1:08 AM
  • You can not use Bitblocker on raid 0. If you need to encrypt the drives you will need addition 3rd party software.

    sorry

    You could add a 3 drive to your system

    boot with bitlocker on new drive and raid you data partion

    Thursday, March 22, 2007 9:27 PM
  • All of the Microsoft technical documents say that BitLocker fully supports hardware RAID, even RAID 0. I have a ticket open with Microsoft Support right now and will advise on the resolution when I get off the phone.

     

    BFG NVidia 680i

    4GB DDR2-8500

    Vista Ultimate 64-bit

    (6) 250GB Western Digital SATA2 drives in two RAID 5 arrays of (3) disks each. (C: & DSmile

    C: Drive is partitioned into 2 primary partitions ~6GB for BitLocker and ~460GB for the C drive volume.

     

    - Andrew

    Thursday, April 5, 2007 7:45 PM
  • Andrew,

     

    I really hope you and Microsoft can get to a resolution. Please do inform us of the conclusion reached, even if the issue isn't resolved. I am looking forward to getting BitLocker working.

    I almost gave up hope entirely until I saw your post. Hope to hear from you soon.

     

    Sincerely,

    Alex G.

     

    BTW, awesome system. Do you have 4 x 1GB, or 2 x 2GB modules?

    Monday, April 9, 2007 8:23 PM
  • Hi Andrew,

     

    did you get a solution from Microsoft?

    I have the same problem, the same error, also RAID 0 on a notebook, which would like to remain like this.

     

    Greetz

     

     

    Claus Greck

    Sunday, April 22, 2007 11:40 AM
  • Same issue Nvidia Nforce 570 ultra 1 160 + 1 250GB as Stripeset Raid 1 Vista ultimate Need help

     

    replay on itnetdesign@aol.com

     

    Thx

    Thursday, April 26, 2007 6:32 AM
  • did you hear already from MicSupport?
    Thursday, April 26, 2007 6:36 AM
  • Hi all,

     

    at least concerning MY problem with my VIARAID Controller with RAID 0  I have solved the problem on my own.

     

    When setting up the Bitlocker System Volume I tried it with 1.5 Gb, with 1.6 GB and at last with 2.0 GB (and I always had 137 GB free space on my VISTA Volume).

    But always I got the message that I have insufficient space and I should repair the volume with .... (unfortunately it was not written with what I should repair it  ). In the system log there were about 30-40 event messages 24612 " Commit of metadata failed ..........."

     

    Finally I just did a defragmentation of the volumes it with the VISTA embedded defrag tool, and what shall I say, I am just encrypting my drive (on a RAID 0 !!) at this moment, huuuhhhh  Smile

     

    So give this a try ....

     

     

     

    Greetings

     

     

    Claus

     

     

    Saturday, April 28, 2007 8:55 PM
  • I have tried defragmenting, but it didn't work.
    Tuesday, May 22, 2007 12:28 AM
  • I believe that the problem most of us are facing comes not from a problem with Bitlocker, but rather from the integrated RAID controllers. These controllers are really "hybrid controllers"(nVidia Technical support), meaning that, although they act as a hardware controller, the calculations and control take place within the CPU, not the controller itself. This merely means that they are software RAID controllers. Of course, the OS should be oblivious to this, and still treat it as a hardware controller.

    I know I had bitlocker working before, but I was not able to re-encrypt the drive after re-installing Vista. After more than two months of research on the matter, I was not able to solution the problem. I can only hope that the upcoming Vista Service Pack will change things.

    Wednesday, June 6, 2007 12:36 AM
  • Something very interesting happened. I've added a third drive to my computer, morphed my RAID 0 array from 2 drives to 3 drives, and turned on BitLocker. Now it is encrypting my drive without a problem. Any idea to why this happens?

    Sunday, October 14, 2007 2:15 AM
  • There is a solution, but it works in another way you had done.
    You have to add a third drive to ur array controller(not in motherboard`s bios mode, but in array card`s bios or it didnt work) as a single drive.
    I have a 3 x raid0 250GB + single 640GB, and as u can notice on screen it work`s Smile

    http://img294.imageshack.us/img294/6600/39305667io2.jpg
    http://img387.imageshack.us/img387/5853/47708966kq5.jpg

    And what i like with Bitlocker, there is no performance drop Smile only 10% more CPU usage.

    http://img262.imageshack.us/img262/337/37710006gh0.jpg
    Friday, September 19, 2008 10:34 AM