locked
Internal Error in the .Net Runtime and clr.dll fault module RRS feed

  • Question

  • I have noticed a potential fix for these two sets of event logs.http://support.microsoft.com/kb/2640103. Our ImageRight is a third-party application. The application is on a Citrix hosted terminal server running windows 2008 R2 server OS. We are on .Net 4.5 Framework, Not sure what causes the application to crash, but a restart seems to fix things, it happens towards the end of the day. A question we have is the above hotfix is a potential fix, but that is for 4.0, and I have seen some folks uninstall 4.5, install 4.0, then install the hotfix, then run MS updates which upgrades .Net back to 4.5 and things seem to work. My question is what does this hotfix change, since we want to go to .Net 4.5 wouldn't the hotfix get taken off and .Net 4.5 replace the dlls the hotfix would have updated?

    Faulting application name: imageright.desktop.exe, version: 5.7.7.1678, time stamp: 0x5332a927

    Faulting module name: clr.dll, version: 4.0.30319.18444, time stamp: 0x52717e84

    Exception code: 0xc0000005

    Fault offset: 0x000a6d27

    Faulting process id: 0x5714

    Faulting application start time: 0x01cff8ccedae8d2b

    Faulting application path: C:\Program Files (x86)\ImageRight\Clients\imageright.desktop.exe

    Faulting module path: C:\Windows\Microsoft.NET\Framework\v4.0.30319\clr.dll

    Report Id: 479ab52a-64c0-11e4-912c-0050569c5ee7

    Application: imageright.desktop.exe

    Framework Version: v4.0.30319

    Description: The process was terminated due to an internal error in the .NET Runtime at IP 6AA56D27 (6A9B0000) with exit code 80131506.

    Friday, November 14, 2014 5:50 PM

All replies

  • Hi,

    I am experiencing the same issue. @ asnjduarte1234 did you manage to resolve this?

    Friday, July 10, 2015 10:43 AM
  • I'm also experiencing this error. Did either of you have any joy?
    Monday, July 27, 2015 9:55 AM
  • Same problem for us. We use provisioned Citrix terminal servers and once this problem occurs you can only solve it with a server reboot.

    Tried various hotfixes, but most were not applicable and the rest made no difference at all. Also tried to install .Net 4.6 RC, no change.
    The servers are Windows 2008 R2 Standard with all security updates. Installing recommended an optional updates for .Net 4 increased the problem even further.

    We have several applications and also have some Office plugins that are based on .Net 4.x and they all stop working -.-

    We really need a fix for this, thanks!

    Tuesday, July 28, 2015 9:29 AM
  • Same problem here at XenApp 6 using Framework 4.5 Application.

    The more sessions and Memory is used the more it is getting unimpossible to start the application.

    Is it a GC problem or what?

    Please fix it !!!


    • Edited by foxxed Monday, August 3, 2015 11:31 AM
    Monday, August 3, 2015 8:26 AM
  • Tested the final release of .Net 4.6 (https://www.microsoft.com/en-US/download/details.aspx?id=48137) but it did not solve the problem.

    What I can say, is that it does not depend on how many users are logged in, but on the memory. I wrote a single C# application which fills the memory with random objects, deletes them afterwards and creates new ones. This is to give the GC  a hell lot of work to do as it has to manage millions of objects.

    After a while (1-3 hours), I can no longer start the other .Net 4 applications. The funny thing is that my application is based on .Net 4.5 ... and it still works and can also be restarted without any problems.

    All tests were made with a single user (local administrator) and no one else logged in. The Citrix server has a total of 8GB memory.

    Hope this information is somehow useful for finding and fixing the GC problem. Maybe this thread would get more attention if it was posted in another forum section?

    Wednesday, August 19, 2015 9:39 AM
  • I have exactly the same problems with the same environment then ennimaniac.  The problems look like beginning after the last application of security patch for Windows Server 2008.  We have the problems with Dynamics 2013 users on Citrix.

    For the moment I don't have any solutions.

     
    Friday, August 28, 2015 10:12 PM
  • I ran into a similar issue and it turned out to be the new Runtime JIT compiler released with .NET 4.6. Here is an article I found that resolved my issue. Worth a squint. Good luck.

    https://github.com/Microsoft/dotnet/blob/master/docs/testing-with-ryujit.md

    Monday, June 20, 2016 10:46 PM