none
.Net framework 4.6.1 problems with SCCM 2012 R2 SP1 on Windows 2008 R2 RRS feed

  • General discussion

  • I had an interesting 24 hours with SCCM in our organisation.... Long story.. I will try to keep it short.

    We have a standalone primary SCCM 2012 R2 SP1 running on Windows server 2008 R2 with a dedicated SQL Server 2008 R2 back end.

    Yesterday I was trying to install SCUP 2011 on the above SCCM server. As part of the wizard I was asked to install KB2530678. It looks like something went wrong with that hotfix installation which I did not notice at that time and hence I continued with SCUP installation. It was much later that I realised that WSUS had gone belly up. It was throwing error when launching the WSUS console, at the same time there were Site Status error messages on SCCM console monitoring tab. So I tried to uninstall WSUS role (with the intention of reinstalling it) and it is during this time things started to take interesting turn. After selecting all the appropriate options (WSUS location, backend server, port/url selection etc.) during the middle of installation, the wizard threw an error with no specific useful error message. The log file had errors discussed in this thread but it wasn't specifically related to that problem. Repeated installation attempts of WSUS (even with reboots) did not make the situation any better. So I contacted Microsoft support.

    The engineer initially tried various dcom/iis permissions and coudn't find anything obvious. So he suggested moving the WSUS/SUP role to another server which wasn't an ideal option for us. We continued trawling through the enormous WSUS installation logs. During this stage one particular entry in the log caught my eyes. As you can see in the below screenshot, the WSUS installer attempts to run a MSI custom action in the middle of the wizard which makes use of InstallUtil.exe which is present under .net framework. When we manually browsed to that location, that folder C:\Windows\Microsoft.Net\Framework64\v4.6.1055 did not exist on the system.

    And then I suddenly remembered that last month while troubleshooting this issue we had installed all the latest .net framwork updates (including 4.6.1) though those updates did not resolve the problem, they did not seem to cause any harm to the server so we left them as they were (By the way it was only the R2 SP1 CU2 which resolved that Admin console problem later on).

    Coming back to the WSUS/4.6.1 issue, I also remembered from a recent Windows IT Pro article about .Net 4.6.1 update causing problems in the Exchange world. So I told this to the Microsoft engineer and we decided to remove 4.6.1 from the server. When we removed it, it also took the whole .net 4.0 with it. So we had to reinstall .net 4.0.

    After this, the above WSUS installation problem disappeared, completed the wizard and the SUP successfully synchronised with WSUS and everything started working again.

    After sometime however I noticed that 3 other SCCM components (Application Catalog, App Catalog Service and Certificate Registration points) stopped working. It took us some time to realise that while removing 4.6.1 above, it took the whole of .net 4 with it, and as a result, all the IIS web applications associated with .net 4.0 app pools were relegated to .net 2.0 app pool. IIS itself seemed to be working fine (as SCCM MP was working ok). I have to thank the Microsoft engineer for identifying this. The other option would have been to reinstall those 3 roles which wasn't an ideal option.

    So, once we reverted the app pool .net versions to 4.0 all the 3 components started working again. There was another issue that I faced with where WSUS app pool was entering into stopped state. But this blog helped me resolve it. It's working ok for now but I am keeping an eye on it. So, overall, it was really an interesting day for me.

    So the 2 big lessons I learnt from this are

    1. .Net Framework 4.6.1 has problems which can cause issues with SCCM (who knows, it could be affecting many other products, as we already know Exchange is one of them).

    2. While uninistalling .Net framework special care should be taken to make sure the existing IIS app pools are not affected.

    Just thought of sharing my experience so it can help others who may encounter this situation, mainly the .net 4.6.1



    Wednesday, March 2, 2016 8:27 PM