Add-AppvClientPackage fails with error 0C80070002 RRS feed

  • Question

  • I'm using this powershell command to add and publish AppV packages:

    Get-ChildItem "\\usdcwisln01.edc.nam.gm.com\a-avf101-data-p\appv_packages\" -recurse -force -include *.appv | Add-AppvClientPackage | Publish-AppvClientPackage –global

    The Add-AppvClientPackage command is failing for certain packages with the following error:

    Add-AppvClientPackage : Application Virtualization Service failed to complete requested operation.
    Operation attempted: Configure AppV Package.
    AppV Error Code: 0C80070002.
    Error module: Streaming Manager. Internal error detail: 74F00F0C80070002.
    Please consult AppV Client Event Log for more details.
    At C:\Scripts\AppV_SCS_test.ps1:11 char:2
    +     Add-AppvClientPackage $package.fullname
    +     ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
        + CategoryInfo          : InvalidResult: (:) [Add-AppvClientPackage], ClientException
        + FullyQualifiedErrorId : ConfigurePackageError,Microsoft.AppV.AppvClientPowerShell.AddAppvPackage

    In the Event Viewer, Event ID 14010 is displayed with the following message:

    The package {6cf54d97-dc47-46dc-9fbc-faa318b41312} version {980ae1d0-9aaf-4029-bb34-28f13cc70f69} could not be configured because the path \\usdcwisln01.edc.nam.gm.com\a-avf101-data-p\appv_packages\appv_packages\appv_packages\Oracle11gClient\OracleClient11G_2.appv could not be reached.  Ensure the path is correct and try again.

    The path displayed in the error message is no the correct path.  The path I provided to powershell was  \\usdcwisln01.edc.nam.gm.com\a-avf101-data-p\appv_packages\appv_packages\appv_packages\Oracle11gClient\OracleClient11G_2.appv, but you can see in the error the appv_packages folder was repeated in the path a couple times.

    Any insight would be appreciated.

    Thursday, July 11, 2013 8:36 PM

All replies

  • What is your package source root and package installation roots set to in HKLM\Software\microsoft\AppV\Client\Streaming

    If you add the package simply using the UNC path as a -path argument to Add-AppVClientpackage, does it work?

    Steve Thomas, Senior Consultant, Microsoft

    App-V/MED-V/SCVMM/Server App-V/MDOP/AppCompat

    The App-V Team blog: http://blogs.technet.com/appv/
    The MED-V Team Blog: http://blogs.technet.com/medv
    The SCVMM Team blog: http://blogs.technet.com/scvmm/

    “This posting is provided "AS IS" with no warranties, and confers no rights. User assumes all risks.”

    Friday, July 12, 2013 3:03 PM
  • Package source root:  \\usdcwisln01.edc.nam.gm.com\a-avf101-data-p\appv_packages\

    Package Installation Root:  D:\AppVcache

    I ran this single command with several different packages and they all failed with the same error:  Add-AppvClientPackage -path "\\usdcwisln01.edc.nam.gm.com\a-avf101-data-p\appv_packages\Oracle11gClient\OracleClient11G_2.appv"

    I ran process monitor and confirmed that AppVClient.exe is making a call to an invalid directory:

    Date & Time: 7/12/2013 1:11:00 PM
    Event Class: File System
    Operation: CreateFile
    Result: NAME NOT FOUND
    Path: \\usdcwisln01.edc.nam.gm.com\a-avf101-data-p\appv_packages\appv_packages\appv_packages\Mozilla Firefox\Mozilla Firefox.appv
    TID: 7316
    Duration: 0.0001078
    Desired Access: Generic Read
    Dis"Apple-tab-span" style="white-space:pre;"> Open
    Options: Non-Directory File
    Attributes: N
    ShareMode: Read
    AllocationSize: n/a
    Impersonating: NAM\LS_cz9zf9

    Where is it pulling that path from?

    Friday, July 12, 2013 5:16 PM
  • The path is the same that is referenced in the PS command.
    Monday, July 15, 2013 6:25 PM
  • Does the output of

    Get-ChildItem "\\usdcwisln01.edc.nam.gm.com\a-avf101-data-p\appv_packages\" -recurse -force -include *.appv

    already show any difference.

    In fact it seems that PacakgeSourceRoot causes the issue. Does it work if you shorten or remove the PackageSourceRoot registry value?


    Twitter @kirk_tn   |  Blog kirxblog   |  Web kirx.org

    Tuesday, July 16, 2013 11:42 AM
  • Get-ChildItem returns the correct path:

    PS C:\Users\LS_cz9zf9> Get-ChildItem "\\usdcwisln01.edc.nam.gm.com\a-avf101-data-p\appv_packages\" -recurse -force -incl
    ude *.appv

        Directory: \\usdcwisln01.edc.nam.gm.com\a-avf101-data-p\appv_packages\Oracle11gClient

    Mode                LastWriteTime     Length Name
    ----                -------------     ------ ----
    -a---          7/9/2013   2:34 PM  621318485 OracleClient11G_2.appv

    I tried shortening and completely removing the PackageSourceRoot key and get the same error with the incorrect path.  I also uninstalled/reinstalled the AppV client to make sure the incorrect path wasn't cached somewhere.  Same error after fresh installation of 5.0 and 5.1.

    Tuesday, July 16, 2013 1:00 PM
  • Hello,

    I just experienced the same problem. My package installation root is also D:\Appv.

    I fixed it by creating a D:\Temp folder.  I cannot explain why....

    Hope this helps


    Wednesday, October 30, 2013 3:46 PM
  • Import-Module -Name AppvClient
    $appvloc = "\\Srv-fs01\software\AppVPackages"
    $loc = Get-ChildItem $appvloc  -Recurse -Filter *.appv
    #Set-AppvClientConfiguration -EnablePackageScripts $true
    foreach ($package in $loc)
    $appv = Add-AppvClientPackage -PSPath $package.PSPath
    Publish-AppvClientPackage $appv
    #Stop-AppvClientPackage -PackageId $appv.PackageId -VersionId $appv.VersionId

    #Unpublish-AppvClientPackage -PackageId $appv.PackageId -VersionId $appv.VersionId

    #Remove-AppvClientPackage -PackageId $appv.PackageId -VersionId $appv.VersionId

    • Edited by dsmanneke2 Wednesday, May 4, 2016 9:16 AM
    Wednesday, May 4, 2016 9:14 AM
  • Just curious, did you sequence both Firefox and the Oracle client on the same VM, and the VM snapshot was taken while the VM was running?
    Wednesday, July 6, 2016 5:38 PM