none
Power Query "From Web" not working RRS feed

  • Question

  • It seems ever since the last couple of updates, I am no longer able to use the "From Web" functionality like before and I don't know what the problem is.  When I access the below link, I receive the below error.  This link is an intranet link that requires credentials.  I have been able to utilize internal links before and Power Query would ask me for my credentials.  That is not happening anymore.

    DataSource.Error: Web.Contents failed to get contents from 'https://starship-abc.somecompany.com/BFI1/ExSD?yAxis=PROCESS_PATH&zAxis=WORK_POOL&shipmentTypes=CUSTOMER_SHIPMENTS&_shipmentTypes=on&exSDRange.quickRange=TODAY&exSDRange.dailyStart=00%3A00&exSDRange.dailyEnd=00%3A00&bucketSize=ONE&giftOption=ALL&fulfillmentServiceClass=ALL&fracs=ALL&workPool=ReadyToPick&workPool=PickingNotYetPicked&workPool=CrossdockNotYetPicked&_workPool=on&workPool=PickingPicked&workPool=Inducted&workPool=RebinBuffered&workPool=Sorted&workPool=GiftWrap&workPool=Packing&workPool=Scanned&workPool=ProblemSolving&workPool=ProcessPartial&workPool=SoftwareException&workPool=Crossdock&workPool=PreSort&workPool=TransshipSorted&workPool=Palletized&_workPool=on&_workPool=on&processPath=&shipMethod=&shipOption=&sortCode=&fnSku=' (302): Found

    To test further, I tried an external link and it does work.  I was able to extract a table from http://en.wikipedia.org/wiki/List_of_states_and_territories_of_the_United_States.

    What can I do?  I need this to work like it did before.

    Thank you,

    Jessica

    Friday, September 26, 2014 3:56 PM

Answers

All replies

  • Hi,

    It seems like your data source is offline...

    Try accessing this address manually from browser , or ping it from CMD:

    https://starship-abc.somecompany.com

    Sunday, September 28, 2014 2:31 PM
  • I think to diagnose this problem we'd need a network trace. Are you familiar with Fiddler or some other way to capture your HTTP traffic?

    Wednesday, October 1, 2014 1:18 PM
  • Just to be clear, I provided a fake URL to protect the company I work for.  I am able to access the URL just fine through my browser. 

    I am not able to get an answer when I research error code 302 on the internet.  What does this mean? 

    I have removed Power Query and re-installed it but get the same result.  I think something has become corrupt.

    Wednesday, October 8, 2014 7:27 PM
  • http://en.wikipedia.org/wiki/HTTP_302

    As I said, this is next-to-impossible to diagnose without a network trace.

    Thursday, October 9, 2014 4:12 PM
  • I have the same problem with the same response code of 302. I can access my URL with Firefox, with plain IE 11..... and with native Excel/Data/FromTheWeb.

    • Wikipedia says "The HTTP response status code 302 Found is a common way of performing URL redirection" What does Excel think it is?
    • What, exactly, will a network trace, tell you?
    • How, exactly, should I perform this trace?

    Thanks... Bob

    Friday, March 18, 2016 9:55 PM
  • Same issue here.  It has to do with security, but I can see the page just fine in IE and also Web query from Excel.  However I also get the same 302 error as above.  I've tried every variation of connection property I could think of, to no avail.

    Fundamentally, the issue is that IE somehow knows that I've signed into the site (through a cookie, I'm guessing, since there is no security token in the url)  So the old web query is somehow recognizing the cookie, while Get Transform is not.

     "Web.Contents failed to get contents from 'http://www.xxxxxx.gov/xx/showxxx.do?PanelID=xxxxxx' (302): Found"

    Wednesday, July 19, 2017 4:01 PM