locked
SharePoint Error when accessing page. RRS feed

  • Question

  • I am new to sharepoing, just starting.

    I installed SharePoint 2010 Server on my Windows 7 machine..

    i am just going through some tutorials, when i try to access a page on my test sharepoint site...i get the error

    Could not load file or assembly 'Microsoft.SharePoint, Version=14.0.0.0, Culture=neutral' or one of its dependencies. The system cannot find the file specified.

     

    Troubleshoot issues with Microsoft SharePoint Foundation.

    Correlation ID: 39445602-0039-4d28-8e09-46770e67d0dc


    I am getting same error even when i use console application just for testing..it seems like its not able to find the assembly..it is there, i have referenced it in my project and project does build and deploy without error.

     

    Saturday, December 3, 2011 11:01 PM

All replies

  • Hi,

    Go to Run. Type assembly. This will open the GAC. Check if Microsoft.Sharepoint dll is there or not. If it is not in the GAC then go to

    12Hives folder and then open ISAPI folder. There you will find the Microsoft.SharePoint dll. Copy this dll to GAC.

    DO IISReset and then open your web.config of the web application

    Check if you have a safe control entry for this dll.

    If it is there then its fine else make the following entry in the <SafeControls> tag

    <SafeControl Assembly="Microsoft.SharePoint, Version=11.0.0.0, Culture=neutral, PublicKeyToken=71e9bce111e9429c" Namespace="Microsoft.SharePoint" TypeName="*" Safe="True" AllowRemoteDesigner="True"  />
    

    Do iisreset.

    Please let me know if it still doesnt work.

    Sunday, December 4, 2011 4:59 AM
  • typing assembly in Run did not open GAC.

    However, I did check the C:\Windows\assembly folder and all the Microsoft.SharePoint.*.dlls are there.

    As far changing web.config is concerned. I dont have one in my project. I am sorry I am just starting to learn sharepoint and using the step by step tutorials in a book. I am using an empty sharepoint project and building and deploying a page and accessing it from the site. The page shows up in the list of pages, but when i access it throws that exception.

     

     

    Monday, December 5, 2011 2:17 AM
  • Hi,

    is the error is related to only this page? If yes then delete this page and create a new one.

    If a web application is created a site will be created in IIS and a web config must have created.

    Go to IIS and then select the correct site and click properties it will take you to the location where your web.config is stored.


    Thanks, Rahul Rashu
    Monday, December 5, 2011 2:59 AM
  • Can you once take a backup of your web.config and then edit your web.config using visual studio by inserting the following entry in safecontrols section and do iisreset

    <SafeControl Assembly="Microsoft.SharePoint, Version=11.0.0.0, Culture=neutral, PublicKeyToken=71e9bce111e9429c" Namespace="Microsoft.SharePoint" TypeName="*" Safe="True" AllowRemoteDesigner="True"  />
    

    Monday, December 5, 2011 3:10 AM
  • Actually, following the instruction in the book that i am using I had not really created a new web application, rather a blank site using SP Designer..so there was no seprate web application in the IIS, but i did find that other web application that i had added earlier did have the SafeControl tab in it.

    I tried to add a new web application but it did not work,......assuming that I might have messed up the configuration somewhere by playing around too much with Central Administration..I reinstalled SharePoint 2010 (supposed to be the mother of all solutions) as it was not working as expected when I tried to add a new web application. The new problem is that It is not giving the options under Service Application Connections section of new web application dialoge(see image below).. Please advise as to what has gone wrong now.

     

    Monday, December 5, 2011 10:05 PM