locked
WSUS MMC stopped working RRS feed

  • Question

  • Hello

    The MMC worked fine for a few days, and then suddenly started showing me this: https://i.imgur.com/XUtOPL3.png
    Rough translation: MMC cannot create the snap-in. The snap-in may not be installed correctly.
    I tried removing the snap-in and installing it again (each time it requires me to unplug myself from our WSUS server). It didn't help.
    Luckily I have access to the WSUS server itself and can manage it, but having a working MMC for it would be very convenient ;)

    Any thoughts on how to fix this?

    Thursday, June 27, 2019 11:34 AM

All replies

  • Hi,

    I often face a similar problem like this when the WSUS Server is busy working on several tasks - for example WSUS Cleanup.

    Here you also should have the button to "Reset Node" in the bottom left.

    Can you make sure that no other admin has started a wsus cleanup task without letting you know ?

    regards, patrick

    Thursday, June 27, 2019 12:18 PM
  • I'm the only admin here, no cleanup task active. And no "Reset node" button :(

    I noticed that no matter if the snap-in is installed or not, i see the same message. I guess the snap-in somehow got corrupted or removed and is not able to install again. 

    Thursday, June 27, 2019 1:23 PM
  • Hi Stanisław Smólski,
      

    If you have other WSUS servers in your environment, open the registry from these WSUS servers, navigate to the following key, and export it:
      

    • HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MMC\SnapIns\FX:{8b6499ed-0241-e032-6508-da4b1c879d7e}\Type
        

    Then import it into the WSUS server registry where the MMC issue occurs and check if this fixes the problem you are experiencing.
      

    If there are no other WSUS servers in your environment, the following is the TYPE key value in my environment (WSUS 10.0.14393.2007), please refer to the modification:
      

    • Microsoft.UpdateServices.UI.SnapIn.Common.SnapInManager, Microsoft.UpdateServices.UI.SnapIn, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35
        

    Hope the above can help you.
      

    Regards,
    Yic

    Please remember to mark as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Friday, June 28, 2019 2:14 AM
  • Thank you, now i know where the WSUS MMC files are stored, i wasn't sure they are instaled. But all registry values look ok to my untrained eye ;) and all of the files seem to be present in C:\Program Files\Update Services\

    https://i.imgur.com/vNrgKJ3.png

    edit: It's clearly issue with this Windows 10 Pro (1903) I'm working on, the snap-in on the WSUS server itself works.
    Friday, June 28, 2019 6:53 AM