locked
Exchange 2010 MP Synthetic Transactions on OpsMgr 2012 fails on some CAS servers but not all. RRS feed

  • Question

  • Hi,

    I've imported the Exchange 2010 MP and ran the New-TestCASConnectivityUser.ps1 on a mailbox server. The testuser and mailbox is created fine, even though I get the warning message "The command completed successfully but no settings of <user account> have been modified." - Not sure if its an issue related to my problem. We have 3 mailbox servers and 3 CAS+HT servers in our enviroment.

    Two out of three CAS servers fail to run the synthetic transactions ActiveSync, Outlook Web App, and Exchange Controlpanel. CAS server #1 reports no problems running the transactions, while server #2 and #3 gives me warnings.

    The errors I get is:

    The test mailbox was not initialized. Run new-TestCasConnectivityUser.ps1 to ensure that the test mailbox is created. Detailed information: Local Site:SiteShared [Microsoft.Exchange.Monitoring.CasHealthCouldNotLogUserException]: The task couldn't sign in with user <Test user>. Run Scripts\new-TestCasConnectivityUser.ps1 to verify that the user exists on the Mailbox server <Server> To run this task without credentials, sign in as a Domain Administrator. Detailed error information: 1326 Diagnostic command: "Test-OwaConnectivity -TestType:External -MonitoringContext:$true -TrustAnySSLCertificate:$true -LightMode:$true"

    I've tried to do as stated in the alert on the server stated in the errormessage, but no luck. It seems like the credentials isnt distributed across the CAS servers?

    Tuesday, June 25, 2013 7:32 AM

All replies

  • Please double-check the configurations or re-create test mailbox referring to the following document:

    Optional Configurations

    http://technet.microsoft.com/en-us/library/ee758052(v=exchg.140).aspx

    Thanks.


    Nicholas Li
    TechNet Community Support


    • Edited by Nicholas Li Wednesday, June 26, 2013 4:34 AM
    • Marked as answer by Nicholas Li Friday, July 5, 2013 9:08 AM
    • Unmarked as answer by caskphm Tuesday, August 27, 2013 10:05 AM
    Wednesday, June 26, 2013 4:33 AM
  • Hi Nicholas,

    I unmarked your post as an answer. The post did unfortunately not help, I still face the issue. 1 of 3 CAS servers runs fine, but the last two gets the error stated above.

    The CAS and MBX servers reside in the same domain, so that should not be a problem. Besides that, I have tried to run the New-TestCASConnectivityUser.ps1 on one mailbox server and on all of them, no difference :/

    Tuesday, August 27, 2013 10:08 AM
  • Hi,

    What if you delete the mailbox in AD/Exchange, wait few minutes, then run the new-TestCasConnectivityUser.ps1 again?


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Tuesday, August 27, 2013 10:49 AM
  • Hi,

    Thanks for your answer.

    Tried that several times. I waited long enough to see another error ("Couldnt find the user in AD") on all three CAS servers, ran the script again and saw the same pattern; Works on one CAS server, does not work on the two others :/

    Tuesday, August 27, 2013 11:39 AM