locked
Why is Windows 8 Windows Explorer so slow on Refresh? RRS feed

  • Question

  • I've experienced this problem a couple of times in the last few days (ie. since the last Windows Update):

    1. I open Windows Explorer - it is almost empty. It just contains Favorites, Libraries, Computer and Home Group

    2. When I click on the Computer it attempts a refresh (green bar), but it take ages. It is quicker to restart the computer.

    Does anyone have any suggestions?

    Will

    Rant: Please, please, please do NOT attempt to do automation unless you're very smart. Most of the time these automation features do things that I don't want or need, and mostly they're the wrong thing anyway. A good example of this sort of nonsense is the automated doors in UK trains which never open when you want them (so they've got a open button as well) and then close when you're half way through the door. A lot of software suffers from similar bad design!


    will stott

    Thursday, June 6, 2013 11:27 AM

Answers

  • Hi,

    The issue may related with third party tools or too many service running background.

    I suggest to logon with Safe Mode or Clean boot to see if the same issue occurs:

    http://support.microsoft.com/kb/929135

    If the issue persists, you can also try to create anther administrator account and login for test.

    Furthermore, you can perform a system restore.

    Hope that helps.


    Leo Huang
    TechNet Community Support

    • Marked as answer by Leo Huang Tuesday, June 18, 2013 7:36 AM
    Friday, June 7, 2013 8:34 AM
  • Rant: Please, please, please do NOT attempt to do automation unless you're very smart. Most of the time these automation features do things that I don't want or need, and mostly they're the wrong thing anyway. A good example of this sort of nonsense is the automated doors in UK trains which never open when you want them (so they've got a open button as well) and then close when you're half way through the door. A lot of software suffers from similar bad design!

    I'm curious specifically to what you're referring here...  The "automation" that is embodied in the abstraction of Libraries?

    There's quite a lot in Windows 8 that can be tweaked or turned off, generally to good benefit and without loss of utility (e.g., turn off Homegroup, avoid using Libraries).  It stabilizes and makes more efficient one's Windows 8 desktop experience to avoid these things.  I'm not sure these things are what you're talking about, but certainly there's a lot that can be configured to make Windows 8 more tolerable.

    Try changing this setting in Folder Options, then reboot.

    Also, try starting File Explorer from a shortcut that contains this command line:  C:\Windows\explorer.exe /select,C:\

     

    Finally, it's a good idea to review all your Shell Extensions that you have installed.  This is a good free tool for listing them, and potentially disabling them methodically to see if they're affecting your responsiveness:

    Shell Extensions Viewer:  http://www.nirsoft.net/utils/shexview.html

    I have a fully updated Windows 8 system which is still instantly responsive, so it's possible - it's not a systemic thing everyone's experiencing.

    Good luck.

     

    -Noel


    Detailed how-to in my eBooks:  

    Configure The Windows 7 "To Work" Options
    Configure The Windows 8 "To Work" Options

    • Marked as answer by Leo Huang Tuesday, June 18, 2013 7:36 AM
    Friday, June 7, 2013 5:40 PM

All replies

  • Hi,

    The issue may related with third party tools or too many service running background.

    I suggest to logon with Safe Mode or Clean boot to see if the same issue occurs:

    http://support.microsoft.com/kb/929135

    If the issue persists, you can also try to create anther administrator account and login for test.

    Furthermore, you can perform a system restore.

    Hope that helps.


    Leo Huang
    TechNet Community Support

    • Marked as answer by Leo Huang Tuesday, June 18, 2013 7:36 AM
    Friday, June 7, 2013 8:34 AM
  • Rant: Please, please, please do NOT attempt to do automation unless you're very smart. Most of the time these automation features do things that I don't want or need, and mostly they're the wrong thing anyway. A good example of this sort of nonsense is the automated doors in UK trains which never open when you want them (so they've got a open button as well) and then close when you're half way through the door. A lot of software suffers from similar bad design!

    I'm curious specifically to what you're referring here...  The "automation" that is embodied in the abstraction of Libraries?

    There's quite a lot in Windows 8 that can be tweaked or turned off, generally to good benefit and without loss of utility (e.g., turn off Homegroup, avoid using Libraries).  It stabilizes and makes more efficient one's Windows 8 desktop experience to avoid these things.  I'm not sure these things are what you're talking about, but certainly there's a lot that can be configured to make Windows 8 more tolerable.

    Try changing this setting in Folder Options, then reboot.

    Also, try starting File Explorer from a shortcut that contains this command line:  C:\Windows\explorer.exe /select,C:\

     

    Finally, it's a good idea to review all your Shell Extensions that you have installed.  This is a good free tool for listing them, and potentially disabling them methodically to see if they're affecting your responsiveness:

    Shell Extensions Viewer:  http://www.nirsoft.net/utils/shexview.html

    I have a fully updated Windows 8 system which is still instantly responsive, so it's possible - it's not a systemic thing everyone's experiencing.

    Good luck.

     

    -Noel


    Detailed how-to in my eBooks:  

    Configure The Windows 7 "To Work" Options
    Configure The Windows 8 "To Work" Options

    • Marked as answer by Leo Huang Tuesday, June 18, 2013 7:36 AM
    Friday, June 7, 2013 5:40 PM