none
SCCM all content on DP succesfully distributed but status shows error

    Question

  • Hi i have a problem with SCCM 1702, I configured  separate distribution point,  on  installation of DP, distributing  4 items completed with error , then i manually redistributed this 4 items to my newly deployed DP, Items succesfully distributed  but DP complation statistics  shows  Failed: -4, I uninstalll and install DP many times but didint work;

    Thursday, March 30, 2017 9:50 AM

All replies

  • Have you reviewed error detail information?

    If you deploy contents to clients, will the DP work for client to get contents?

    Have you reviewed distmgr.log and pkgxferMgr.log?


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Friday, March 31, 2017 2:33 AM
    Moderator
  • https://blogs.technet.microsoft.com/umairkhan/2014/10/02/the-case-of-the-unexplained-the-package-gets-distributed-successfully-but-does-not-show-in-the-console/

    Check this out this may help you though its something to do with the status update on the system.



    Kamala kannan.c| Please remember to click “Mark as Answer” or Vote as Helpful if its helpful for you. |Disclaimer: This posting is provided with no warranties and confers no rights

    Friday, March 31, 2017 4:43 AM
  • I have tried but didnt worked for me
    Friday, March 31, 2017 10:41 AM
  • As per Frank said, Have you verified distmgr.log and pkgxermgr.log ?

    Please click answer If it works Thanks KMI

    Friday, March 31, 2017 5:17 PM
  • We are also experiencing the same issue with 1702 where the statistics show Failed: -4. Have you made any progress on this?
    Monday, April 3, 2017 5:51 PM
  • Anything on this yet? We have the the same problem.
    Tuesday, April 25, 2017 10:59 AM
  • I've got exactly the same issue, new install of SCCM CB 1702 on Windows Server 2016, no other site servers set up initially, started adding/installing the DP's (also on Windows Server 2016) installed fine, but showing the exact same symptoms/status of error -4.

    Primary Site DP

    2 Additional DP's (notice the Failed -4)

    Looking at the content status (6 pacakges successully deployed to 3 DP's)

    no errors in either the distmgr.log or pkgxferMgr.log.

    Saying that I have just noticed that the no targeted is showing as 2 whereas on the primary DP its showing as 6, yet it has 6 successes on all three. looks like a bug

    Monday, May 22, 2017 7:30 AM
  • I found  this is SCCM 1702 bug and fixed in next update
    Wednesday, May 24, 2017 6:37 AM
  • I have the same issue. 

    Ramixes, where did you get this information about this being a bug and the upcoming fix?

    Sunday, June 4, 2017 2:10 PM
  • I have this issue as well. Did anyone find a fix or figure when Microsoft plans to release a fix? 
    Thursday, June 8, 2017 6:52 PM
  • Hi, the latest update for current branch 1702 has been released. If you're on 1702, just click Updates and Servicing, you'll see 1702 hotfix Rollup KB4019926

    https://support.microsoft.com/en-us/help/4019926/update-rollup-for-system-center-configuration-manager-current-branch-v


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.


    Friday, June 9, 2017 1:10 AM
    Moderator
  • I have to say I have installed the 1702 hotfix Rollup KB4019926, and it fixed it for new DP's however was still showing wrong for ones already added. luckily I hadn't deployed much content so removed and readded them and they are now all ok :)
    Friday, June 9, 2017 6:47 AM
  • Hi all,

    The information about the update specifies:

    The summary data that is displayed in the Distribution Point Configuration Status window is inconsistent between a CAS and Primary site. However, the details of the data are correct. To recover the Distribution Point that has this problem, run the following script:

    exec spRebuildContentDistribution 1

    Anyone able to run it? I have no clue how to run it

    Friday, June 9, 2017 7:38 AM
  • nope couldn't find any info on where to run it from, or where the script is located
    Friday, June 9, 2017 7:58 AM
  • this is a Stored Procedure. Open SQL Management Studio and connect to your CM database. Look in the section Programmability -> Stored Procedures.

    News from Forum

    • Proposed as answer by KL_2017 Friday, June 9, 2017 9:51 AM
    Friday, June 9, 2017 9:03 AM
  • running the command fixed it for me. Thanks!
    Friday, June 9, 2017 4:54 PM
  • This command fixed it for me too - all I had to do was paste it into a New Query window and Execute. Voila. Issue fixed. Thanks!

    Michael B Courville

    Thursday, June 29, 2017 3:26 PM
  • KL_2017 & aladin4711 - You guys are great.  How did you come across this command.  I followed the instruction of aladin4711 and it fixed my problem.

    I spent over 3 hours in the last 2 weeks to fix this issue.  Luck this afternoon, I came across this post and got the issue resovled.

    Just installed hotfix KB4036267 on CB1706.  All working fine.

    Thanks to everyone.

    Ram

    Sunday, September 10, 2017 7:52 PM
  • *SCCM 2012 Current Branch 1702 unique Primary Site.*

    I have the same problem above four distribution points (Windows Server 2016) that we created after upgrading to version 1702.

    To solve we can directly upgrade to version 1710, or is not necessary and then resolves simply by applying the "Stored Procedure" first?

    Currently in the SCCM SQL database I was unable to find the "Stored Procedure".

    Am I not able to find it, or will it be visible only after upgrade?

    \Store Procedure/

    Configuration Manager 1702 Hotfix Rollup(KB4019926)

    "https://support.microsoft.com/en-us/help/4019926/update-rollup-for-system-center-configuration-manager-current-branch-v"

    "Configuration Manager Console" section in the Microsoft article.

    Thank you all for the support.

    Friday, January 12, 2018 9:43 AM
  • Hi Michael,

    I ran the query "

    exec spRebuildContentDistribution 1 into the SQL DB and later the status was changed for all the DP's into Green.

    Thanks & Regards, Deepak

    Thursday, January 25, 2018 7:33 PM