none
FAILED updating DPM management shell to 3.0.7707 from 3.0.7696 RRS feed

  • Question

  • This has been a mess. 

    I have DPM 2010 installed with NO updates/hotfix. It's been running fine since i first installed it(when 2010 became available).

    Several weeks ago a VM can't be backed up from the host, and the suggestion i have is to install the hot fix. So, i did. Now, all my dpm related powershell script can't connect to the DPM server even when the script is ran locally. If i launched DPM management shell, the script would run. but if i launch a regular powershell window, the get-protectiongroup cmdlet will fail, warning me to make sure that the DPM service is running. 

     

    after further research, i found out that apparently i also need to update the management shell. The updater doesn't do it automatically.

    so, i downloaded the msp file from http://www.microsoft.com/download/en/details.aspx?displaylang=en&id=20953

    when running the file, it says:

    The upgrade patch cannot be installed by the windows installer service because the program to be upgraded may be missing, or the upgrade patch may update a different version of the program. verify that the program to be upgraded exists on your computer and that you have the correct upgrade patch.

    I issued the following command to find out what version is running on the shell

    get-wmiobject -computername servername win32_product -filter "Name = 'Microsoft System Center Data Protection Manager 2010'"|select version

    I'm getting : 3.0.7696.0

    So i thought maybe i need to upgrade it to 3.0.7706 first. So, i downloaded that update from here

    http://support.microsoft.com/kb/2250444

    but the MSP file is NOWHERE to be found after the extraction. 

    how do i solve this problem? this is killing me. My DPM gui console is at 3.7707. so are all my agents. 

     

    Tuesday, October 11, 2011 2:30 AM

Answers

  • Hi,

    I have duplicated the error in 3.0.7707.0 and confirmned that it works correctly in 3.0.7706.0.  Strange thing is that it works in 3.0.7707.0 if you connect to a remote DPM server, it just fails connecting to itself.

    This must be a regression, so I'll report it to the product group. 


    Regards, Mike J. [MSFT] This posting is provided "AS IS" with no warranties, and confers no rights.
    Tuesday, October 11, 2011 11:13 PM
    Moderator
  • Hi,

    Yes, sorry for the inconvience, you are the first user to report this problem.

    How to Install DPM Management Shell
    http://technet.microsoft.com/en-us/library/ff399369.aspx

     


    Regards, Mike J. [MSFT] This posting is provided "AS IS" with no warranties, and confers no rights.
    • Marked as answer by rickybud7 Wednesday, October 26, 2011 6:31 PM
    Wednesday, October 12, 2011 12:05 AM
    Moderator

All replies

  • Hi,

    1) The DPM Powershell update is only required if DPM SQL DB is hosted on another (remote) system.  If DPMDB is local, then the update does not apply. 
    2) get-wmiobject -computername servername win32_product -filter "Name = 'Microsoft System Center Data Protection Manager 2010'"|select version
           This will always return 3.0.7696.0 - so that is not the issue.
    3) If you have trouble running "Connect-DPMServer DPM_SERVER_NAME" from inside the DPM Powershell cmd window - then look in the c:\program files\Microsoft DPM\DPM\temp\DPMCLI0Curr.errlog to see why it is not connecting.

    If the GUI shows 3.0.7707.0 - then you have the latest update installed ok.


    Regards, Mike J. [MSFT] This posting is provided "AS IS" with no warranties, and confers no rights.
    Tuesday, October 11, 2011 2:39 PM
    Moderator
  • if i launch a powershell window, not the DPM powershell, but regular powershell, at the very first line is:

    Add-PSSnapin -Name 'Microsoft.DataProtectionManager.PowerShell'

    No error here. 

    if i issued this command:

    $pgList=get-protectiongroup dpmservername

    or 

    $pgList=get-protectiongroup dpmservername.domain.com

     

    this used to work flawlessly before i applied the hot fix.

    but now, it's throwing this error:

    Get-ProtectionGroup : Unable to connect to dpmmservername.domain.com. (ID: 948)

    Verify that the DPM service is running on this computer.

    At line:1 char:28

    + $pgList=get-protectiongroup <<<<  libxxvi

        + CategoryInfo          : NotSpecified: (:) [Get-ProtectionGroup], DlsException

        + FullyQualifiedErrorId : 948,Microsoft.Internal.EnterpriseStorage.Dls.UI.Cmdlet.ProtectionCmdLets.GetProtectionGr

       oup

     

    that's the problem i have. 

    Tuesday, October 11, 2011 6:00 PM
  • Hi,

    I have duplicated the error in 3.0.7707.0 and confirmned that it works correctly in 3.0.7706.0.  Strange thing is that it works in 3.0.7707.0 if you connect to a remote DPM server, it just fails connecting to itself.

    This must be a regression, so I'll report it to the product group. 


    Regards, Mike J. [MSFT] This posting is provided "AS IS" with no warranties, and confers no rights.
    Tuesday, October 11, 2011 11:13 PM
    Moderator
  • Thanks for your help Mike. this is not looking good for me though because i use DPM ps script nightly. is there anyway i can roll back the installation to 3.7706 so that the script would work again without breaking any other parts? all the agents are running 3.0.7707 now. 

    since it works if it's called remotely. how can i successfully use the DPM PS snapin in on a NON dpm server? is it possible? 

    Tuesday, October 11, 2011 11:53 PM
  • Hi,

    Yes, sorry for the inconvience, you are the first user to report this problem.

    How to Install DPM Management Shell
    http://technet.microsoft.com/en-us/library/ff399369.aspx

     


    Regards, Mike J. [MSFT] This posting is provided "AS IS" with no warranties, and confers no rights.
    • Marked as answer by rickybud7 Wednesday, October 26, 2011 6:31 PM
    Wednesday, October 12, 2011 12:05 AM
    Moderator
  • Mike, 

    is there any firewall port i should open for this shell to talk to my DPM server?

    I can only get the shell to talk to the DPM server remotely if i disable the firewall setting on the DPM server/

    Looking at firewall setting on dpm server, i saw that the following packet is being dropped:

    TCP port 49154, 49238 

    UDP 1434

    I tried enabling all the port and protocol above without any luck. 

    Wednesday, October 26, 2011 7:47 PM
  • Mike, 

    is there any firewall port i should open for this shell to talk to my DPM server?

    I can only get the shell to talk to the DPM server remotely if i disable the firewall setting on the DPM server/

    Looking at firewall setting on dpm server, i saw that the following packet is being dropped:

    TCP port 49154, 49238 

    UDP 1434

    I tried enabling all the port and protocol above without any luck. I had the same error when I join populated, DPM on my local server:
     Get-ProtectionGroup:" Unable to connect to dpm server name (ID: 948)
     Verify that the DPM service is running on this computer".
     But when I load a PowerShell as administrator on the local server, then everything works.
     But from a remote server, I can not join to the DPM server in PowerShell and get the error:
     "Unable to connect to dpm server name (ID: 948) Verify that the DPM service is running on this computer".
     I have installed DPM 2010 Rollup2 on Winserver 2008 R2.
     Is there currently a solution from Microsoft for this problem?


    Monday, June 18, 2012 8:43 AM
  • I had the same error when I join populated, DPM on my local server:
     Get-ProtectionGroup:" Unable to connect to dpm server name (ID: 948)
     Verify that the DPM service is running on this computer".
     But when I load a PowerShell as administrator on the local server, then everything works.
     But from a remote server, I can not join to the DPM server in PowerShell and get the error:
     "Unable to connect to dpm server name (ID: 948) Verify that the DPM service is running on this computer".
     I have installed DPM 2010 Rollup2 on Winserver 2008 R2.
     Is there currently a solution from Microsoft for this problem?
    Monday, June 18, 2012 8:44 AM