none
workflow manager installation and configuration issue RRS feed

  • Question

  • I am trying to install workflow maanger on my dev server for sharepoint 2013. I have followed TechNet articles . I have followed few other articles as well . but once I try to register the workflow using powershell . it throws error. sometimes it says'the remote server not found (404)'. sometimes it says 'an internal error occured '. and when I go to central admin it says
    "Workflow is Not Connected

    SharePoint 2013 workflow requires a compatible workflow service configured with SharePoint such as Workflow Manager" under workflow service in central admin. I have installed cumulative updates for service bus and workflow manager and then again tried the register command . still the same error.

    Its a development server , I have started user profile service , the account through which I am trying to install is farm account and the user profile is coming up in the user profile service as well.

    I just don't understand what the issue is .the logs are as follows:

    High     Microsoft.Workflow.Client.InternalServerException: An internal error occured. For more details, please see the server logs. Client ActivityId : a722ae87-baa6-4e18-98b5-8c5465ef3ac8. ---> System.Net.WebException: The remote server returned an error: (500) Internal Server Error.     at Microsoft.Workflow.Common.AsyncResult.End[TAsyncResult](IAsyncResult result)     at Microsoft.Workflow.Client.HttpGetResponseAsyncResult`1.End(IAsyncResult result)     at Microsoft.Workflow.Client.ClientHelpers.SendRequest[T](HttpWebRequest request, T content)     --- End of inner exception stack trace ---     at Microsoft.Workflow.Client.ClientHelpers.SendRequest[T](HttpWebRequest request, T content)     at Microsoft.Workflow.Client.WorkflowManagementClient.SendRequest[T](HttpWebRequest request, T content)   ... a722ae87-baa6-4e18-98b5-8c5465ef3ac8
    10/27/2015 10:58:22.01* PowerShell.exe (0x4A68)                  0x0E68 SharePoint Foundation          PowerShell                     6tf2 High     ...  at Microsoft.Workflow.Client.ScopeManager.Get()     at Microsoft.SharePoint.WorkflowServices.WorkflowServerPairingContext.RegisterFarm()     at Microsoft.SharePoint.WorkflowServices.PowerShell.RegisterSPWorkflowService.InternalProcessRecord()     at Microsoft.SharePoint.PowerShell.SPCmdlet.ProcessRecord() a722ae87-baa6-4e18-98b5-8c5465ef3ac8
    10/27/2015 10:58:22.01  PowerShell.exe (0x4A68)                  0x0E68 SharePoint Foundation          PowerShell                     91ux High     Error Category: InvalidData    Target Object  Microsoft.SharePoint.WorkflowServices.PowerShell.RegisterSPWorkflowService  Details  NULL  RecommendedAction NULL a722ae87-baa6-4e18-98b5-8c5465ef3ac8
    10/27/2015 10:58:22.04  PowerShell.exe (0x4A68)                  0x0E68 SharePoint Foundation          PowerShell                     6tf0 Medium   Leaving ProcessRecord Method of Register-SPWorkflowService. 9c82141a-0ff5-0001-a25a-849cf50fd101
    10/27/2015 10:58:22.04  PowerShell.exe (0x4A68)                  0x0E68 SharePoint Foundation          PowerShell                     6tf0 Medium   Entering EndProcessing Method of Register-SPWorkflowService. 9c82141a-0ff5-0001-a25a-849cf50fd101.

    please do reply .

    Tuesday, October 27, 2015 7:11 AM

All replies