none
An error has occurred while validating the configuration settings RRS feed

  • Question

  • I am getting the following error while trying to install SharePoint 2010 Beta on a 64-bit Windows 2008 Server for demoing purposes:

    "An error has occurred while validating the configuration settings.  An exception of type System.ArgumentNullException was thrown.  Additional exception information: The errorData argument cannot be null or zero length.  Parameter name: errorData"

    I have rebuilt this Windows 2008 Server 5 times now but still the SharePoint Products and Configuration Wizard fails.

    No amount of words can explain my frustration with the sub-standard error reporting in Microsoft products especially MOSS 2007 e.g. an "unexpected error has occurred" <- what use is that for troubleshooting? 
    It now looks like we are going down the same path with SharePoint 2010 error reporting.
    Friday, November 20, 2009 10:57 PM

Answers

All replies

  • Hi Wexford,

    you might want to check your firewall settings. Try to turn them off and retry to see if that helps.

    Greets,
    Frank
    Saturday, November 21, 2009 3:40 PM
  • Frank is probably right, indeed this problem has been reported last month by Steve Peschka; here is the post : http://blogs.technet.com/speschka/archive/2009/10/27/problems-joining-a-server-to-a-farm.aspx
    You should authorize sql server through the firewall...

    Serge Luca; blog: http://www.redwood.be Devoteam Belgium
    Saturday, November 21, 2009 4:24 PM
  • Frank, firewall was turned off before starting the installation of SharePoint.
    Monday, November 23, 2009 9:18 AM
  • Same problem here.  Target = Windows Server 2008 x64, completely clean, new installation of both the OS and SP Server, no other apps, and the firewall is disabled.  It appears to authenticate the database access account username & password, since if either is wrong it comes back right away with an appropriate error message.  This comes back after ~30 seconds of pondering. 

    I did install the KB update that it insisted on, but no other specific SP's or hotfixes. 

    Help!?!  Thanks.
    Monday, November 23, 2009 9:52 PM
  • I also have this same problem, clean machines, is therre an install log where i can get more information on the error?
    • Proposed as answer by Jonathan Drury Monday, November 23, 2009 10:06 PM
    Monday, November 23, 2009 10:01 PM
  • Good thought about the log.  I just looked at the Application log in the Event Viewer, and found this for each time I tried.  Looks like the key phrase is "Could not open a connection to SQL Server" (my highlight below).  I did not install SQL Server separately; I just used the instance of SQL Server 2008 Native Client that came along with the preparation tool.  I also don't see anything to manage or configure SQL Server Native Client.  Can someone out there confirm that this is correct? 

    Log Name:      Application
    Source:        Microsoft-SharePoint Products-SharePoint Foundation
    Date:          11/23/2009 4:17:02 PM
    Event ID:      5586
    Task Category: Database
    Level:         Error
    Keywords:     
    User:          [DOMAIN]\administrator
    Computer:      PS10Server.[DOMAIN].com
    Description:
    Unknown SQL Exception 2 occurred. Additional error information from SQL Server is included below.

    A network-related or instance-specific error occurred while establishing a connection to SQL Server. The server was not found or was not accessible. Verify that the instance name is correct and that SQL Server is configured to allow remote connections. (provider: Named Pipes Provider, error: 40 - Could not open a connection to SQL Server )
    Event Xml:
    <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
      <System>
        <Provider Name="Microsoft-SharePoint Products-SharePoint Foundation" Guid="{6fb7e0cd-52e7-47dd-997a-241563931fc2}" />
        <EventID>5586</EventID>
        <Version>14</Version>
        <Level>2</Level>
        <Task>3</Task>
        <Opcode>0</Opcode>
        <Keywords>0x4000000000000000</Keywords>
        <TimeCreated SystemTime="2009-11-23T21:17:02.356Z" />
        <EventRecordID>773</EventRecordID>
        <Correlation />
        <Execution ProcessID="1668" ThreadID="3924" />
        <Channel>Application</Channel>
        <Computer>PS10Server.[domain].com</Computer>
        <Security UserID="S-1-5-21-180556409-1961896859-627194967-500" />
      </System>
      <EventData>
        <Data Name="int0">2</Data>
        <Data Name="string1">A network-related or instance-specific error occurred while establishing a connection to SQL Server. The server was not found or was not accessible. Verify that the instance name is correct and that SQL Server is configured to allow remote connections. (provider: Named Pipes Provider, error: 40 - Could not open a connection to SQL Server)</Data>
      </EventData>
    </Event>
    Monday, November 23, 2009 10:12 PM

  • I had a similar problem recently whilst trying to install SharePoint Server 2010 Beta 2.

    WFE: Windows Server 2008 Enterprise x64
    Database Server: Windows Server 2008 Enterprise x64 + SQL Server 2008 R2 x64

    A colleague pointed out that it was probably because I had the SQL service (MSSQLSERVER) running under a domain account that was not registered with a Service Principle Name (SPN) and advised that I either give it one or run the service under the built in local account. We tried both methods on separate installations and both achieved the desired result.

    Saturday, November 28, 2009 4:27 PM
  • Hello

    I am currently trying to install Foundation and I've hit this issue as well. I discovered that my newly installed SQL box was not showing up using Ping. So I allowed all inbound connections on its firewall. The wizard worked as expected. So it wasn't the firewall on the Foundation box that was the problem, it was the SQL box.

    What I don't understand is why the server was not even allowing PING. I looked at the firewall rules and could not see anything obvious but then I'm not a IP/Firewall guru. It's obviously not ideal to basically disable the firewall.

    Hope this might shed some light.

    Thanks
    Friday, December 4, 2009 11:24 AM
  • My Solution for this....

    I had this exact problem and was able to fix it in the following way.

    If your Firewall 1433 port is open (and it probably is, but just check it) then this is a SQL Server configuration issue. 

    Go to the SQL Server Configuration Manager (Start - All Programs - SQL Server 2008 - Configuration Tools - SQL Server Configuration Manager))

    Now look under SQL Server Network Configuration - Protocols for MSSQLSERVER

    *  TCP/IP should be enabled (by default installation, it is not).  Enable that and RESTART SQL Services. 


    You should be good to go after that. 

    Best of Luck!!!  (and if this helps you please vote for my answer.  Thanks!)

    • Proposed as answer by PaminCambridge Wednesday, December 16, 2009 5:05 PM
    Wednesday, December 16, 2009 5:05 PM
  • I did the following:
    1. Installed SQL Server 2008 64 bit (SharePoint 2010 won't work with SQL Server 32 bit)
    2. Installed SQL Server 2008 Service Pack 1 (MUST).
    3. Installed the Cumulative Update for SQL Server 2008 Service Pack 1 - http://support.microsoft.com/kb/973602
    4. Created Active Directory user for SharePoint Administrator and created a login for that user in SQL Server 2008
    5. Checked whether TCP/IP Protocol for SQL Server instance is enabled (as per PaminCambridge). It was enabled by default in my SQL Server 2008 installation.
    6. My SQL Service account is a domain account. So, I did as Anthony Allen mentioned and registered the domain account with a SPN using the "setspn" command. - I am not 100% sure whether this step is necessary and if yes, not sure why. 
    7. On SQL Server machine, using 'Windows Firewall with Advanced Security", created an inbound rule to allow connections on port 1433.

    And. it went fine. 

    Hope this helps.

    Friday, December 25, 2009 5:22 PM
  • Hi all,

    just a little note, SQL server must be entered with its instance name e.g. SERVER\SQLEXPRESS for example !!!

    Tomas


    Tomas Paulas MCP,MCSA,MCSA-Messaging
    Monday, January 11, 2010 2:28 PM
  • The error was indeed resolved when turning off the firewall on the SharePoint server and the SQL Server respectively.  This is obviously not the best route, but as it is sandbox it is not the end of the world.  

    Would be interesting to find a "policy pack" specific for SharePoint which we could load onto the environments when deploying (assuming clients are using windows firewall that is)

    http://technicallead.wordpress.com/
    Wednesday, January 27, 2010 2:26 PM
  • hi,

      Ive had exactly the same error and it now appears to be resolved. My configuration is Windows 2008 R2 and SQL server 2008 sp1 with CU 6. I created a domain level SQL service account with Windows 2008 server.

    when the error first cropped up in SharePoint configuration wizard I first went to the SQL server configuration manager selected "SQL server network Configuation->protocols for MSSQLSERVER" and enabled both named pipes and TCP/IP

    next i went to "SQL Server Services" and right clicked  SQL server agent->properties>service and made start up automatic. I did the same with SQL server browser. I then started them up and also restarted "SQL server (MSSQLSERVER)" so that the changes I made earlier in the "SQL server network configuration" section became updated. Note that every service in the SQL Server services link is now fired up...

    next I went and disabled windows firewall. After that I went back to the sharepoint products configuration wizard and under database server I entered the server name, I then entered my service account and its corresponding password and clicked next. After I got the passphrase screen I returned and re-enabled my windows firewall. It seems that even if I were to go back a page in the sharepoint products configuration wizard and re-enter the data again. I do not have to disable the firewall a second time...
    Thursday, February 18, 2010 5:16 AM
  • I have the same issues and I tried the proposed solution and it didn't work for me.  Not sure if I missed something.  Just one question about the SQL service accounts.  Did you set them to Local System or Network Services?

    Thanks.
    Wednesday, March 3, 2010 9:02 PM
  • i had the same issue and enabling TCPIP protocol for sql fixed it.
    Wednesday, March 24, 2010 3:28 AM
  • hi guys!

    i've got 2 Hyper-V virtual machines in a forest: the first one's running the SQL Server, the second one's the Sharepoint 2010 service. now when i want to estabilish a connection from Sharepoint to the SQL Server, just recieve the above mentioned error. here's a list about my recent activities and the technical data:

    -SQL Server 2008 succesfully installed, TCP/IP enabled, using the default port 1433, working well (can reach it with management studio from a remote machine)
    -pipelines enabled
    -sql 2008 Service Pack 1 installed
    -cumulative updates (both) installed
    -firewall off
    -running user: Local Service

    Sharepoint:
    -the firewall of the server is off

    i use a domain user with windows authentication to connect to the database.

    tried all of the workarounds described in this thread, but no success. it's pretty annoying, that MS cannot provide normal error messages or any documentation, help or support for thit mess.

    Monday, March 29, 2010 2:31 PM