locked
After upgrade cannot delete Word document posted in Mailbox RRS feed

  • Question

  • I have one user who has a Microsoft Word document posted (pinned) in his mailbox that cannot be deleted. Upon the first deleted, Outlook moved it to deleted items, but when we try to empty deleted items or hard delete the item Outlook gives an error: Some items cannot be deleted. They were either moved or already deleted, or access was denied.  (Tried deleting with both Outlook 2007 and 2010) The Word document does not show up in OWA just in Outlook. Using MFCMapi I can see the message but get an error on deleting it. The document is just 2MB. Its a Microsoft white paper on MPIO. 

    Running Exchange 2010 SP1

    Thoughts and suggestions would be appreciated (other than the deleting the user's mailbox).

    Monday, July 25, 2011 10:36 PM

Answers

  • Hi nansinc,

    Per your description, you already use the mfmapi, which version do you use?
    You could use the newest version to make a test.
    If the error still exist, please post here, then we could do more research about it.
    It seems some curruption in the mailbox, how about move the mailbox to other database, and then make a test. Or please use the new-mailboxrepairrequest to repair the mailbox, and then use the mfcmapi to make a test again.

    Regards!
    Gavin

    TechNet Subscriber Support in forum

    If you have any feedback on our support, please contact tngfb@microsoft.com
    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    • Marked as answer by Gavin-Zhang Wednesday, July 27, 2011 1:57 AM
    Tuesday, July 26, 2011 7:38 AM
    1. Did you try the other points,ie. move the mailbox to another database.
    2. new-mailboxrepairrequest ?
    3. Could be your database which may need an ISINTEG but I personally wouldnt do it for one mailbox.
    4. At this mo, it seems like a corruptiom and seems to be pointing towards a new mailbox (which I know you dont want to do) but just bear this in mind as the last resort.
    5. Are you trying to delete that message when in cache modeor online mode? How is the profile configured, try both.
    6. Have you tried to create a new Outlook profile and test?  Is the message still there?
    7. I'll look into this a bit more.

    Sukh
    • Marked as answer by nansinc Tuesday, July 26, 2011 10:08 PM
    Tuesday, July 26, 2011 6:39 PM
  • Sukh828,

    After moving the mailbox to another database I was able to delete the message from Outlook..

    Thank you.

     

    • Marked as answer by nansinc Tuesday, July 26, 2011 10:08 PM
    Tuesday, July 26, 2011 10:08 PM

All replies

    1. Try deleting the email via OWA.
    2. Try creating a new outlook profile and deleting it.
    3. Try to export the message out - http://technet.microsoft.com/en-us/library/ff607299.aspx
    4. Try to delete the message via search-mailbox. - http://technet.microsoft.com/en-us/library/dd298173.aspx

    Sukh
    Monday, July 25, 2011 10:47 PM
  • Sukh,

    Thanks for your suggestions. 

    1. However as I stated in my posting the message does not appear in OWA

    2. I tryed in both versions of Outlook, 2007 was a new profile

    3. Export does not find the message (its not a message, its a posting) - exports empty PST

    4. Deleting via search-mailbox failed with error - Deletion failed with error 'Move/Copy messages failed.'


    Tuesday, July 26, 2011 1:10 AM
  • Hi nansinc,

    Per your description, you already use the mfmapi, which version do you use?
    You could use the newest version to make a test.
    If the error still exist, please post here, then we could do more research about it.
    It seems some curruption in the mailbox, how about move the mailbox to other database, and then make a test. Or please use the new-mailboxrepairrequest to repair the mailbox, and then use the mfcmapi to make a test again.

    Regards!
    Gavin

    TechNet Subscriber Support in forum

    If you have any feedback on our support, please contact tngfb@microsoft.com
    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    • Marked as answer by Gavin-Zhang Wednesday, July 27, 2011 1:57 AM
    Tuesday, July 26, 2011 7:38 AM
    1. As mentioned by Gavin use MFCMAPI - I know you have tried this so post the error now so we can investigate. - http://www.activedir.org/Articles/tabid/54/articleType/ArticleView/articleId/50/Default.aspx

    Sukh
    Tuesday, July 26, 2011 8:03 AM
  • Gavin-Zhang and Sukh828,

    Thank you for your posts. I was used the latest build of MFCMapi, 6.0.0.1027, and here were the results:

    If I try to delete the attachment:

    Error:
    Code: MAPI_E_CALL_FAILED == 0x80004005
    Function lpMessage->SaveChanges(KEEP_OPEN_READWRITE)
    File .\File.cpp
    Line 991

    followed by:
    Error:
    Code: MAPI_E_CALL_FAILED == 0x80004005
    Function DeleteAttachments( lpMessage, lpszAttName, m_hWnd)
    File .\FolderDlg.cpp
    Line 592

     

    If I try to delete the message as in the posting that Sukh828 posted:


    Delete message
    Warning:
    Code: MAPI_W_PARTIAL_COMPLETION == 0x00040680
    Function ((LPMAPIFOLDER) m_lpContainer)->DeleteMessages( lpEIDs, lpProgress ? (ULONG_PTR)m_hWnd : NULL, lpProgress, ulFlag)
    File .\FolderDlg.cpp
    Line 691

     

    Just to be clear of what I am trying to delete I have posted a screen shot of the Outlook window http://scandium.nansinc.com/outlook.jpg

     

     

    Tuesday, July 26, 2011 5:28 PM
    1. Did you try the other points,ie. move the mailbox to another database.
    2. new-mailboxrepairrequest ?
    3. Could be your database which may need an ISINTEG but I personally wouldnt do it for one mailbox.
    4. At this mo, it seems like a corruptiom and seems to be pointing towards a new mailbox (which I know you dont want to do) but just bear this in mind as the last resort.
    5. Are you trying to delete that message when in cache modeor online mode? How is the profile configured, try both.
    6. Have you tried to create a new Outlook profile and test?  Is the message still there?
    7. I'll look into this a bit more.

    Sukh
    • Marked as answer by nansinc Tuesday, July 26, 2011 10:08 PM
    Tuesday, July 26, 2011 6:39 PM
  • Sukh828,

    After moving the mailbox to another database I was able to delete the message from Outlook..

    Thank you.

     

    • Marked as answer by nansinc Tuesday, July 26, 2011 10:08 PM
    Tuesday, July 26, 2011 10:08 PM