none
Windows 10 1703 unable to install driver in Audit mode, some driver installer didn't start

    Question

  • I have a strange issue with 1703.... (tested versions Win 10 1703 Pro and Enterprise)

    If I switch to Audit mode on a fresh installed system and try to install the drivers system I notice that, the Chipset file for example  that could be the first driver that you must install, it's installer GUI didn't start....

    I can see the circle working for few second and no other... first of all I suppose that is because I launch the Chipset installer from a zipped file but also if I extract and run it didn't start, the same if I try to run it as Administrator.

    The only way that I found to can run it, is to run a Command Administrative Prompt and run it from command line or, edit the .exe file propriety and mark the "unblock" box.

    I got this kind of problem only with 1703, I never have this kind of problem with all previous version of Win10 and with other kind of windows 8.1, 8, 7 ecc....

    To avoid that my custom base image could have some kind of problem I used for my latest test the original Eng ISO downloaded from MOO site.

    Another info is that if I try to continue the installation of other drivers like: ME, VGA, Audio, LAN, iRST I notice that someone start and someone not. I can't understand why 1703 version have this kind of problem.

    Someone can help me??

    Thursday, April 27, 2017 9:06 AM

Answers

  • Hi Miki,

    What if you install other application?
    The only way that I found to can run it, is to run a Command Administrative Prompt and run it from command line or, edit the .exe file propriety and mark the "unblock" box.

    What's "unblock" box? If it's convenient, please give us a screenshot.

    In addition, about cannot open the app using the built-in Administrator account issue, please solve it by enabling the following Group Policy:

    Computer Configuration >>Windows Settings>Security Settings>Local Policies>security options> User account control:admin approval mode for the built in administrator account

    Computer Configuration >>Windows Settings>Security Settings>Local Policies>security options> User Account Control: Run all administrators in Admin Approval Mode

    The related registry setting are shown blew, we could also implement it by modifying registry
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System

    FilterAdministratorToken change the value data to “1”
    EnableLUA change the value data to “1”


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.


    Friday, April 28, 2017 6:58 AM
    Moderator

All replies

  • I think to have found the cause from myself, it the Windows Defender and the SmartScreen option that block the running of some executable file but, in audit mode with the only Administrator user enable you can start the app because it was disable for this account so I found the cause but didn't have a solution to can workaround it's.

    I'm sure at 99% that the cause is this because if I try to execute the same file from OOBE mode a SmartScreen popup windows show and ask if I want to "Run" this specified file.

    How I can disable or skip the Defender check in audit mode??

    Thursday, April 27, 2017 3:37 PM
  • Hi Miki,

    What if you install other application?
    The only way that I found to can run it, is to run a Command Administrative Prompt and run it from command line or, edit the .exe file propriety and mark the "unblock" box.

    What's "unblock" box? If it's convenient, please give us a screenshot.

    In addition, about cannot open the app using the built-in Administrator account issue, please solve it by enabling the following Group Policy:

    Computer Configuration >>Windows Settings>Security Settings>Local Policies>security options> User account control:admin approval mode for the built in administrator account

    Computer Configuration >>Windows Settings>Security Settings>Local Policies>security options> User Account Control: Run all administrators in Admin Approval Mode

    The related registry setting are shown blew, we could also implement it by modifying registry
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System

    FilterAdministratorToken change the value data to “1”
    EnableLUA change the value data to “1”


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.


    Friday, April 28, 2017 6:58 AM
    Moderator
  • Hi Miki,

    What if you install other application?
    The only way that I found to can run it, is to run a Command Administrative Prompt and run it from command line or, edit the .exe file propriety and mark the "unblock" box.

    What's "unblock" box? If it's convenient, please give us a screenshot.

    In addition, about cannot open the app using the built-in Administrator account issue, please solve it by enabling the following Group Policy:

    Computer Configuration >>Windows Settings>Security Settings>Local Policies>security options> User account control:admin approval mode for the built in administrator account

    Computer Configuration >>Windows Settings>Security Settings>Local Policies>security options> User Account Control: Run all administrators in Admin Approval Mode

    The related registry setting are shown blew, we could also implement it by modifying registry
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System

    FilterAdministratorToken change the value data to “1”
    EnableLUA change the value data to “1”


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.


    The "unblock" tab avoid the SmartScreen check, and also if you run the installer from a command prompt (in this case the "unblock" is not necessary").

    Friday, April 28, 2017 7:21 AM
  • Computer Configuration >>Windows Settings>Security Settings>Local Policies>security options> User account control:admin approval mode for the built in administrator account

    Computer Configuration >>Windows Settings>Security Settings>Local Policies>security options> User Account Control: Run all administrators in Admin Approval Mode

    The related registry setting are shown blew, we could also implement it by modifying registry
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System

    FilterAdministratorToken change the value data to “1”
    EnableLUA change the value data to “1”

    This workaround work!! I only change the group policy filed, the registry is by default ok now.... can I set these policy inside my unattend.xml file, via Windows System Image Manager, for only audit mode?  

    Friday, April 28, 2017 8:30 AM
  • Yes, that can be done.

    You could use the script to add the registry in the unattend.xml file.


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.


    Friday, April 28, 2017 10:38 AM
    Moderator
  • WSIM have a lot of options, the first that I have think is to add a Sync command that run a script file.

    I don't know if WSIM can directly edit the Windows registry

    Friday, April 28, 2017 10:45 AM
  • WSIM have a lot of options, the first that I have think is to add a Sync command that run a script file.

    I don't know if WSIM can directly edit the Windows registry


    Yes, it can.

    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Monday, May 8, 2017 8:22 AM
    Moderator
  • WSIM have a lot of options, the first that I have think is to add a Sync command that run a script file.

    I don't know if WSIM can directly edit the Windows registry


    Yes, it can.

    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.


    How I can do it?
    Monday, May 8, 2017 8:25 AM
  • Hi,

    What I mean is not you can edit the registry as in the registry editor.

    It means that you could edit the registry via editing the answer file script that include the registry configuration components.

    1. Open Windows SIM.

    2. Open a Windows image. For more information, see Open a Windows Image or Catalog File.

    3. Open or create an answer file.

    4. In the Answer File pane, find the configuration pass that contains the component for the setting to edit.

    5. Select the component or package that contains the setting to edit.
     The component or package information appears in the Properties pane.

    6. In the Settings section of the Properties pane, change the value of the setting to update it. Depending on the type of setting, you can enter a new setting or choose from a drop-down list of possible settings.

    For more information, please refer to this article:

    Customize a Setting in an Answer File

    https://technet.microsoft.com/en-us/library/cc749184(v=ws.10).aspx


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Wednesday, May 10, 2017 9:48 AM
    Moderator