none
PWA 2013 Schedule Template not being used when creating a project in PWA RRS feed

  • Question

  • Created and loaded Schedule Template from Project Professional 2016

    Template shows up and is selectable on EPT

    When I create a New Project Type for that EPT, the schedule is the default one not the one entered on the EPT.

    1.  Is it a problem to create the template in 2016 for use with PWA 2013?

    2.  If not, what could I be doing wrong?  Note - my schedule Template has Custom Fields at the task level.

    Thursday, December 22, 2016 1:45 PM

All replies

  • Hi,

    Just to be sure. You're working with Project Server 2013? Anyway, if you can see the template in the drop down list of the EPT, it should work. Have you double-checked the EPT configuration? Have you checked the queue to see if you have any errors ?


    Hope this helps,


    Guillaume Rouyre, MBA, MVP, P-Seller

    Thursday, December 22, 2016 2:47 PM
    Moderator
  • Yes, Project Server 2013 and Projects on my computer is 2016.

    I have custom task level fields on the template - I have added several columns.  I just checked to make sure all fields are defined and they seem to be.  I can check that again.

    On the EPT form, I can see the template name and I select it. 

    Thank you for your suggestion to check the Queue jobs  - I did not know a queue job was involved in this process.  I see this error in the queue:

          
        
    General
    • CreateWssSiteContent: Creating project site failed! Project Uid=ce6f223f-55c8-e611-80e2-0050569f0f03, site URL=http://proj2013-tst.polysci.com/BE-PWA/TEST Name 2, site name=TEST Name 2. Cannot attach workspace without either PWSVisibility or PWSManaged feature enabled:
      • WSSCreateSiteFailure (16400). Details: id='16400' name='WSSCreateSiteFailure' uid='0be4753f-55c8-e611-80e2-0050569f0f03' projectUID='ce6f223f-55c8-e611-80e2-0050569f0f03' workspaceUrl='http://proj2013-tst.polysci.com/BE-PWA/TEST Name 2/TEST Name 2' projectWorkspaceName='TEST Name 2'.
    • Queue:
      • GeneralQueueJobFailed (26000) - CreateWssSite.CreateWssSiteMessage. Details: id='26000' name='GeneralQueueJobFailed' uid='0ce4753f-55c8-e611-80e2-0050569f0f03' JobUID='1770223f-55c8-e611-80e2-0050569f0f03' ComputerName='8dd70ab6-28fa-494f-ac0f-1bd38e483551' GroupType='CreateWssSite' MessageType='CreateWssSiteMessage' MessageId='1' Stage='' CorrelationUID='b192c39d-67bb-4092-8355-1c9268661950'. For more details, check the ULS logs on machine 8dd70ab6-28fa-494f-ac0f-1bd38e483551 for entries with JobUID 1770223f-55c8-e611-80e2-0050569f0f03.

    The issue may be that I do not have all required schedule task level fields or project level fields.  How can I see the required fields that are not custom fields.  I tried renaming the project from above and it did not help. 

    Next setup is to make sure I have all fields from the out of the box schedule on the schedule and the project level ones on my custom PDP for it.

    Ideas?

    Thursday, December 22, 2016 2:57 PM
  • This is not an issue to have task custom fields. Can you create a new template starting from a blank project just with a few tasks to see if the issue comes from the template?

    The message says that there is an issue with the project site template, and not the schedule template. Have you customized the site template? Can you try again without creating a project site?


    Hope this helps,


    Guillaume Rouyre, MBA, MVP, P-Seller

    Thursday, December 22, 2016 4:20 PM
    Moderator
  • On the EPT Page, the default says "Project Site" and I have no option to deselect creating a Project Site.  I have not yet done anything with the Project Site or Site Template.  I think the one there is out of the box.
    Thursday, December 22, 2016 5:10 PM
  • I created a Schedule Template in Project 2016 and saved to PWA 2013

    The data entered in the Schedule Template shows up for the normal schedule fields where I entered data on the template but the one custom task level field does not show up?

    Shouldn't the Task Level Custom Fields entered on the Template show up?

    Thursday, December 22, 2016 5:53 PM
  • I entered both Project Level fields and a different task level field custom on the Template. The Data for the Project Level fields does not come over and the custom level fields name or contents are not coming over.  I am no longer getting the Queue error.
    Thursday, December 22, 2016 6:49 PM
  • I have the data coming over but the Enterprise Custom Field columns I added are not coming over.  Still no error message.

    The Custom Schedule Template is showing in Working Status even though I said to Publish in Project Professional 2016

    Thursday, December 22, 2016 9:17 PM