locked
.NET Framework 3.5 Will Not Install. Error: 0x80071A90 RRS feed

  • Question

  • I have searched for this error and cannot find any information, I think this is a NEW question. I apologize if I missed a solution somewhere.

    I recently downloaded the free upgrade to Windows 10.

    I am having an issue trying to open the Sims 3 from Origin, this is when I am prompted to install the app feature (.net framework 3.5) It goes through the process of installation but then I am prompted with the error code 0x80071A90. It says "The function attempted to use a name that is reserved for use by another transaction." My computer seems to think it is NOT installed, but, either it actually IS installed or there is something "in its place" that it can't access or recognize the correct framework? I am not computer savvy, but that is my interpretation of the error thus far..

    I have opened app features on/off, clicked and unclicked between the 4.5 and 3.5 (they are both there, every time.) I've tried to download and install from the website. I've restarted the computer. Uninstalled my games and Origin. Reinstalled Origin and base game. I've tried seemingly every option suggested. I tried to rollback my OS to 8, only for the process to freeze partway (I waited well over an hour, it was definitely frozen, and a chat support person told me my only option was to force reboot.) When I got back in, I still was on OS 10, still having the same error code, and now petrified to try and rollback again. 

    I've spoken with several friends to try and resolve this before coming here. At this point I would like to stick with OS 10, and just resolve the whole .NET framework thing. Can anyone help me?

    Friday, December 4, 2015 2:46 PM

Answers

  • kwheels187,

    What is your current situation?

    The below is the information talking about the error 0x80071A90:

    http://windows.microsoft.com/en-us/windows7/windows-update-error-80071a90

    Windows Update error 80071A90 happens when files that are required by Windows are in use (locked) by other programs. Programs, such as antivirus programs that run when Windows starts, can lock system files.

    Please first run Windows Update troubleshooter, if issue still insists, please do the following steps:

    1. Follow the guide below to boot into safe mode:

    http://windows.microsoft.com/en-us/windows-10/get-to-safe-mode-and-other-startup-settings-in-windows-10#v1h=tab01

    2. Do the changes from there.

    Besides, we could take use of the Dism command and the install Media to enable .net 3.5 with command line:

    To install .NET Framework 3.5 from installation media located on the D: drive (mounted Windows 10 ISO), use the following command:

    DISM /Online /Enable-Feature /FeatureName:NetFx3 /All /LimitAccess /Source:d:\sources\sxs

    Reference: https://technet.microsoft.com/en-us/library/dn482069.aspx

    Regards


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    • Proposed as answer by Michael_LS Thursday, December 10, 2015 8:57 AM
    • Marked as answer by Deason Wu Friday, December 25, 2015 7:05 AM
    Monday, December 7, 2015 9:10 AM

All replies