locked
Connect to Microsoft Exchange using HTTP will not stay ticked RRS feed

  • Question

  • I am trying to set up a remote laptop that will pretty much only ever connect to exchange from the web.  When launching outlook to 1st register it with exchange, it recognised our server as a blah.local address (e.g. a local server only available via DNS) which obviously doesnt work from outside of the LAN.

    I have enabled COnnect to Microsoft Exchange of HTTP, filled in the setting, but then Outlook says it has to reboot for the setting to apply.  When Outlook then re-opens the box is not ticked and all the sendings have gone.

    Any ideas how to fix this?

    Saturday, July 16, 2011 11:00 PM

Answers

All replies

  • Hi,

    I believe you are configuring outlook anyhwhere in outlook to connect from WAN. Please check you have vallid URL of OWA which you will be using in outlook anywhere http settings. OA setting will be remain in outlook once it will make a connection with server. I would ask you to check follwoing things.

    1. Vallid URL of OWA, Autodiscover URL

    2. Certificate if you are using

    3. verify outlook anywhere connection from below link first and if test pass then conifugre outlook.

    Microsoft Remote Connectivity Analyzer

    https://www.testexchangeconnectivity.com/

    Anil MCC 2011,ITIL V3,MCSA 2003,MCTS 2010, My Blog : http://messagingschool.wordpress.com
    Sunday, July 17, 2011 3:53 AM
  • hi, the test was successful as shown below.  I think the settings are correct, but physically, whenever I open OUtlook, the settings vanish and the tick is removed from the "COnnect over HTTP" box.  It is as if it is hard set somewhere to turn this off, every time I launch Outlook.


    Any other ideas?

    ExRCA is attempting to test Autodiscover for xxx@xxx.co.uk.
      Autodiscover was tested successfully.
     


    • Edited by CDBill Sunday, July 17, 2011 2:48 PM removed email address for security
    Sunday, July 17, 2011 2:42 PM
  • Hi, I retried the test today and did it so that it manually tried the settings and it failed.  Does this help diagnosis?

    RPC/HTTP connectivity.

    Testing

      The RPC/HTTP test failed.
     
    Test Steps
     
    Attempting to resolve the host name mail.xxx.co.uk in DNS.
      The host name resolved successfully.
     
    Additional Details
    Testing TCP port 443 on host mail.xxx.co.uk to ensure it's listening and open.
      The port was opened successfully.
    Testing the SSL certificate to make sure it's valid.
      The certificate passed all validation requirements.
     
    Test Steps
    Checking the IIS configuration for client certificate authentication.
      Client certificate authentication wasn't detected.
     
    Additional Details
    Testing HTTP Authentication Methods for URL https://mail.xxx.co.uk/rpc/rpcproxy.dll.
      The HTTP authentication methods are correct.
     
    Additional Details
    Testing SSL mutual authentication with the RPC proxy server.
      Mutual authentication was verified successfully.
     
    Additional Details
    Attempting to ping RPC proxy mail.xxx.co.uk.
      RPC Proxy can't be pinged.
     
    Additional Details
      A Web exception occurred because an HTTP 404 - NotFound response was received from IIS7.
    Monday, July 18, 2011 8:41 PM
  • Hello,

     

    Please check the following link and make sure the ROH has been enabled properly from the server side:

     

    http://exchangeserverpro.com/how-to-configure-exchange-server-2010-outlook-anywhere

     

    In addition, please access the following url on the CAS sever and check whether it returns a blank screen or any error codes:

     

    https://localhost/rpc/rpcproxy.dll

     

    Thanks,

    Simon

    Tuesday, July 19, 2011 6:51 AM
    Moderator