locked
Remote desktop into Windows 8 RP with Microsoft Account fails RRS feed

  • Question

  • When attempting to remote desktop into one of my Windows 8 RP computers from another Windows 8 RP computer mstsc.exe prompts for credentials. Entering the correct credentials for a Microsoft Account on the remote computer fails: "Your credentials did not work"

    I set up another account on the remote computer, this one a local account. I can log in with this account.

    I can also log in to the Microsoft Account if the RDP client does not prompt for the credentials before the terminal service session starts. IE, if it connects to the remote computer first, then I log in. This works on older mstsc.exe's and iTap RDP (an iOS RDP client) that allows me to connect without sending credentials.

    Is there a fix? Is there a way to force newer mstsc.exe's to connect without sending credentials first?

    Thanks,

    Mike Ellis

    Friday, August 3, 2012 8:38 PM

Answers

  • Ok, I found that if you save your connection settings to an .rdp file, then edit it with a text editor and add the line:

    enablecredsspsupport:i:0

    You can then connect without supplying credentials first.

    See http://support.microsoft.com/kb/941641

    Which solves my problem.

    Friday, August 3, 2012 9:29 PM

All replies

  • Maybe it has to do with the Domain changing to "emailprovider.com" when the @emailprovider.com part of the Microsoft Account is entered?
    Friday, August 3, 2012 8:48 PM
  • More information. I turned on failure logging in the event viewer. The successful local account login connects with a SubjectUserName and SubjectDomainName. The failing Microsoft Account is trying to connect with a TargetUserName and TargetDomainName.

    The failure reason is %%2313.

    Friday, August 3, 2012 9:14 PM
  • Ok, I found that if you save your connection settings to an .rdp file, then edit it with a text editor and add the line:

    enablecredsspsupport:i:0

    You can then connect without supplying credentials first.

    See http://support.microsoft.com/kb/941641

    Which solves my problem.

    Friday, August 3, 2012 9:29 PM
  • A more elegant solution is to just properly put your credentials in.

    If you're using a microsoft account, the format should be as follows

    username:  microsoftaccount\<microsoft account email address>

    Works without crippling your security just fine.

    • Proposed as answer by Joe Hancuff Monday, November 19, 2012 12:54 PM
    • Unproposed as answer by MikeAJEllis Wednesday, December 12, 2012 2:32 AM
    • Proposed as answer by Dem0sthenes Friday, December 14, 2012 11:42 PM
    Monday, November 19, 2012 12:54 PM
  • You've assumed that I didn't. When trying to connect with my MS account it fails, prompts me to try again this time with:

    MicrosoftAccount\doej@live.com

    ... and then still fails.

    I've since upgraded this machine from the last preview to Windows 8 Pro and still see this behavior. 

    I have a number of other Win8 boxes. This is the only one that exhibits this.

    Wednesday, December 12, 2012 2:32 AM
  • Except that it does work. 

    Perhaps it has to do with the account's domain name?  I log in this way every day to several Windows 8 Pro (retail) machines on a daily basis with no issue.

    Have you tested this with a different MS account?  


    Dev-Hack.Com -=- Modder Central

    Friday, December 14, 2012 11:42 PM
  • http://10rem.net/blog/2012/03/05/my-unofficial-tips-for-remoting-into-a-windows-8-machine-from-windows-7-plus-microsoft-account-tips  I'm not the only one.  

    Dev-Hack.Com -=- Modder Central

    Saturday, December 15, 2012 12:02 AM
  • Hey I also found that if you just use the username that you'd find in the local groups and users and treat it like a local users to the box instead of a domain users you can logon with RDP just fine.  If you're logging on from a domain computer, just use the universal local-computer .\username



    Dev-Hack.Com -=- Modder Central

    Sunday, January 27, 2013 2:07 PM
  • The sollution that works for me (local account): in the textbox for a username insert the computer name (eg. "home"), backslash,  username (e.g. "john") - in the form:

      home\john

    You can see changing the domain label below the username textbox from MicrosoftAccount to the computer name.

    Wednesday, February 20, 2013 6:07 PM
  • Thank you - Had the same problem; your answer solved it for me.
    Friday, February 22, 2013 5:28 AM
  • Joe Hancuff's solution worked perfectly for me. It seems odd that Microsoft have not made this change clear.

    Thank you Joe

    Wednesday, May 22, 2013 8:54 AM