locked
Desktop Wallpaper\backgroud RRS feed

  • Question

  • I am having the darnest time. I set a standard policy in my "default domain users policy" to change the users wallpaper to a company one.But when they log in it does not apply to the desktop. However, if you go to display properties and select the "desktop" tab it is there as my background. It is puzzling, Also It will not allow me to change it, even logged in as a domain admin.Anyone know what i should be looking for?
    Scott Cummins
    Tuesday, June 30, 2009 6:24 PM

Answers

  • Hello Scott,

    Well First I'd check to ensure the path to the graphic is at a location that all users have access. That is, if the BMP is in a folder on the server, does everyone have read rights to that folder?

    Another thing you might want to consider is to push out that BMP to each workstation, say to the Program Files or Windows\System32 folder. Then have the Group policy point to that drive. This way if a user does not have a network connection, he will still get that wallpaper assigned from this Cached Group Policy.

    I'd check the settings of your GPO against this,
    \user configuration\administrative Templates\desktop\active desktop
    *Enable Active Desktop (only Needed if you are using JPEG's, if your using a BMP you don't need to enable this)
    * Active Desktop Wallpaper

    As for not being able to change the wallpaper, check out this KB to see if this might help
    http://support.microsoft.com/default.aspx/kb/327998

    Also, I'd check the settings in User Configuration\administrative Templates\control Panel and \control panel\DIsplay to ensure that  you have the prevent changin wallpaper either enabled or disabled depending on your desired outcome.

    Lastly, Remember that once enabled, there are sometimes that you can't just go back and change a setting to not configured, you have to disable it to remove the setting, sometimes I have to think of Math and the double negative when working with Group Policies...

    Good Luck and let us know if you have any luck..

    Mike





    • Proposed as answer by Havoc64 Wednesday, July 1, 2009 3:29 PM
    • Marked as answer by Mervyn Zhang Thursday, July 2, 2009 6:57 AM
    Tuesday, June 30, 2009 9:16 PM

All replies

  • Scott, please specify what operating systems you are using (client and GPO editing machine).
    Which GPO setting exactly are you trying to set up (exact path in editor) ?
    Keep in mind that concerning wallpaper settings there are different ways (e.g. when using "Active Desktop")
    and to get a clear picture it is necessary to know which you are following...


    Patrick
    Tuesday, June 30, 2009 8:26 PM
  • Hey Patrick

    Well, it is Server 2003, I am using the native GroupPolicy Management tool On my Domain controller that is the Primary roleholder.

    I am using the "active Desktop Wallpaper" object in the "Administrative" portion of the 'User Configuration" section of my policy.It is pretty straight foward that is why I am thinking perhaps the users are lacking some permission on their mnachine that won't allow GP to display the wallpaper. if not, i am SOOO lost. Any assistance would be greatly appreciated
    Scott Cummins
    Tuesday, June 30, 2009 9:06 PM
  • Hello Scott,

    Well First I'd check to ensure the path to the graphic is at a location that all users have access. That is, if the BMP is in a folder on the server, does everyone have read rights to that folder?

    Another thing you might want to consider is to push out that BMP to each workstation, say to the Program Files or Windows\System32 folder. Then have the Group policy point to that drive. This way if a user does not have a network connection, he will still get that wallpaper assigned from this Cached Group Policy.

    I'd check the settings of your GPO against this,
    \user configuration\administrative Templates\desktop\active desktop
    *Enable Active Desktop (only Needed if you are using JPEG's, if your using a BMP you don't need to enable this)
    * Active Desktop Wallpaper

    As for not being able to change the wallpaper, check out this KB to see if this might help
    http://support.microsoft.com/default.aspx/kb/327998

    Also, I'd check the settings in User Configuration\administrative Templates\control Panel and \control panel\DIsplay to ensure that  you have the prevent changin wallpaper either enabled or disabled depending on your desired outcome.

    Lastly, Remember that once enabled, there are sometimes that you can't just go back and change a setting to not configured, you have to disable it to remove the setting, sometimes I have to think of Math and the double negative when working with Group Policies...

    Good Luck and let us know if you have any luck..

    Mike





    • Proposed as answer by Havoc64 Wednesday, July 1, 2009 3:29 PM
    • Marked as answer by Mervyn Zhang Thursday, July 2, 2009 6:57 AM
    Tuesday, June 30, 2009 9:16 PM
  • Mike

    you were absolutely correct on all accounts, I believe I was in to much of a hurry and impatient and was just 'clicking' stuff. thank you so much and it is working fantastic now.
    Scott Cummins
    Wednesday, July 1, 2009 2:49 PM
  • Hi Mike or Anyone,

    I am having the same issue Scott was having. The image is shared out on one of my non-critical servers (I have also tried hosting it locally) but the users still do not have the wallpaper. As Scott was saying, if I right-click on the desktop select properties and go to the Desktop tab, the preview has the image there, but not actually on the desktop itself. I don't want them to be able to change it, so that is disabled, but any help on how to make the image appear on the desktop would be much appreciated.

    I have the Policy set for Default Domain Policy as well as for the OU the user is in. I have tried through just the default domain policy, then just through the OU policy, and now both simultaneously. I have given full control to the share and the image just to make sure it was not a permissions issue on the .bmp.

    Thanks,
    Tony Chaney 

    PS - I am using Microsoft Windows Server 2008 for Servers and Windows XP SP3 for all desktops.
    Thursday, July 2, 2009 12:35 PM
  • Tony, Mike and anyone

    One "side-effect" to the fix is that on the desktop all the Icons no  have their text description highlighted with a different background, Like a shadowbox around the text. Of Course people are complaining, I have gone in and changed the color of it but it is still noticeable. Also, As Tony was stating, I have a secondary issue wher I am trying to apply a separate background "wallpaper" locally to my production servers. I put them on a VLAN so close to my Disaster Recovery site that on one or two occasions I have logged into production by mistake and rebooted. So I wanted to apply a background to them that is bright red and says "PRODUCTION" I have applied it locally and again, when you log in you see it in the "Desktop" tab But I get the user background from GP, even if I "block"policy inheritance to that OU.

    I know this is convoluted, But again any helpfor I or Tony is greatly appreciated


    signed
    GP challenged in Phoenix
    Scott Cummins
    Thursday, July 2, 2009 2:57 PM
  • Scott,

    Do you have the background color being set too? Also what resolution is the image? Are there any Settings defined in User Config\Administrative Templates\Control Panel\Display\Desktop Themes\?  Do you have the "Load a specific Visual Style file or Force Windows Classic" Enabled? This might accunt for the weird side effect.

    I have seen it do strange things when it had to resize the image to fit. Do all your systems have the same size monitor and same setting? i.e. 1024x768?

    I'd try this, resize the image to something that will fit in the majority of your users, something like 800x600. Push that out and see if it helps. Also check to make sure the Wallpaper Style is set to Center and not stretch.

    Tony, is the rest of the policy being applied? Is it just the desktop part not applying? I'd check the slow link detection settings. Also do you have the Windows 2008 Client Side Extensions loaded on the XP Boxes? I know Mundane questions, but I always start at the bottom and work up... *Smile*

    Lemme know if this helps any.

    Mike
    • Proposed as answer by Mervyn Zhang Monday, November 23, 2009 9:04 AM
    Thursday, July 2, 2009 3:56 PM
  • Hi Scott & Mike (And Anyone Else),

    The solution was as simple as me changing the wallpaper source from a .bmp to .jpg.

    Now i'm moving on to other Group Policy issues. The folder redirection for Favorites is not working...

    Thanks for your help guys, I appreciate your time and effort!

    Tony
    Monday, July 6, 2009 1:05 PM