locked
Deploying via powershell command from AppV Management Server 5.0 RRS feed

  • Question

  • Hello All,

    Good day!

    I am having hard time in deploying an application from AppV Management Server 5.0 using Powershell command.

    I have an application which works in Standalone client machine and even from SCCM 2012(AppV Deployment), whereas if I deploy that application from AppV server it is not working

    I am using this command line to deploy an application from AppV Mgmt server thru powershell command,

    Import-AppvServerPackage -PackagePath "<Path of .appv file>" –DynamicDeploymentConfigurationPath "<Path of DeploymentConfig.xml"> | Publish-AppvServerPackage -Verbose | Grant-AppvServerPackage -Groups "domain\AppV_Users" -Verbose

    is there anything wrong in the command which I used?

    When I run, am receiving this error.

    Import-AppvServerPackage : A parameter cannot be found that matches parameter name
    'DynamicDeploymentConfigurationPath'.
    At line:1 char:126
    + ... 1.0.3333.appv" –DynamicDeploymentConfigurationPath '\App_DeploymentConfig.xml'  ...
    +                    ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
        + CategoryInfo          : InvalidArgument: (:) [Import-AppvServerPackage], ParameterBindingException
        + FullyQualifiedErrorId : NamedParameterNotFound,Microsoft.AppV.Server.Cmdlets.ImportAppvServerPackageCommand

    whereas this command works, without DynamicDeploymentConfigurationPath
    Import-AppvServerPackage -PackagePath "<Path of .appv file>" | Publish-AppvServerPackage -Verbose | Grant-AppvServerPackage -Groups "domain\AppV_Users" -Verbose

    How do I direct my application to take the DeploymentConfig.xml file though powershell.

    I even tried to Import this xml from AppV Management console, even it did not work for me. 

    Kindly help me, your inputs needed.

    Any help would be greatly appreciated.

    Thanks in Advance!

    Regards,

    Raj

    Tuesday, March 25, 2014 11:19 AM

Answers

  • Hello,

    You need to use the -Name (or _something_ to identify which package you want to change) when using set-appvserverpackage...

    sample;

    Set-AppVServerPackage -Name <nameofurpkg> -DynamicDeploymentConfigurationPath \\whack\whack\file_deploymentconfig.xml

    or, if using a user-config;

    Set-AppVServerPackage -Name <nameofurpkg> -DynamicUserConfigurationPath \\whack\whack\file_userconfig.xml -Groups AD.GROUP.SMTHGN


    Nicke Källén | The Knack| Twitter: @Znackattack

    Tuesday, March 25, 2014 7:27 PM

All replies

  • Run the following commands to get the right syntax for the Import-AppvServerPackage

    Get-Help Import-AppvServerPackage -Detailed

    Get-Help Import-AppvServerPackage -Examples



    Please remember to click "Mark as Answer" or "Vote as Helpful" on the post that answers your question (or click "Unmark as Answer" if a marked post does not actually answer your question). This can be beneficial to other community members reading the thread.


    This forum post is my own opinion and does not necessarily reflect the opinion or view of my employer, Microsoft, its employees, or other MVPs.

    Twitter: @stealthpuppy | Blog: stealthpuppy.com | The Definitive Guide to Delivering Microsoft Office with App-V

    Tuesday, March 25, 2014 12:27 PM
    Moderator
  • import-appvserverpackage doesn't seem to support the –DynamicDeploymentConfigurationPath parameter. After importing the package, use set-appvserverpackage instead, which does.

    BTW if you have an syntax error in an PoSH cmdlet it would be wise to post the _exact and complete_ command without any replacements (or 'anonymisation'), as this may interfere with the result.


    Falko

    Twitter @kirk_tn   |   Blog kirxblog   |   Web kirx.org   |   Fireside appvbook.com

    Tuesday, March 25, 2014 12:55 PM
    Moderator
  • Hi Falko,

    Thanks for your response.

    As you said, I tried to import the package and used set-appvserverpackage

    PS C:\Users\Administrator.xxxxxxxxxxx> Import-AppvServerPackage "\\appv\Content\Filezilla\Filezilla.appv"


    Id               : 15
    Name             : Filezilla
    Description      :
    PackageGuid      : e8720679-cc41-4578-98a4-32a382f790ef
    VersionGuid      : 296708bc-e07d-474a-bb46-1f09d9779a4c
    Version          : 0.0.0.1
    Enabled          : False
    Applications     : {}
    Entitlements     : {}
    ConnectionGroups : {}
    PackageUrl       : \\appv\Content\Filezilla\Filezilla.appv

    import was successful, when I try Set-Appvserverpackage am receiving the following error

    PS C:\Users\Administrator.xxxxxxxxxxx> Set-AppvServerPackage -DynamicDeploymentConfigurationPath "\\appv\Conte
    nt\Filezilla\Filezilla_DeploymentConfig.xml" | Publish-AppvServerPackage -Global
    Set-AppvServerPackage : Parameter set cannot be resolved using the specified named parameters.
    At line:1 char:1
    + Set-AppvServerPackage -DynamicDeploymentConfigurationPath "\\appv\Content ...
    + ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
        + CategoryInfo          : InvalidArgument: (:) [Set-AppvServerPackage], ParameterBindingException
        + FullyQualifiedErrorId : AmbiguousParameterSet,Microsoft.AppV.Server.Cmdlets.SetAppvServerPackageCommand

    I am going wrong somewhere...

    Tuesday, March 25, 2014 4:51 PM
  • I'll have to download this, I would download and give a try. Thanks for your suggestion Aaron.

    Tuesday, March 25, 2014 4:53 PM
  • Hello,

    You need to use the -Name (or _something_ to identify which package you want to change) when using set-appvserverpackage...

    sample;

    Set-AppVServerPackage -Name <nameofurpkg> -DynamicDeploymentConfigurationPath \\whack\whack\file_deploymentconfig.xml

    or, if using a user-config;

    Set-AppVServerPackage -Name <nameofurpkg> -DynamicUserConfigurationPath \\whack\whack\file_userconfig.xml -Groups AD.GROUP.SMTHGN


    Nicke Källén | The Knack| Twitter: @Znackattack

    Tuesday, March 25, 2014 7:27 PM