locked
Access file from a network share RRS feed

  • Question

  • Hi, I am using VMware player to host my biztalk development environment. My VM is not part of a domain. BTS was installed under local workgroup account. Now can Biztalk access file located in a folder in a different network. FTP cannot be used. How can we access a file?
    Friday, November 4, 2011 2:42 PM

Answers

  • In the Authentication tab, there should be an option to supply valid credentials (domain account) to be used. Please note that the user account needs full control permission on the source folder.


    Randy Aldrich Paulo

    MCTS(BizTalk 2010/2006,WCF NET4.0), MCPD | My Blog



    • Edited by Randy Paulo Friday, November 4, 2011 2:56 PM
    • Proposed as answer by Tord G. Nordahl Monday, November 7, 2011 10:39 AM
    • Marked as answer by Kakko72 Thursday, November 10, 2011 5:00 PM
    Friday, November 4, 2011 2:55 PM

All replies

  • In the Authentication tab, there should be an option to supply valid credentials (domain account) to be used. Please note that the user account needs full control permission on the source folder.


    Randy Aldrich Paulo

    MCTS(BizTalk 2010/2006,WCF NET4.0), MCPD | My Blog



    • Edited by Randy Paulo Friday, November 4, 2011 2:56 PM
    • Proposed as answer by Tord G. Nordahl Monday, November 7, 2011 10:39 AM
    • Marked as answer by Kakko72 Thursday, November 10, 2011 5:00 PM
    Friday, November 4, 2011 2:55 PM
  • If your BizTalk host instance is running on a local account, you need the file adapter to impersonate another user (domain or local user on file share), and give that user the full control Randy mentions.

    To impersonate on the  file receive or send adapter:

    -Click on the Authentication tab

    -Check the "Use these Credentials.." checkbox.

    -Enter username (Domain|Other computer\Username) and password.

     

    Morten la Cour


    • Edited by la Cour Friday, November 4, 2011 5:46 PM
    • Proposed as answer by Tord G. Nordahl Monday, November 7, 2011 10:39 AM
    Friday, November 4, 2011 3:22 PM