none
Unable to Force ActiveX Installation for Local Machine Files RRS feed

  • Question

  • I support a vendor application that launches .htm files in Internet Explorer. These files have imbedded VBScript that works with a proprietary .dll file to connect it to another application. Because of IE11's dropped support for VBScript, I modified the pages with the Meta tag:

    <meta http-equiv="x-ua-compatible" content="IE=emulateIE9">

    This meta tag allows the content to be run, but you first have to allow it.

    The problem is that these pages prompt to "Allow blocked content" everytime they are launched, and I cannot figure out how to force them to install/run the activex controls.

    I have enabled ActiveX and done everything i can find within Group Policy, but no matter what i put in for the ActiveX Installer Service "Approved Installation Sites for ActiveX Controls" it does not approve it. Also because the file is being launched as "C:\Program Files (x86)\..." I get an error when i try to add it to trusted sites, even with the file:///C:/Program%20Files%20(x86)/... style.

    How can I force IE to allow these?  These computers are used for 911 dispatch and are not connected to the internet so I am okay with brute forcing it and allowing ActiveX to run from anywhere.

    Thank you!


    • Edited by twolfmain Wednesday, March 14, 2018 3:56 AM
    Monday, March 12, 2018 6:22 PM

Answers

  • Hi,

    Tools>Manage Addons>Show all addons>.... locate the vendors ActiveX control in the list and double click it to show its properties page... select the Copy button and post back with the details.

    The CLSID value is the key..... use it to search the registry.... some old Visual Basic/ocx ActiveX controls (like mshlp.ocx) may be in the IE kill bits list).

    Are you able to contact the vendor of the software for support?

    Regards.


    Rob^_^

    • Marked as answer by twolfmain Thursday, March 15, 2018 4:16 PM
    Thursday, March 15, 2018 2:26 AM

All replies

  • Hi,

    Tools>Internet Options>Advanced tab, check "Enable active content to run from files on my computer". !important: you must restart the computer for the changes to take affect.

    Group Policy Settings

    Local Computer Policy>Computer/User Configuration>Administrative Templates>Windows Components>Intenet Explorer>Internet Control Panel>Advanced page...

    To prevent users from making changes to their personal Internet Options disable tabs of the Internet Options using GPO.

    Regards.

    Questions regarding Internet Explorer 8, 9 and 10 and Internet Explorer 11 for the IT Pro Audience. Topics covered are: Installation, Deployment, Configuration, Security, Group Policy, Management questions.


    Rob^_^

    Wednesday, March 14, 2018 6:29 AM
  • Thank you very much!  Unfortunately that is already enabled.  The problem is that the activex control itself is a vendor made one that is not in the safe activex controls list.

    Do you know of the best way to add to this list?

    Tyler

    Wednesday, March 14, 2018 4:45 PM
  • Hi,

    Tools>Manage Addons>Show all addons>.... locate the vendors ActiveX control in the list and double click it to show its properties page... select the Copy button and post back with the details.

    The CLSID value is the key..... use it to search the registry.... some old Visual Basic/ocx ActiveX controls (like mshlp.ocx) may be in the IE kill bits list).

    Are you able to contact the vendor of the software for support?

    Regards.


    Rob^_^

    • Marked as answer by twolfmain Thursday, March 15, 2018 4:16 PM
    Thursday, March 15, 2018 2:26 AM
  • Thank you for this! This is what i ended up finding last night.  The activex control is a vendor created dll that is loaded at runtime of the .htm page, referenced with VBScript.  

    What i ended up doing in Group Policy was:

    Configuring the "Computer Configurations/Policies/Administrative Templates/Windows Components/Internet Explorer/Security Features/Add-on Management/Add-on List" to include the CLSID of the activex control and enabling with value 2 so user's could see it.

    Then I went into the Local Machine Zone policy and set all VBScript/ActiveX policy to enable instead of prompt.

    Thank you very much for your assistance, and I hope this helps other people in the future!

    Thursday, March 15, 2018 4:23 PM