locked
What recent Windows 8.1 update corrupted Remote Desktop capabilities? RRS feed

  • Question

  • I have been connecting to multiple Windows 7 and 8 computers at my office though a sonic-wall VPN without issue for years. This past week, my Remote Desktop suddenly stopped working. I have done all the research I can and found that some recent Windows Update may have caused the problem.

    I'm really not the event-log sniffing type, but I can do it with guidance.

    I can't afford to reinstall this computer from scratch. I just can't.

    Please let me know what steps to take to isolate and resolve the problem.

    Thank you!

    Thursday, October 2, 2014 2:40 AM

All replies

  • What's the error ?

    Arnav Sharma | http://arnavsharma.net/ Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Thursday, October 2, 2014 5:18 AM
  • Remote Desktop from Windows 8.1 computer will not connect to any client after a recent update.
    (It's all over the net as a problem, but I cannot isolate what KB# to reference to uninstall the update.)

    Most solutions talk about reinstalling from scratch. This would be an 8 hour task for me. Not time-efficient.

    One day it's working fine. I used it 10x a day.

    Updates came in overnight.

    Next day it doesn't connect. with the following window message:
    Remote Desktop can't connect to the remote computer for one of these reasons:

    1) Remote access to the server is not enabled [it is]

    2) The remote computer is turned off [um, no]

    3) The remote computer is not available on the network [but I CAN access it via the network]

    Not one setting on the system was changed manually. Just an update, but I can't find which one.

    P.S. There should be one more option that says:

    4) Microsoft installed an update that screwed up RDP and hasn't posted a fix yet.

    Any help would be appreciated. :-(

    Thursday, October 2, 2014 1:54 PM
  • I found this security update, but it did not resolve the inability to connect problem.

    MS14-030: Description of the security update for Remote Desktop Security Release for Windows: June 10, 2014

    http://support2.microsoft.com/kb/2965788

    Thursday, October 2, 2014 2:57 PM
  • Hi,

    I recommend you first record the list with recent updates and take some time to perform a system restore back to these updates and check if the RDP can work fine.

    Then manually install  these updates one by one, after each one, check your issue, so that we can easily determine which update may cause your issue.

    Let me know KB number of the update causing your issue, and I will help to do the deep research. If necessary, post a feedback of this update.


    Kate Li
    TechNet Community Support

    Friday, October 3, 2014 8:49 AM
  • Thanks Kate. I tried to do system restores, and none will complete successfully.

    I uninstalled the RDP update mentioned above, but when I look at the list of installed updates, it's still there with no option to uninstall. I think it might have been part of a roll-up as well.

    I am now uninstalling every update sequentially. Hoping I can find the culprit.

    Do you (or anyone reading) have any access to a Microsoft support KB that might point to what update caused this issue (I see the issue all over the internet, but no solutions.) If I knew what was changed or "tightened" I could fix it, but I'm at a loss with RDP.  It's just always worked. :-(

    Sunday, October 5, 2014 12:32 PM