locked
Auto-Generated computer names not updating in App Controller RRS feed

  • Question

  • When I create a new virtual machine in App Controller 2012 (RTM) with an auto-generated computer name (leaving the '*' wildcard in the 'computer name' field) I cannot connect or RDP to the machine when it has finished setting up.

    If I specify a 'computer name' it works fine.

    One thing I have noticed is that the 'Computer Name' field in the properties of an auto-generated machine displays '*.domainname.com' instead of updating to 'machinename.domainname.com'. When I launch a console connection I can see that it is trying to resolve '*.domainname.com'. When start the machine and launch an RDP connection it also attempts to connect to '*.domainname.com'. Obviously neither resolve.

    If I go directly to the host machine and connect via Hyper-V manager I can see that the machine name has been correctly auto-generated it just hasn't been passed back up to App Controller.

    I had previously been using the 'Self-Service Portal' and had no problems with the auto-generated name feature.

    Any ideas anyone?

    Tuesday, December 18, 2012 3:31 PM

Answers

  • SCVMM will fill in the computer name once it discovers it via the VM refresher.  I created a VM as well, specifying * for the computer name.  Then starting the VM, and after a while the VM refresher in VMM runs and discovers the guest OS name:

    Once this happens, the VM name shows up correctly in the VMM connection in AC as well, and you should be able to RDP to it:


    • Edited by John Shen (WS) Wednesday, December 19, 2012 9:00 AM
    • Marked as answer by window_eye1 Monday, January 14, 2013 4:30 PM
    Wednesday, December 19, 2012 8:58 AM