none
In our Prod and test env we are getting this error during the user profiles' sync RRS feed

  • Question

  • Hi,

      We are getting this error

     

    6803 in the event viewer and the same error is of type stopped-dll-exception in MIIS

     The management agent "MOSS-359dfd13-4e32-4d7d-853d-7ea685d48f95" failed on run profile "MOSS_FULLIMPORT_cc8dc694-fc8f-405b-aa2d-62091e61da8b" because the server encountered errors.

    Tried many links but could not find the relevant solution for this problem.

    Please help

     
    Wednesday, July 23, 2014 10:04 AM

All replies

  • I think the best way to help is for you to provide more detail about your configuration and what you are trying to accomplish.  Did this MA work before?  Did it suddenly stop working, if so what changed?  Was code updated on the FIM side?  Was there a change on the target system side?

    If this post has been useful please click the green arrow to the left or click Propose as answer

    Wednesday, July 23, 2014 11:09 AM
  • It never stops working but as you know there are many steps involved in any sync process and even after this error the sync process continues and also it updates the changes.

    Wednesday, July 23, 2014 12:18 PM
  • Hi.

    Please try the following steps:

    1. Tools > Management Agents (or click the Management Agents in the bar)
    2. Right-click on the MOSS-{guid} management agent and select Properties
    3. Go to the Configure Connection Information section in the left-hand pane
    4. In the connection information box, change the Connect To URL to be the same URL as listed as the “Public URL for Zone” for your CA in the AAM configuration.
    5. Re-enter the farm account username and password for good measure
    6. Save the configuration
    7. Run a full profile sync from CA

    I've seen this error in SharePoint User Profile a couple of times and such Full Synchronization should help.

    Another idea: You can try to insert web application root CA certificate into Trust on SharePoint Central Administration: 

    1. Export to cer file the root web application certificate (not the FQDN certificate, only the root)
    2. Go to Central Administration - Security - General Security - Manage Trust
    3. Click NEW, type a name and select the exported CER file
      Start the User Profile full synchronization.

      If your issue persists, you can refer to the blog:

      http://blog.helloitsliam.com/Lists/Posts/Post.aspx?ID=9

      Reference: http://social.technet.microsoft.com/Forums/sharepoint/en-US/44708c38-9b68-4411-94da-65734897a306/fim-sychronisation-service-with-6801-6803-6110-and-8311-errors?forum=sharepointadminprevious


    If you found my post helpful, please give it a Helpful vote. If it answered your question, remember to mark it as an Answer.

    Wednesday, July 23, 2014 1:13 PM