none
Project Site Template Issue in Project Server 2013 RRS feed

  • Question

  • I am testing out PS2013.  I downloaded my 2010 project site template and then uploaded it into 2013 & then activated it.  When I try to modify my EPT to make the uploaded template my default project site template, it is not listed in the drop down.  I don't see it in the Template Selection menu if I try to create a new subsite either.

    If I create a project site with the default site template, modify it and save it as a new template, I can see that new template in both EPT and the create site menu.

    I am not sure what is going on.  I would hate to create a new custom site from scratch.

    Any thoughts??


    Monday, November 18, 2013 8:30 PM

Answers

  • Hello,

    Unfortunately no way to trick it, not as far as I know anyway.

    Paul


    Paul Mather | Twitter | http://pwmather.wordpress.com | CPS

    Tuesday, November 19, 2013 7:46 PM
    Moderator
  • Hello,

    Set the site template on the EPTs, the site template setting on the Project Site Provisioning Settings in Project Server 2010 didn't do anything. Projects that aren't created from an EPT and straight from Project Pro will use the site template associated with the default EPT.

    Paul


    Paul Mather | Twitter | http://pwmather.wordpress.com | CPS

    Thursday, November 21, 2013 9:29 AM
    Moderator
  • Hello,

    I would start a new thread for your issue.

    As per the posts above, the site template setting on the Project Site Provisioning Settings in Project Server 2010 didn't do anything, this was just carried over from 2007. Projects that were created directly in Project Pro just used the site template specified on the default EPT - this is the same in PS2013. Microsoft have removed the default site template from the Project Site Provisioning Settings page as it was redundant.

    Paul


    Paul Mather | Twitter | http://pwmather.wordpress.com | CPS

    Tuesday, May 20, 2014 11:50 AM
    Moderator

All replies

  • Unfortunately you will need to create the template again, the 2010 version has the wrong site template ID so Project Server 2013 doesn't recognise it as a valid template.

    Paul


    Paul Mather | Twitter | http://pwmather.wordpress.com | CPS

    Monday, November 18, 2013 9:45 PM
    Moderator
  • Thanks Paul!

    I was afraid of an answer like that.  

    Any way I can trick the system?  Import a project site and then use it to create the template?

    Tuesday, November 19, 2013 4:03 PM
  • Hello,

    Unfortunately no way to trick it, not as far as I know anyway.

    Paul


    Paul Mather | Twitter | http://pwmather.wordpress.com | CPS

    Tuesday, November 19, 2013 7:46 PM
    Moderator
  • Hi Paul,

    So a follow up question.  I re-create the site template (fun!) and set it as the default type for my EPT but when I tried to set it as the default type in Project Site Provisioning Settings I discovered that for 2013 you only have "default site template language".  2010 had "default site template language" and "default project site template"

    How do I make my project site template apply to projects that are imported into 2013 and not created with an EPT?

    Thanks in advance!!

    Wednesday, November 20, 2013 4:40 PM
  • Hi,

    For any existing project site, unfortunately you need to delete and re-create project site using modified project site template, and associate your new site URL with project.

    You can use powershell script to expedite the process though, use the following powershell command to get the name/id of your site template:

    $web = Get-SPweb http://SiteUrl 
    Write-host
     “Web Template:” $web.WebTemplate ” | Web Template ID:” $web.WebTemplateId 
    $web.Dispose()

    and create new site using following powershell command, pass tempalte id/name so that your site will be based on new template:

    New-SPWeb http://somesite/subweb1 -Template "STS#0"

    http://technet.microsoft.com/en-us/library/ff607579.aspx

    hope this helps.



    Khurram Jamshed - MBA, PMP, MCTS, MCITP ( Blog, Twitter, Linkedin )
    If you found this post helpful, please “Vote as Helpful”. If it answered your question, please “Mark as Answer”.

    Thursday, November 21, 2013 9:06 AM
  • Hello,

    Set the site template on the EPTs, the site template setting on the Project Site Provisioning Settings in Project Server 2010 didn't do anything. Projects that aren't created from an EPT and straight from Project Pro will use the site template associated with the default EPT.

    Paul


    Paul Mather | Twitter | http://pwmather.wordpress.com | CPS

    Thursday, November 21, 2013 9:29 AM
    Moderator
  • Hi -sin,

    just to avoid any confusion between my response and Paul's reply to your follow up query, my reply is based on assumption that you want to apply update project site template to existing project sites. Whereas Paul's brilliant reply is to direct you to how to configure updated project site template to be used for any new project sites.

    hope this clarifies and helps you find your way out.


    Khurram Jamshed - MBA, PMP, MCTS, MCITP ( Blog, Twitter, Linkedin )
    If you found this post helpful, please “Vote as Helpful”. If it answered your question, please “Mark as Answer”.

    Thursday, November 21, 2013 9:34 AM
  • In Project Server 2010 you could specify what the default site template was as well as defining the site templates against defined EPT's - whilst some options carry over to 2013 I cannot find anywhere to define the default site template - reason I am asking is that I have encountered problems with my personal instance of Project Server and I deleted the project site for a project that had been created using an EPT with a custom site template defined. When I recreated the site from the "Connected SharePoint Sites" page it was the OOTB project site and it was corrupted like Carl Dalton experienced:

    http://carl-projectserver.blogspot.co.uk/2014/02/projectserver2013-curious-tale-of-2010.html

    I also found this info on Technet about available languages for the template:

    The languages available to you in the Default site template language drop-down list are:

    • The language of your base-installation of Project Server 2013.

    • The language of any installed Project Server 2013 language packs.

    For example, if you install the Project Server 2013 Spanish language pack on a Project Server 2013 English base installation, you can choose English or Spanish from the Default site template language drop-down menu. Selecting one or the other will determine the default language the Project Web App user interface will display in for newly provisioned instances of Project Web App.


    Dominic Moss MAPM, MCTS, MCITP, MCT
    Wellingtone PM News
    Wellingtone EPM Site
    Wellingtone PM Recruitment

    Tuesday, May 20, 2014 11:43 AM
  • Hello,

    I would start a new thread for your issue.

    As per the posts above, the site template setting on the Project Site Provisioning Settings in Project Server 2010 didn't do anything, this was just carried over from 2007. Projects that were created directly in Project Pro just used the site template specified on the default EPT - this is the same in PS2013. Microsoft have removed the default site template from the Project Site Provisioning Settings page as it was redundant.

    Paul


    Paul Mather | Twitter | http://pwmather.wordpress.com | CPS

    Tuesday, May 20, 2014 11:50 AM
    Moderator
  • Dear Paul - thanks for your swift answer, I now appreciate more clearly that the setting of the site template option was redundant in 2010 - I used to always edit it to be the same as a custom template just for consistencies sake, I knew about Default EPT setting the default site but had not appreciated that the set site template option was redundant.

    I have resolved my issue by creating a new project - I checked Carls blog and there was no update on the issue he had encountered with site corruption.


    Dominic Moss MAPM, MCTS, MCITP, MCT
    Wellingtone PM News
    Wellingtone EPM Site
    Wellingtone PM Recruitment

    Tuesday, May 20, 2014 11:57 AM