locked
Large Shared Mailboxes issue.. RRS feed

  • Question

  • Hello All.

     

    Cutting down quickly to the issue:

     

    Environment:

    Exchange 2010 Sp1 Ru3 (Re-relased version), Outlook 2007 SP2.

     

    Issue:

    1 of team requires to have or work with large shared mailboxes like average 3 to 6GB one. They have them configured in single Outlook profile.

    When i keep them under option "Download shared folders checked" under Outlook account settings, they get error message

    "The Message Store has reached its maximum size. To reduce the amount of data in the message store, select some items that you no longer need, permanently (shift+del) delete them"

    and when I keep same option un-chedked, i.e. keeping shared mailboxes in online mode, they get a diffferent issue

    "There are no items to show in this view"

    Now both issues are intermittent, and generally go away after trying one more time

    1. Click OK on the warning, try to save message with modified Subject line, and its saved

    2. Go to some other folder and return back, Emails are all in there.

     

    So users are kinda irritated with this behaviour and apparently this issue was not when the shared mailboxes were on Exchange 2003 SP2

     

    So far I have tried:

    1.       Creating New Outlook Profile along with OST, with & without download shared folders option.

    2.       Assigning shared mailboxes with Throttling Policy so that it allows any number of RCA connections

    3.       Tried to put OST size limit registries as per KB http://support.microsoft.com/kb/832925/

    4.       Assign a 30GB size limit to Aveda Salon mailbox, as its current usage is 7GB it is safe to apply same and Exchange 2010 can cause some goofy issues with unlimited size limit, we can remove it later if not applicable in resolution.

    ANY help will be greatly appreciated !!!

     

    Please revert back for any further details needed.

     

    P.S. Using OWA 2010 is not alternative as users have over a dozen shared mailboxes

    Thanks

    Ajay


    Thank You Ajay Kundnani
    Wednesday, June 15, 2011 8:00 PM

Answers

  • Okay here is what worked here:

    1. Installed Exchange 2010 SP1 RU5 (http://support.microsoft.com/kb/2582113 ) Issue reference (http://support.microsoft.com/kb/2559926)

    2. Pushed a GPO that configures all Outlook client such that shared folders are always viewed in online mode.

     

    Haven't heard back of any further issue from long which is a good sign.

    Note: Keeping shared folder in cached mode will grow size of OST file and end users will get send/receive error in Outlook for maximum size reached.

    Thanks for your support/assistance guys  - Technet forum always promises timely & precise responses. :-)


    Ajay Kundnani MCTS - Exchange 2007, 2010
    • Marked as answer by AJKL Sunday, October 2, 2011 9:49 PM
    Sunday, October 2, 2011 9:49 PM

All replies

  • If you have multiple users working from the same mailbox, cached mode will likely lead to an increase in "race conditions" where multiple people work on the same content at the same time, with some of them cancelling each other.  This can happen without cached mode, but it's going to be a lot worse in cached mode since users will have copies of the mailbox content on their workstations.  Outlook with Exchange is not tranactional in that Outlook doesn't lock records it works on like a transactional database system would.  Therefore, you may want to reconsider using cached mode for these mailboxes.

    Not to say that this isn't the correct forum, but you might want to post this question in the Outlook forum.

    http://social.technet.microsoft.com/Forums/en-US/outlook/threads


    Ed Crowley MVP "There are seldom good technological solutions to behavioral problems."
    Wednesday, June 15, 2011 8:43 PM
  • Thanks for pointing me to correct thread and wonderful explanation Ed. I have posted this question on Outlook thread.

    i thought it has to do more with Exchange 2010 design/settings than Outlook client. Also, as I mentioned I when I keep them in online mode, it creates issue "No items to show in this view".

    Also users have their own sub folders which they play with under those shared mailboxes so not sure if overlapping of content information is case here but it is very much possible (as I am not sure what they do with those mailboxes on hourly or minute by minute basis)

    Thanks again.

    Aj


    Thank You Ajay Kundnani
    Wednesday, June 15, 2011 10:25 PM
  • Well, users may be creating views on folders that may be causing problems with other users.

    Seriously you should consider how you are using these shared mailboxes.  There may be better options.


    Ed Crowley MVP "There are seldom good technological solutions to behavioral problems."
    Wednesday, June 15, 2011 10:48 PM
  • Hi Ajay,

    Per your description, it seems an issue, I would suggest that you could open a ticket from MS.

    Regards!
    Gavin
    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Tuesday, June 21, 2011 9:08 AM
  • Thanks Gavin. I will try and reach them, will post solution here if any I get from them.


    Ajay Kundnani MCTS - Exchange 2007, 2010
    Tuesday, June 21, 2011 9:50 PM
  • Okay here is what worked here:

    1. Installed Exchange 2010 SP1 RU5 (http://support.microsoft.com/kb/2582113 ) Issue reference (http://support.microsoft.com/kb/2559926)

    2. Pushed a GPO that configures all Outlook client such that shared folders are always viewed in online mode.

     

    Haven't heard back of any further issue from long which is a good sign.

    Note: Keeping shared folder in cached mode will grow size of OST file and end users will get send/receive error in Outlook for maximum size reached.

    Thanks for your support/assistance guys  - Technet forum always promises timely & precise responses. :-)


    Ajay Kundnani MCTS - Exchange 2007, 2010
    • Marked as answer by AJKL Sunday, October 2, 2011 9:49 PM
    Sunday, October 2, 2011 9:49 PM
  • That won't eliminate the problem but it will certainly reduce it.
    Ed Crowley MVP "There are seldom good technological solutions to behavioral problems."
    Monday, October 3, 2011 3:38 PM
  • I agree - it surely reduced it to extent that users are not experiencing it 95% of chances.
    Ajay Kundnani MCTS - Exchange 2007, 2010
    Friday, October 7, 2011 12:58 AM