locked
Unable to "Run As..." on AppV 5 applications RRS feed

  • Question

  • Hi Everyone,

    Hoping to get some further info on AppV 5, just in case anyone has come across this.

    Were running Windows 7 enterprise X64 - and on our live environment we still use AppV 4.5 SP3. Further to this, the guys and gals in the IT Department have separate logon accounts and admin accounts. As such, to remotely manage machine and the like we would "Run As..." an application and logon to the application with our admin account, while remaining logged onto our machines with our restricted accounts. 

    Now - while this seems to work fine in AppV 4.6, I'm finding that in my test environment if I try this on anything captured in AppV 5.1 the application simply doesn't load. The app loads fine if I just double click the icon, but when I "Run As..." I get as far as entering my admin credentials after selecting the "Run As..." option, and when I click OK nothing more happens. 

    Has anyone else come across this, or maybe this is a know "feature" of AppV 5?

    Thanks in advance,

    Ed

    Monday, October 26, 2015 1:45 PM

Answers

  • Have you published the application Globally or to the User?

    What is the mode of Deployment? For Standalone, it'll be -Global to publish an application to the Machine.


    Posted AS IS with No Warranties. Mark as Answer if this answers your question, It will help other community members.

    Monday, October 26, 2015 1:53 PM

All replies

  • Always sequence the application in a sequencer machine that has the same settings like that of client machine in-order to avoid issues. How is UAC handled?

    (Please click on "Vote as Helpful" and/or "Mark as Answer", if it has helped you.)

    app2pack.blogspot.com: app2pack.blogspot.com

    Monday, October 26, 2015 1:49 PM
  • Also try using procmon to capture shortcut launch for both local installed application and virtual package and compare it to find out the actual reason.

    (Please click on "Vote as Helpful" and/or "Mark as Answer", if it has helped you.)

    app2pack.blogspot.com: app2pack.blogspot.com

    Monday, October 26, 2015 1:53 PM
  • Have you published the application Globally or to the User?

    What is the mode of Deployment? For Standalone, it'll be -Global to publish an application to the Machine.


    Posted AS IS with No Warranties. Mark as Answer if this answers your question, It will help other community members.

    Monday, October 26, 2015 1:53 PM
  • Hi Vigneshwaran,

    We do that already - Our Sequencer machines are built the same way our client machines are built - same settings, same image, etc. UAC is disabled by default. 

    The issue we're having, I don't think is UAC related. We basically restrict admin rights across the network as a security measure. So none of the accounts that are used to log onto a machine have local admin rights. As you'll be aware, to remotely manage a machine you must have admin rights over that machine - so to get around this problem, when we run any admin tools we shift+right mouse click the application so that we can "Run As..." an admin account - essentially we're loading our admin tool with admin priviledges.

    This doesn't seem possible in AppV 5 - and was possible in AppV 4.6.

    Nothing has changed in our sequencing practice (other than the obvious changes of PVAD and the like recommended in the white paper for AppV 5).

    I hope this clarifies. 

    Kind regards,

    Ed

    Monday, October 26, 2015 1:56 PM
  • Try using RunAsAdmin or RunAsInvoker shim or if you explicitly require user to provide credentials then check the below link by Dan.

    http://packageology.com/2013/06/app-v-5-uac-file-virtualisation-virtualstore/


    (Please click on "Vote as Helpful" and/or "Mark as Answer", if it has helped you.)

    app2pack.blogspot.com: app2pack.blogspot.com

    Monday, October 26, 2015 1:59 PM
  • Hi Vino,

    Thank you for the pointer - it's basically pushed down by SCCM 2012 - not sure if I mentioned it earlier in the query but AppV 5 is kind of new to me so I'm not sure if I missed out some basic SCCM check box - I'll look for the global setting you suggested - I suspect it's as you say - only targetted at my specific user account. 

    Thanks for the pointer

    Ed

    Monday, October 26, 2015 2:01 PM
  • In this case, no need for SHIM as UAC is already disabled. Try the link I specified above and create an external manifest file with RequireAdministrator.

    (Please click on "Vote as Helpful" and/or "Mark as Answer", if it has helped you.)

    app2pack.blogspot.com: app2pack.blogspot.com

    Monday, October 26, 2015 2:08 PM
  • Hi Vigneshwaran,

    I'll try your suggestion also - thank you for the link, very educational read. 

    Cheers,

    Ed

    Monday, October 26, 2015 2:10 PM
  • Hi Vino, Hi Vigneshwaran,

    Looks like the answer was that -Global flag in the publishing of the app. 

    Just need to have a look at SCCM 2012 to see how I can incorporate that in there. 

    Thank you both for your efforts and advice on this. 

    Cheers,

    Ed

    Monday, October 26, 2015 2:38 PM
  • If you publish to users, your admin account need also be in the specific group. If you publish to machines, the app becomes available for all users (and also for your admin account).
    Monday, October 26, 2015 2:54 PM