locked
Failed to install WIndows update KB3045313 RRS feed

  • Question

  • Environment

    Our machine is running Windows Server 2012 R2 Standard and SQL Server 2008 R2 (SP2) - 10.50.4000.0 (Intel X86).

    Problem encountered

    When installing the update for KB3045313 in Windows Update, the following error was prompted (error screen attached):

    Error(s) found:

    Code 80246013 Windows Update ran into a problem.

    Then I tried to download the update from Microsoft and install the update manually, the following error was prompted (error screen attached):

    The following feature couldn't be installed:

    .NET Framework 3.5 (includes .NET 2.0 and 3.0)

    As .NET framework is not compulsory for SQL Server 2008 R2, how can we install the update for KB3045313 when SQL Server development using NET Framework 3.5 is not required for us.

    Thursday, September 1, 2016 9:47 AM

Answers

  • Hello,

    .NET Framework 3.5 is a software requirement of SQL Server 2008 R2. Please read about it on the URL below.

    https://msdn.microsoft.com/en-us/library/ms143506(v=sql.105).aspx



    Hope this helps.



    Regards,

    Alberto Morillo
    SQLCoffee.com

    Thursday, September 1, 2016 3:19 PM
  • Hi Edwin,

    From the point of yours- can see you are trying to update from windows for SQL server 2008R2, if you are not the SQL Admin/DBA      the I request you to stop & involve/notify to the appropriate guys who handles the sql.

    coming to your question as Albert said its an .NET 3.5 pre-requisites for sql server 2008R2 ,Also if you are going to remove/uninstall might lead other issues for the applications like sql/codes/ssis many components when dev guys use it .

    Also there are some command utility exuecute (or) manual install too-

    https://support.microsoft.com/en-in/kb/2734782
    http://techhead.co/vmware-vcenter-server-5-x-install-on-w2k12-fix-the-following-feature-couldnt-be-installed-net-framework-3-5/

    but advising to check with appropriate team before next course of action plan.

    Also for sql server 2008 r2 latest SP is also exists & it is not recommended that autoupdate should perform sql rather than inform to the team who handles it.


    Regards, S_NO "_"

    Friday, September 2, 2016 3:08 AM

All replies

  • http://answers.microsoft.com/en-us/windows/forum/windows8_1-update/getting-an-error-code-80246013-failed-to-complete/0d18f6b3-4878-4631-80e1-aed9cb1ec717?auth=1

    Please click Mark As Answer if my post helped.

    Thursday, September 1, 2016 2:36 PM
  • Hello,

    .NET Framework 3.5 is a software requirement of SQL Server 2008 R2. Please read about it on the URL below.

    https://msdn.microsoft.com/en-us/library/ms143506(v=sql.105).aspx



    Hope this helps.



    Regards,

    Alberto Morillo
    SQLCoffee.com

    Thursday, September 1, 2016 3:19 PM
  • Hi Edwin,

    From the point of yours- can see you are trying to update from windows for SQL server 2008R2, if you are not the SQL Admin/DBA      the I request you to stop & involve/notify to the appropriate guys who handles the sql.

    coming to your question as Albert said its an .NET 3.5 pre-requisites for sql server 2008R2 ,Also if you are going to remove/uninstall might lead other issues for the applications like sql/codes/ssis many components when dev guys use it .

    Also there are some command utility exuecute (or) manual install too-

    https://support.microsoft.com/en-in/kb/2734782
    http://techhead.co/vmware-vcenter-server-5-x-install-on-w2k12-fix-the-following-feature-couldnt-be-installed-net-framework-3-5/

    but advising to check with appropriate team before next course of action plan.

    Also for sql server 2008 r2 latest SP is also exists & it is not recommended that autoupdate should perform sql rather than inform to the team who handles it.


    Regards, S_NO "_"

    Friday, September 2, 2016 3:08 AM
  • In my Windows 2012 R2 Server.  Microsoft SQL Server 2008 R2 was installed.

    Checked that .NET Framework 4.5 was installed but .NET Framework 3.5 was not installed 

    Then we upgraded SQL Server to SQL Server 2014.  We successfully upgraded to SQL Server 2014.  It was mentioned at https://msdn.microsoft.com/en-us/library/ms143506(v=sql.120).aspx  that .NET framework 3.5 SP1 was required for installing SQL Server 2014 but actually we did not.

    The current status of my server is as follows.

    1. The following programs were shown in Programs and Features:

    - Service Pack 2 for SQL Server 2008 R2 (KB2630458)

    - Microsoft SQL Server 2014 Setup (English)

    2. .NET Framework 4.5 was enabled but .NET Framework 3.5 was not enabled (as revealed in Windows Roles and Features)

    So anyone can share why we can install SQL Server 2008 and SQL Server 2014 without .NET Framework 3.5.  How can we install the update for KB3045313 successfully without .NET framework 3.5 ?

    Monday, October 17, 2016 10:24 AM