none
Error 0x204 with Microsoft Remote Desktop on Catalina RRS feed

  • Question

  • I keep getting  Error code 0x204 ("Unable to connect. We couldn't connect to the remote PC. Make sure the PC is turned on and connected to the network, and the remote access is enabled"). when trying to connect to my office computer by Microsoft Remote Desktop on Mac OS Catalina 10.15.7 MacBook Pro (2019). I get this error in 90% cases, and in 10% cases I manage to connect. I successfully connect to VPN server (Forticlient) but Microsoft Remote Desktop doesn't work.

    I checked another computer MacBook Pro (2013) MacOS Mojave 10.14.6 everything works fine.

    If I try connecting through mobile internet on Catalina MacBook Pro (2019) everything works fine.

    If I try connecting through home wifi internet (asus router) on Catalina MacBook Pro (2019), I get 204 error.

    It's strange that the problem is in internet because I don't get error 204 on MacBook Pro (2013) MacOS Mojave with the same home wifi internet..

    What i tried and it didn't help:

    1) checked internet connection with provider

    2) deleting and installing Microsoft Remote Desktop

    3) installing Microsoft Remote Desktop Beta 

    4) and the method below with moving folders in libraries. After moving folders com.microsoft.rdc.macos etc. to another place (desctop for example) they keep getting back to Containers and Group Containers

    ________________________________________________

    Quit RDP on the Mac, hold the option key & click on the Go menu to enable showing the Library & select that.

    Within that user's Library (NOT the top-level Library folder),

    navigate into Containers and set aside com.microsoft.rdc.macos and com.microsoft.rdc.mac  (one of those is for v8, just pull them both aside).

    go back to the User's Library and open the Group Containers folder.

    Set aside the folder

    UBF8T346G9.com.microsoft.rdc

    In the Terminal (logged in as the user in question) issue the following, which will reset (kill and it will then auto-relaunch) the preference caching daemon, as prefs are AGGRESSIVELY cached in current versions of OS X.

    killall cfprefsd

    ______________________________________________

    Does anyone have a solution?

    Thanks a lot!

    Best regards


    • Edited by ffffkkkk Monday, November 2, 2020 6:51 PM
    Monday, November 2, 2020 6:47 PM

All replies

  • https://login.live.com/login.srf?wa=wsignin1.0&rpsnv=13&checkda=1&ct=1604344687&rver=6.7.6643.0&wp=MBI_SSL&wreply=https:%2F%2Fanswers.microsoft.com%2Fen-us%2Fsite%2Fcompletesignin%3Fsilent%3DTrue%26returnUrl%3Dhttps%253A%252F%252Fanswers.microsoft.com%253A443%252Fen-us%252Fwindows%252Fforum%252Fall%252Freceiving-error-0x204-attempting-to-connect-to-a%252F4470c6d8-bdb0-428e-8c9b-ab4661fb57e2%253Fauth%253D1&id=273572&aadredir=1

    I hope it will help please vote if it works...

    Monday, November 2, 2020 7:18 PM
  • Thank you

    Could anyone suggest which firewall settings can I try to change?

    Monday, November 2, 2020 7:50 PM