locked
Application Partition Discovery failed because permission was denied to the LDAP instance RRS feed

  • Question

  • Hi,

    I'm trying to deploy the AD LDS Management Pack but I receive this alert: Application Partition Discovery failed because permission was denied to the LDAP instance. I've setup the proper runas account that has permission on the application partion and followed all instructions in the documentation. When I looked into the event log I found the following error description:

    LDS Application Partition Discovery : The script 'ApplicationPartitionDiscovery.vbs' failed to get the FSMO owner from 'LDAP://localhost:389/CN=NTDS Settings\0ADEL:8e211d56-b1a3-45c4-9442-f3675bd202c8,CN=PRODLDSEN1$<AD LDS Instance>\0ADEL:e55c7c35-62df-422d-a27d-02073d094871,CN=Servers,CN=PROD,CN=Sites,CN=Configuration,CN={34A03B5D-EF59-4CC3-B475-E03C56DD453A}'.

    The error returned was: 'There is no such object on the server.' (0x80072030). This script was executed as <hostname>\<user account> S-1-5-21-2276015955-2337790395-3574248464-1003.

    It seems the script could not find the proper instance during its execution.

    Thanks in advance,

    Giancarlo.

    Friday, October 29, 2010 1:05 AM

All replies

  • This is very likely a permission problem.  Try running the script with a credential that can get the FSMO data.

     

     


    Microsoft Corporation
    • Proposed as answer by Heldesk Friday, September 25, 2015 2:13 PM
    Friday, October 29, 2010 4:36 PM
  • I tried either running with local system account and a specific account created to run the AD LDS instance. I don't think it is a permission issue because I also tried to add them to the Administrators role through ADSIEDIT and they already belong to that role. As I highlighted I believe the discovery cannot find the instance running on the server.
    Sunday, October 31, 2010 11:53 PM
  • Don't follow Vivian Xing's links - they're malicious.
    Friday, September 25, 2015 2:13 PM