none
Using Microsoft R Server packages (e.g., RevoScaleR) with RStudio Server RRS feed

  • Question

  • I am using Microsoft R Server (MRS 8.0.5) on a Hadoop cluster. MRS packages (RevoScaleR, RevoPemaR) work well at the command line, but I can't use them with RStudio Server. It seems these packages are not available for Rstudio server. Other packages (such as RevoIOQ, RevoMods) are OK. This might be a configuration issue, but there is no other versions of R on my cluster, only Microsoft R Open (MRO) for MRS.

    The problem is that I can't use MRS packages in Rstudio Server IDE.

    I get an error when I write:

    > library(RevoScaleR)

    Error in library (RevoScaleR) : there is no package called RevoScaleR?

    Friday, November 11, 2016 7:11 AM

All replies

  • If you've installed R Server and RevoScaleR is available and working from the R command line, then you may just need to point RStudio to R Server as the version of R to use. For more info see this RStudio article: https://support.rstudio.com/hc/en-us/articles/200486138-Using-Different-Versions-of-R

    Monday, November 14, 2016 12:55 AM
  • RStudio Server is already configured to work with R Server (Revo64), but we still have the same problem. 

    I don't know if this is related to the R server license. We are using R Server for academics and students via DreamSpark.  

    Friday, November 18, 2016 6:00 AM
  • @Ansiwen, I ran into that same issue trying RevoScaleR with RStudio 3.3.2.  After further research I found a Microsoft site (https://support.microsoft.com/en-us/kb/3104227) that stated: "The Revolution packages - RevoScaleR, RevoPemaR, RevoBaseEnt... are optimized to run only on the distribution included with Revolution R Enterprise.  They do not run outside that application."

    Since RevoScaleR is included with Microsoft R Client, RevoScaleR should already be available if you have Microsoft R Client installed.  I used Microsoft R Client and it worked.

    Immediately after switching to Microsoft R Client issue the R command   search()    and you will see "package:RevoScaleR"  in your result set.

    It might also work in RTVS if you set the R interpreter to C:/Program Files/Microsoft/R Client/R_SERVER/


    SOTATS, Inc.



    Monday, November 21, 2016 1:30 AM

  • Actually, this works fine with RStudio Desktop on Windows, but my problem is with RStudio Server on Linux.   

    Monday, November 21, 2016 11:13 AM
  • If R Server is working from the R command line tool then this looks like a question for RStudio.  Please try their technical support.
    Monday, December 12, 2016 11:42 PM

  • I'm following these guidelines, but the problem has not been solved yet! 

    https://support.rstudio.com/hc/en-us/articles/235841328-Using-RStudio-Server-with-Microsoft-R-Server-for-Cloudera

    Tuesday, December 20, 2016 8:14 AM
  • Those instructions should work with RStudio Server Pro.  Are you using the community version?   
    Friday, December 23, 2016 4:45 AM
  • Did your issue get resolved? I am trying to guide a customer who is using RStudio Server pro already and wants to use it on both the Windows and Linux DSVM and have the same web accessible link to share with internal users like they do today with their on premise RStudio Server Pro box setup - What are the guidelines or where can I get them to share with this customer about this use case?

    laedell (MSFT alias)

    Wednesday, August 15, 2018 8:55 PM
    1. On a machine with unrestricted internet access:

      1. Download Microsoft R Client from https://aka.ms/rclient/.

      2. Download the Microsoft R Open ( *.cab) needed to install R Client from https://go.microsoft.com/fwlink/?LinkId=852724.

      3. Download .NET Framework 4.5.2 from https://www.microsoft.com/download/details.aspx?id=42642.

      4. Download, if desired, the .cab file for pre-trained machine learning models from: https://go.microsoft.com/fwlink/?LinkId=852727. Learn more about these pre-trained models.

      5. Copy the downloaded files to a network share or portable drive.

    2. On the machine with restricted internet access:

      1. Log in with administrator privileges.

      2. Copy the .cab file and R Client installer from the network share/portable drive on the first machine to the machine that has restricted internet access. Put the CAB files in the setup user's temp folder under %temp%.

      3. Copy and install the .NET Framework. Restart your computer if you installed the .NET Framework.

      4. Run RClientSetup.exe, which finds the cab file in the temp folder for you.

    https://docs.microsoft.com/en-us/machine-learning-server/r-client/install-on-windows 


    ayaz

    Thursday, August 23, 2018 4:09 PM