none
OpsMgr 2012 SP1: Operational Data Reporting Failed - Unable to determine if watson (DW20.exe) is installed

    Question

  • Hello,

    I am receiving the following alert on a new OpsMgr 2012 SP1 installation. Anyone have any idea how to solve the problem?:

    Operational Data Reporting Failed
    The alert description states: Unable to determine if watson (DW20.exe) is installed

    This alert is sourced from the following event log entry on the Management Server:

    Log Name: Operations Manager
    Source: Operational Data Reporting
    Event Number: 101
    Description: Unable to determine if watson (DW20.exe) is installed

    ************************

    Server information:

    OpsMgr 2012 SP1 installed on Windows Server 2012, fully-patched

    Operations Database is on a separate database server running SQL Server 2012 SP1 x64 on Windows Server 2012. OS is fully-patched

    Data Warehouse, OpsMgr Reporting, and Web Console are on a third server running SQL Server 2012 SP1 x64 on Windows Server 2012. OS is fully-patched.

    ************************

    Additional details:

    I have Operational Data Reporting enabled and wish to leave it that way.

    I installed .NET 3.5 on the Management Server to try and fix this issue. I now see dw20.exe present in C:\Windows\Microsoft.NET\Framework\v2.0.50727 and C:\Windows\Microsoft.NET\Framework64\v2.0.50727. I do not see it in any of the C:\Program Files or C:\Program Files (x86) folders.

    Thanks in advance!
    Frank

    Monday, March 4, 2013 3:29 AM

All replies

  • Hi,

    Regarding the alert, please check it referring to the following article:

    Operational Data Reporting submission failed Rule

    http://mpwiki.viacode.com/default.aspx?g=posts&t=99847

    Thanks.

    Nicholas Li
    TechNet Community Support

    Wednesday, March 6, 2013 6:08 AM
    Moderator
  • Nicholas,

    Thanks for the response. I've seen that page and it's what pointed me to the fact that dw20.exe is not present in the C:\Program Files folders. It seems that on Windows Server 2012, dw20.exe is no longer placed within the "%ProgramFiles%\Common Files\Microsoft Shared\DW" folder, as per the page that you linked. As I said, after installing .NET 3.5 SP1, I only see dw20.exe present in C:\Windows\Microsoft.NET\Framework\v2.0.50727 and C:\Windows\Microsoft.NET\Framework64\v2.0.50727.

    I'm going to try manually creating the Program Files folder structure and copying dw20.exe over to it. I'll report back with my findings.

    EDIT: I've manually copied C:\Windows\Microsoft.NET\Framework64\v2.0.50727\dw20.exe to C:\Program Files\Common Files\microsoft shared\DW and C:\Windows\Microsoft.NET\Framework\v2.0.50727\dw20.exe to C:\Program Files (x86)\Common Files\microsoft shared\DW. But this did not work: on Saturday at 10:00 PM I see the "Operational Data Reporting" event ID 101 in the Operations Manager event log and the alert was regenerated.

    -Frank


    • Edited by Frank E Lesniak Monday, March 25, 2013 8:19 PM Provided an update on my attempt to resolve issue
    Monday, March 18, 2013 1:16 PM
  • I tried building the C:\Program Files\Common Files\microsoft shared\DW & C:\Program Files (x86)\Common Files\microsoft shared\DW folder structures on the Reporting server, but that also did not work.

    Next I am going to try and set up a Process Monitor trace on all three servers this Saturday at 10 PM to try and find out why Operations Manager is throwing this error.

    In the meantime, please let me know if anyone has any ideas. Surely others must be experiencing this issue...

    Monday, April 1, 2013 2:17 PM
  • Frank,   Very curious to see if you have resolved this as I am experiencing the same issue, same behavior.
    Tuesday, June 18, 2013 3:33 PM
  • John,

    I have not resolved it yet. Unfortunately I have not been able to catch the Saturday 10 PM ODR process with Process Monitor.

    Thanks
    Frank

    Tuesday, June 18, 2013 3:35 PM
  • Also seeing this issue, .NET is installed but dw20.exe is only in the .\Windows\Microsoft.NET dir
    Sunday, September 15, 2013 9:19 PM
  • I captured the ODR process this evening. I am still investigating, but here is what I know so far:

    • The following command line executes and runs as the Management Server Action Account:
      "D:\Program Files\System Center 2012\Operations Manager\Server\Reporting\OperationalDataReporting.exe" /ReportingServerUrl:http://opsmgrreporting.domain.com:8080/ReportServer /ReportsRootFolder:/ODR
    • Replace D:\ with the drive letter on which OpsMgr is installed
    • Replace http://opsmgrreporting.domain.com:8080/ReportServer with the URL to the OpsMgr Reporting server

    Running this command at the command prompt reproduces the error.

    Sunday, September 22, 2013 3:19 AM
  • any resolution or traction on this? I'm seeing this behavior as well.

    Jeffrey S. Patton Jeffrey S. Patton Systems Specialist, Enterprise Systems University of Kansas 1001 Sunnyside Ave. Lawrence, KS. 66045 (785) 864-0242 | http://patton-tech.com

    Wednesday, February 26, 2014 9:41 PM
  • Bump. SCOM 2012R2 UR4 reproduces the same error.

    Brand new install on Windows Server 2012R2; EventID 101 Operational Data Reporting.

    I do not have .NET 3.5 installed, and it is not listed as a pre req. https://technet.microsoft.com/en-us/library/dn249696.aspx.

    Popped up with the same message on one of my management servers, which has the exact same build as the others.

    Saturday, February 7, 2015 12:17 PM
  • Bump for me too.  Brand new 2012 R2 servers, same as everybody else.  No resolution, I take it?

    ETA: .Net 3.5 is installed.

    Tuesday, May 5, 2015 3:51 PM