locked
APP V 5 Beta RRS feed

  • Question

  • I Have Installed APP V 5 Beta Server.I have sequenced the Adobe application through APP V 5 Sequencer.

    I can't import the package on Microsoft Application Virtualization console.

    he gives this message

    An unexpected error occurred while retrieving the package at \\appvserver\Content\Adobereader10\Adobereader10.appv. Please ensure that it exists and that the package’s file permissions allow the management service to access it.

    I am not able to register server in APP V console.

    Thanks,

    Nuni


    N R Raju

    Tuesday, June 5, 2012 9:41 AM

Answers

  • Once i installed Microsoft KB2533623 in Sequencer system. i was able  to import the appv packages in app-v server 5.0.

    Thanks,

    Nuni


    N R Raju


    Thursday, June 14, 2012 11:44 AM

All replies

  • Did you set the share permissions on your content folder?

    PLEASE MARK ANY ANSWERS TO HELP OTHERS Blog: rorymon.com Twitter: @Rorymon

    Tuesday, June 5, 2012 2:40 PM
  • Also see this thread: http://social.technet.microsoft.com/Forums/en-GB/appvserverandmanagement/thread/89e9affb-de55-42e4-93b9-c93a5200cc7e


    Twitter: @stealthpuppy | Blog: stealthpuppy.com

    This forum post is my own opinion and does not necessarily reflect the opinion or view of Microsoft, its employees, or other MVPs.

    Please remember to click "Mark as Answer" or "Vote as Helpful" on the post that answers your question (or click "Unmark as Answer" if a marked post does not actually answer your question). This can be beneficial to other community members reading the thread.

    Tuesday, June 5, 2012 5:00 PM
    Moderator
  • I have set the permissins. still i am geting the error .

    Thanks,

    Nuni


    N R Raju

    Wednesday, June 6, 2012 4:36 AM
  • What permissions have you set? Are you adding the application from a remote machine or from the console of the Management Server itself? Does the package exist locally on the Management Server or is it located on a separate server?


    Twitter: @stealthpuppy | Blog: stealthpuppy.com

    This forum post is my own opinion and does not necessarily reflect the opinion or view of Microsoft, its employees, or other MVPs.

    Please remember to click "Mark as Answer" or "Vote as Helpful" on the post that answers your question (or click "Unmark as Answer" if a marked post does not actually answer your question). This can be beneficial to other community members reading the thread.

    Wednesday, June 6, 2012 6:51 AM
    Moderator
  • I have set the read and write access permissions to the content folder for appv admin user .

    I have accessed the application local server and remote.

    Package is  accessing from local system.

    Thanks,

    Nuni


    N R Raju

    Wednesday, June 6, 2012 8:48 AM
  • What about permissions for SYSTEM or NETWORK SERVICE? The account that IIS is running under most likely requires permissions to the content share as well.


    Twitter: @stealthpuppy | Blog: stealthpuppy.com

    This forum post is my own opinion and does not necessarily reflect the opinion or view of Microsoft, its employees, or other MVPs.

    Please remember to click "Mark as Answer" or "Vote as Helpful" on the post that answers your question (or click "Unmark as Answer" if a marked post does not actually answer your question). This can be beneficial to other community members reading the thread.

    • Proposed as answer by AdamIN1 Thursday, June 21, 2012 4:36 AM
    Wednesday, June 6, 2012 10:22 AM
    Moderator
  • IIS is running in local system account.I have provided permissions to the local system account for content folder.

    I do not see any APPV Services in services.msc.

    Thanks,

    Nuni.


    N R Raju

    Thursday, June 7, 2012 8:25 AM
  • And what is the result?


    Twitter: @stealthpuppy | Blog: stealthpuppy.com

    This forum post is my own opinion and does not necessarily reflect the opinion or view of Microsoft, its employees, or other MVPs.

    Please remember to click "Mark as Answer" or "Vote as Helpful" on the post that answers your question (or click "Unmark as Answer" if a marked post does not actually answer your question). This can be beneficial to other community members reading the thread.

    Thursday, June 7, 2012 9:09 AM
    Moderator
  • Same Error.

    An unexpected error occurred while retrieving the package at \\appvserver\Content\Adobereader10\Adobereader10.appv. Please ensure that it exists and that the package’s file permissions allow the management service to access it.

    Thanks,

    Nuni


    N R Raju


    Thursday, June 7, 2012 10:51 AM
  • you can see the APPV Services on IIS Manager {%APPVserver%\sites\Microsoft App-V management Service}
    • Edited by SA_ALA Thursday, June 7, 2012 11:55 AM
    Thursday, June 7, 2012 11:42 AM
  • One possible cause (in spite of the error wording) is a damaged APPV file.

    If you decided to poke around your package file: renaming it to a ZIP, opening it up and saving it, this can cause a damaged APPV file.  Although the format is readable by zip programs, the "streaming" information needed by the client will be wrong if you make any changes, save the file, and name it back to APPV.  It will absolutely corrupt the package if you launched the app for a small FB1, and maybe corrupt it if you did not.

    If you want to poke around, make a copy of the APPV file and rename that one!


    Tim Mangan MVP for App-V and Citrix CTP Author of AppV books: "The Client Book" and "OSD Reference Book" (http://www.tmurgent.com/Books )

    Saturday, June 9, 2012 2:55 PM
    Moderator
  • Once i installed Microsoft KB2533623 in Sequencer system. i was able  to import the appv packages in app-v server 5.0.

    Thanks,

    Nuni


    N R Raju


    Thursday, June 14, 2012 11:44 AM
  • for me, i made a Windows update on management server. 

    After Windows Update, it work well and i have publishing an application with success. (Sorry if my language is bad, i'm french !)

    Friday, June 15, 2012 11:53 AM
  • Aaron, I followed your advice and it worked.  I was experiencing the same issues as others in this thread.  I had added my Appv_Users and Appv_Admins groups and gave them the proper share persmissions to my content/repository share using the advanced sharing feature but I was still experiencing the error when attempting to import a package into the Management Console.  I added the Everyone group temporarily to verify that it was a permissions issue.  Once I verified it was a permissions issue I removed the Everyone group and added the Network Service account.  Once I added the Network Service account and gave it read permissions to my content share I was able to import my package successfully.  Thank you for your help on this!

    I tried the other KB suggestion that others were referring to but that did not work for me.  That KB was released in 2011 and my system was already up-to-date with the latest hotfixes and patches.

    As a side note, Nuni - it looks like you might have a more serious issue since you are unable to register the publishing server in the App-V console.

    Thursday, June 21, 2012 4:36 AM