none
Problem Allowing Access to Certain web Addresses in SteadyState RRS feed

  • Question

  • I am creating a lobby PC for customers to use to accesstwo primary websites, one for an on-line energy audit and another for participation in a campaign. I have taken the steps described in the Handbook (pg 26) several times over several months and what happens is that once I log in as the restricted user, I cannot access the Internet at all. My two main websites are: www.sussexrec.com and www.ourenergy.coop. If I go back and remove the web address restricitions, the problem goes away but the PC is open to any web address. The solution for the .edu web addresses does not help with my situation.

    Thanks for the help.

    Sincerely,

    T. Tate
    Thursday, August 27, 2009 7:10 PM

Answers

  • Hi Guys,

    If you want to restrict Internet access to specific sites use the Content Advisor in IE instead of SteadyState.

    Copy and Paste this content into Notepad.  Save as noaccess.rat into C:\Windows\System32

    ((PICS-version 1.0)
     (rating-system "http://www.microsoft.com")
     (rating-service "http://www.microsoft.com")
     (name "Noaccess")
     (description "This file will block all sites.")

     (category
      (transmit-as "m")
      (name "Yes")
       (label
       (name "Level 0:   No Setting")
       (description "No Setting")
       (value 0) )
      (label
       (name "Level 1:   No Setting")
       (description "No Setting")
       (value 1) ) ))


    Now go to the Tools tab in IE.  Internet Options. Content Tab.  Settings Button.  General Tab. Rating Systems button.  Remove the Rating System loaded and Add noaccess.rat.  This will block all sites accept the ones you now specify in the Approved Sites tab.  Remember to use the * wildcard so you don't get blocked going from www.msn.com to www.server1.msn.com.   Exit out to the Content tab and make sure to Enable the Content Advisor and password it.  

    Tuesday, September 22, 2009 7:16 PM

All replies

  • Hi T.Tate, thanks for the post.

    Firstly, I would like to inform you that when you select the “Prevent Internet access (except Web Sites below)” option, the system will set the proxy server in IE to a non-exist one (NoInternetAccess) and add websites allowed to the “Exceptions”. The “Use the same proxy server for all protocols” option is checked. Thus, all website accesses except for those allowed sites are blocked. According to its working theory, if you already have a proxy server and which is the exclusive Internet access, “Prevent Internet access” option will not work.

    Let's manually set proxy server and check the result this time.

    1. To avoid confusion, please clear the “Prevent Internet access (except Web sites below)” option in SteadyState first.
    2. Click Start and click Run.
    3. Type “inetcpl.cpl” in the open box, and then press Enter.
    4. Select the Connections tab, click LAN Settings.
    5. Uncheck “Automatically detect settings”, select “Use a proxy server for your LAN. Input NoInternetAccess to the Address box, 80 to the port box.
    6. Click Advanced, select “Use the same proxy server for all protocols”
    7. Type some websites in the Exceptions space. Click OK.
    8. Check if websites can be accessed or not.

    Meanwhile, you can also try unlocking the profile and disabling all internet restrictions, then logging on as the restricted user and visiting the allowed sites.  Log off, then log on as the administrator, open the restricted user in SteadyState, lock the profile and select the desired internet restrictions again.  Sometimes some of the restrictions in place prevent Internet Explorer from initializing something, which ends up preventing the allowed web sites from showing.  By relaxing the restrictoins and visiting the site once, Internet Explorer is able to initialize everything, so after the restrictions are enabled, the page should still be available.

    Hope this helps!


    Sean Zhu - MSFT
    Monday, August 31, 2009 4:01 AM
    Moderator
  • Sean:

    Thank you for the detailed response. I went through all the steps you suggested and had the same end result - when the Internet restriction is checked, the user account cannot access the Internet at all. As I type in my expections, I type them without the http and www headers, seperate them with a semicolon and no spaces. I also entered the list of allowed sites starting with an asterisk before the first allowed site as the pop up illustrates in the SteadyState panel. I tried it without the asterisk as well. Just about every possible combination has been tried.

    Is there some detail about our network you need to have to offer further guidance? I am connecting wirelessly if that makes a difference. If it simply will not work in my situation that is not a severe problem as the PC resides in our lobby and I can easily correct issues users may inflict upon the system:>)

    Thanks again.

    Sincerely,

    Tom Tate
    Tuesday, September 1, 2009 3:47 PM
  • I am having the exact same problem at Tom, and advice is greatly appreciated.

    Thanks,
    Marty
    Tuesday, September 1, 2009 5:17 PM
  • Hi Guys,

    If you want to restrict Internet access to specific sites use the Content Advisor in IE instead of SteadyState.

    Copy and Paste this content into Notepad.  Save as noaccess.rat into C:\Windows\System32

    ((PICS-version 1.0)
     (rating-system "http://www.microsoft.com")
     (rating-service "http://www.microsoft.com")
     (name "Noaccess")
     (description "This file will block all sites.")

     (category
      (transmit-as "m")
      (name "Yes")
       (label
       (name "Level 0:   No Setting")
       (description "No Setting")
       (value 0) )
      (label
       (name "Level 1:   No Setting")
       (description "No Setting")
       (value 1) ) ))


    Now go to the Tools tab in IE.  Internet Options. Content Tab.  Settings Button.  General Tab. Rating Systems button.  Remove the Rating System loaded and Add noaccess.rat.  This will block all sites accept the ones you now specify in the Approved Sites tab.  Remember to use the * wildcard so you don't get blocked going from www.msn.com to www.server1.msn.com.   Exit out to the Content tab and make sure to Enable the Content Advisor and password it.  

    Tuesday, September 22, 2009 7:16 PM
  • Morakan:

    Thanks a million, this worked perfectly!

    Sincerely,

    Tom
    Tuesday, September 29, 2009 5:27 PM
  • Morakon,

    In your example above you have http://www.microsoft.com as the only excepted site in the noaccess.rat you created.  Where would a person put more sites if you wanted to allow access to more sites?  Would it look like this? (below)  Also say I want users to be able to view all the content within the www.site1.com domain as I mention below.  Do I change it to (rating-system "http://*.site1.com ")
     (rating-service "http://*.site1.com ")



    ((PICS-version 1.0)
     (rating-system "http://www.site1.com ")
     (rating-service "http://www.site1.com ")
    (rating-system "http://www.site2.com ")
     (rating-service "http://www.site2.com ")
     (name "Noaccess")
     (description "This file will block all sites.")  (category
      (transmit-as "m")
      (name "Yes")
       (label
       (name "Level 0:   No Setting")
       (description "No Setting")
       (value 0) )
      (label
       (name "Level 1:   No Setting")
       (description "No Setting")
       (value 1) ) ))

    Thank you for any assistance.
    Tuesday, October 20, 2009 7:20 PM
  • Hi Guys,

    If you want to restrict Internet access to specific sites use the Content Advisor in IE instead of SteadyState.

    Copy and Paste this content into Notepad.  Save as noaccess.rat into C:\Windows\System32

    ((PICS-version 1.0)
     (rating-system "http://www.microsoft.com ")
     (rating-service "http://www.microsoft.com ")
     (name "Noaccess")
     (description "This file will block all sites.")

     (category
      (transmit-as "m")
      (name "Yes")
       (label
       (name "Level 0:   No Setting")
       (description "No Setting")
       (value 0) )
      (label
       (name "Level 1:   No Setting")
       (description "No Setting")
       (value 1) ) ))


    Now go to the Tools tab in IE.  Internet Options. Content Tab.  Settings Button.  General Tab. Rating Systems button.  Remove the Rating System loaded and Add noaccess.rat.  This will block all sites accept the ones you now specify in the Approved Sites tab.  Remember to use the * wildcard so you don't get blocked going from www.msn.com to www.server1.msn.com .   Exit out to the Content tab and make sure to Enable the Content Advisor and password it.  


    Well done Morakon, works a treat! If I've got any questions about this I'll be back......
    Saturday, December 12, 2009 7:24 PM
  • Using Content Advisor is a work around.  The blcok sites in Steady State should work.  Why doent it work??  Is having a proxy the issue?  Surely many companies have proxies.

    All my websites that I have allowed are blocked too.  Any progress on the fix for this problem  ..in steady State?

    Thursday, May 20, 2010 1:43 AM
  • I came across this problem and managed to come out a workaround. Please enjoy.

    My laptop client is running on Vista. I have already installed SteadyState2.5. I do not need proxy server to access Internet.

    My objective is to allow User1 to access http://www.google.com only. Below are the steps:

    1) Login using User1. At the Internet Explorer Internet Options, Check "Using Proxy Server". Proxy Server can be set to "CannotAccessInternet". 

    2) At the Exception page, put *.google.com into the textbox. This means that accessing www.google.com is using without proxy server.

    3) Login using Administrator. Configure User1 to lock down. Please remember to not enable Only Allow certain website to access. I believe this feature has bugs.

     

    Thanks.

    Wednesday, January 12, 2011 11:21 AM