none
Computer Configuration - Folder Options "File Type" Preference not Applying on Windows Clients (7 and newer)

    Question

  • This morning, a customer sent a RAR file to one of our staff members via email.  We don't routinely handle these files, so that person didn't know how to open it.  However, we do pre-install 7-zip on all of our machines specifically to handle numerous types of compressed/archive files.  I showed the staff member how to use 7-zip to open the file.  The problem is we don't configure 7-zip to take over all the compressed/archive file associations during install.

    Since I'd prefer not to do this manually after the fact, I figured I could use Group Policy to update the file associations for all our client computers (and users).  I did my research and found the Computer Configuration > Control Panel Settings > Preferences > Folder Options > File Type setting should achieve the desired result:

    https://technet.microsoft.com/en-us/library/cc754587.aspx

    I then remoted into one of our Windows 2008 R2 servers and opened Group Policy Management to modify our "standard setup" policy.  This server already had 7-Zip (x64) installed and I had previously used the 7-Zip File Manager to take over the RAR file type *before* I added this new preference to our policy.  I note that because I've seen Group Policy Preferences pull information from the local machine that is used to create/modify the policy.  If the machine didn't have the right settings or software, the policy would be much more challenging to configure.

    That said, I configured the settings below:

    GP-Mgmt-Editor-Folder-Options

    GP-Mgmt-Editor-RAR-File-Type-Settings

    GP-Mgmt-Editor-RAR-Action-Open-Settings

    I compared these settings with the ones from the registry (HKEY_CLASSES_ROOT) and everything looks right to me:

    RegEdit-HKCR-7-Zip.rar-Shell-Open-Command

    RegEdit-HKCR-7-Zip.rar-DefaultIcon

    I finished modifying the policy and closed out the editor and GPMC, then I forced a GP update from each of our domain controllers (PDC emulator first).  I then did the same with my test machines (1 Windows 8.1 Enterprise 64-bit, 1 Windows 7 SP1 Enterprise 64-bit, and 1 Windows 7 SP1 Enterprise 32-bit) , but saw no change.  I logged out of each machine and logged back in (after running gpupdate /force), but that didn't work.  I rebooted each test machine, but still the policy did not apply.

    I looked in the event log and I'm seeing this warning on each machine, no matter the OS or bitness:

    Event ID:  4098 - Source:  Group Policy Folder Options

    Description:

    "The computer 'rar' preference item in the 'Standard-Setup {8AAEFE4E-7904-4BA1-9A44-67805BA91700}' Group Policy Object did not apply because it failed with error code '0x80004002 No such interface supported' This error was suppressed."

    Win8.1-64-Event-Viewer-Application-Log-Warning-EventID-4098

    I researched that warning but my searches came up empty...

    What am I missing here??

    One final note:

    Since the "File Type" setting isn't applying, I'm temporarily using the "Open With" preference in the user context to achieve a similar result (although that's not really how I want the policy to be configured).  The "Open With" preference is working:

    https://technet.microsoft.com/en-us/library/cc732272.aspx


    • Edited by jrondeau30 Thursday, September 17, 2015 7:21 PM Cleaned up title clutter
    Thursday, September 17, 2015 6:43 PM

All replies

  • Have you checked the gpresult?

    According to this MSDN article, the error code you are getting refers to the error constant "E_NOINTERFACE", which basically means the component that was registered to handle this operation does not support it

    Friday, September 18, 2015 8:58 AM
  • Did you see the error/worning on all machines?


    Friday, September 18, 2015 9:06 AM
  • Use GPP registry and modify the HKCU hive to make the change for the user.

    HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\FileExts\.rar

    Populate the OpenWithList, OpenWithProgids and UserChoice using the same steps you did above (mimic a working machine). It should set the file association for .rar with 7zip.

    zxx


    • Edited by zxxzxx Friday, September 18, 2015 2:29 PM
    Friday, September 18, 2015 2:28 PM
  • Have you checked the gpresult?

    According to this MSDN article, the error code you are getting refers to the error constant "E_NOINTERFACE", which basically means the component that was registered to handle this operation does not support it


    GPResult shows the overall policy being applied while the "File Type" preference fails with error code 0x80004002 - *exactly* the same as what I see in Event Viewer.
    Friday, September 18, 2015 3:07 PM
  • Did you see the error/worning on all machines?


    Yes - this error appears on all three test machines.

    One machine is Windows 8.1 Enterprise 64-bit, another is Windows 7 Enterprise (with SP1) 64-bit, and the third is Windows 7 Enterprise (with SP1) 32-bit.

    Friday, September 18, 2015 3:09 PM
  • Use GPP registry and modify the HKCU hive to make the change for the user.

    HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\FileExts\.rar

    Populate the OpenWithList, OpenWithProgids and UserChoice using the same steps you did above (mimic a working machine). It should set the file association for .rar with 7zip.

    zxx


    Thank you for replying, but this doesn't help me with my problem.  I mentioned at the end of my original post/question that I already got the "Open With" preference to apply successfully.  It achieves the same result as what you're proposing here.

    I also mentioned that the "Open With" preference is just being used as a temporary workaround and it's not how I want the policy to apply long term.  I want this to be applied per computer, not per user.

    Friday, September 18, 2015 3:16 PM
  • Have you configured any filters/item level targeting of this preference setting? If so, remove that and see if that works. Might be something in the filter.
     

    Regards,

    Ethan Hua


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com

    Monday, September 21, 2015 2:22 AM
    Moderator
  • Have you configured any filters/item level targeting of this preference setting? If so, remove that and see if that works. Might be something in the filter.
     

    Regards,

    Ethan Hua


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com


    To answer your question, we do not have any filters or item-level targeting specified for this preference.  The GPO itself also does not specify any filters of any kind.
    Monday, September 21, 2015 9:06 PM
  • > "The computer 'rar' preference item in the 'Standard-Setup
    > {8AAEFE4E-7904-4BA1-9A44-67805BA91700}' Group Policy Object did not
    > apply because it failed with error code '0x80004002 No such interface
    > supported' This error was suppressed."
     
    Seems like an issue with your 7-zip installation. I did what you did,
    and it worked immediately. Only possible difference: On Win8.1 64 Bit
    Ent, I used the 64 Bit version of 7-zip.
     
    GPResult excerpt:
     
    File Type (Name: rar)
    The following settings have applied to this object. Within this
    category, settings nearest the top of the report are the prevailing
    settings when resolving conflicts.
    rar
    Winning GPO APP_MSI - 7-Zip
    Result: Success
    General
    Action Update
    Properties
    File extension rar
    Associated Class 7z Archive
    Configure class settings Enabled
    Icon file path C:\Program Files (x86)\7-Zip\7z.dll
    Icon Index 3
    Confirm open after download Disabled
    Always show extension Disabled
    Browse in same window Disabled
     
     

    Greetings/Grüße, Martin

    Mal ein gutes Buch über GPOs lesen?
    Good or bad GPOs? - my blog…
    And if IT bothers me - coke bottle design refreshment (-:
    Thursday, September 24, 2015 11:11 AM
  • > and it worked immediately. Only possible difference: On Win8.1 64 Bit
    > Ent, I used the 64 Bit version of 7-zip.
     
    ...and I created the .rar file class on the client computer with the
    above 7-Zip installation.
     

    Greetings/Grüße, Martin

    Mal ein gutes Buch über GPOs lesen?
    Good or bad GPOs? - my blog…
    And if IT bothers me - coke bottle design refreshment (-:
    Thursday, September 24, 2015 11:33 AM
  • > and it worked immediately. Only possible difference: On Win8.1 64 Bit
    > Ent, I used the 64 Bit version of 7-zip.
     
    ...and I created the .rar file class on the client computer with the
    above 7-Zip installation.
     

    Greetings/Grüße, Martin

    Mal ein gutes Buch über GPOs lesen?
    Good or bad GPOs? - my blog…
    And if IT bothers me - coke bottle design refreshment (-:

    Martin,

    Thanks for your response.  However, I fail to see how this helps.  If I were to create the file class on each computer with 7-Zip (which I'm presently trying to avoid), then there would be no need to configure Group Policy to set the RAR file type to use 7-Zip.  Am I missing something here?

    Try doing the same with the .7z file extension (without first taking over the file association in 7-Zip).  Does that work for you as well?

    Monday, September 28, 2015 7:39 PM
  • > were to create the file class on each computer with 7-Zip (which I'm
     
    Not "on each" - simply "on one", like you did on the server. Install
    RSAT, edit your GPO on the client computer.
     

    Greetings/Grüße, Martin

    Mal ein gutes Buch über GPOs lesen?
    Good or bad GPOs? - my blog…
    And if IT bothers me - coke bottle design refreshment (-:
    Tuesday, September 29, 2015 9:47 AM