locked
Vista prevents me from renaming folders! RRS feed

  • Question

  • My folders are all prevented by something draconian from getting renamed. The read-only box in the properties is filled-in blue, not checked. What does it mean? According to the properties, I own the folders. How do I restore the ability to rename folders???
    Tuesday, June 16, 2009 11:39 PM

Answers

  • Can you remove those files under Safe Mode? You can also try take ownership of the files and then try to delete them:

     

    1. Please navigate to the target file/folder.

    2. Right-click on the file/folder and choose Properties.

    3. Click the "Security" tab and see if your current user is listed in the "Group or user names" list. If not, please click the Add button, type the name of your current user in the "Enter the object names to select " box, then click "OK" to add this group.

    4. Select the user from the list and then check the "Allow" checkbox next to "Full Control".

    5. Click the Advanced button and click the "Owner" tab. Then, press "Edit" button.

    6. Select current user from the list and check the "Replace owner on subcontainers and objects" checkbox.

    7. Click "OK" to save changes and wait for Windows Vista to transfer the ownership of all the objects on the partition.

    8. Click OK again to save changes and exit the Properties window.

     

    Let's see if they can be removed. If they still cannot be removed, please let me know the error message you received.


    Sean Zhu - MSFT
    Wednesday, June 17, 2009 8:52 AM
    Moderator

All replies

  • Can you remove those files under Safe Mode? You can also try take ownership of the files and then try to delete them:

     

    1. Please navigate to the target file/folder.

    2. Right-click on the file/folder and choose Properties.

    3. Click the "Security" tab and see if your current user is listed in the "Group or user names" list. If not, please click the Add button, type the name of your current user in the "Enter the object names to select " box, then click "OK" to add this group.

    4. Select the user from the list and then check the "Allow" checkbox next to "Full Control".

    5. Click the Advanced button and click the "Owner" tab. Then, press "Edit" button.

    6. Select current user from the list and check the "Replace owner on subcontainers and objects" checkbox.

    7. Click "OK" to save changes and wait for Windows Vista to transfer the ownership of all the objects on the partition.

    8. Click OK again to save changes and exit the Properties window.

     

    Let's see if they can be removed. If they still cannot be removed, please let me know the error message you received.


    Sean Zhu - MSFT
    Wednesday, June 17, 2009 8:52 AM
    Moderator
  • HOWDY Sean !
    How does your response relate to the question of not being able to rename folders ?
    Sunday, September 25, 2011 2:00 PM