locked
Multimon function in RDP RRS feed

  • General discussion

  • So I have a Windows 7 Professional desktop. I can remote into my Windows 10 Professional laptop using the multimon feature and everything works properly. On the other hand, my Win10 Pro machine is docked and has dual displays. But if I try to remote into my Win7 Pro desktop with the multimon feature it does not use both screens. The RDP only opens in a sigle screen. I know that I can span using mstsc.exe /span in cmd but that is not the feature that I am looking for. I've also tried running mstsc.exe /multimon in cmd without any success. I've tried the Splitview program and I did not have much success with that either. Below is a copy of the settings in the rdp being used to remote into my desktop. Now, to clearify, I am having the same exact issue on a Win7 Pro laptop. The solution that I am looking for is for the Win7 laptop but I am testing on my Win10 laptop before I implement the fix.

    screen mode id:i:2
    use multimon:i:1
    desktopwidth:i:1920
    desktopheight:i:1080
    session bpp:i:32
    winposstr:s:0,3,0,0,800,600
    compression:i:1
    keyboardhook:i:2
    audiocapturemode:i:0
    videoplaybackmode:i:1
    connection type:i:7
    networkautodetect:i:1
    bandwidthautodetect:i:1
    displayconnectionbar:i:1
    enableworkspacereconnect:i:0
    disable wallpaper:i:0
    allow font smoothing:i:0
    allow desktop com:0
    disable full window drag:i:1
    disable menu anims:i:1
    disable themes:i:0
    disable cursor setting:i:0
    bitmapcachepersistenable:i:1
    full address:s:alg0930 (This is the desktop address)
    audiomode:i:0
    redirectprinters:i:1
    redirectcomports:i:0
    redirectsmartcards:i:1
    redirectclipboard:i:1
    redirectposdevices:i:0
    autoreconnection enabled:i:1
    authentication level:i:2
    prompt for credentials:i:0
    negotiate security layer:i:1
    remoteapplicationmode:i:0
    alternate shell:s:
    shell working directory:s:
    gatewayhostname:s:
    gatewayusagemethod:i:4
    gatewaycredentialssource:i:4
    gatewayprofileusagemethod:i:0
    promptcredentialonce:i:0
    gatewaybrokeringtype:i:0
    use redirection server name:i:0
    rdgiskdcproxy:i:0
    kdcproxyname:s:

    Does anyone have any suggestions?


    • Edited by Marcod184 Monday, November 9, 2015 9:22 PM
    Monday, November 9, 2015 9:20 PM

All replies

  • You already tried this ? 

    http://www.techrepublic.com/blog/windows-and-office/use-multiple-monitors-with-windows-7s-remote-desktop-connection/


    Arnav Sharma | http://arnavsharma.net/ Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Tuesday, November 10, 2015 9:29 PM
  • See that's the thing though. This link is incorrect because I'm using Windows 7 Pro on my desktop (I know this because I do all the imagining for the company I work for). And with that very same desktop I can run the RDP and take advantage of the dual monitors. This not to be confused with mstsc.exe /span. It is completely two separate desktops with no additional software or modifications. The funny thing is, the laptop can remote into all of our servers using dual screen so this leads me to believe that there is a setting that needs to be enabled on the desktop for the laptop to be able to use dual monitors.
    • Edited by Marcod184 Wednesday, November 11, 2015 1:14 PM
    Wednesday, November 11, 2015 1:13 PM
  • Can you try installing this ? 

    https://support.microsoft.com/en-us/kb/2592687


    Arnav Sharma | http://arnavsharma.net/ Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Wednesday, November 11, 2015 10:18 PM
  • Any update ? 

    Arnav Sharma | http://arnavsharma.net/ Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Wednesday, November 18, 2015 2:24 AM
  • I haven't had access to the comp until just now. I've installed the update just waiting for the client to get back and try the solution. Will likely hear something tomorrow.
    Wednesday, November 18, 2015 7:39 PM
  • I've installed the update on the Win7 Pro laptop and restarted it. I tried to install it on the Win7 Pro desktop as well but the system says that it is already installed. I've tried accessing the desktop remotely from the laptop and I still have the same issue.
    Wednesday, November 18, 2015 9:07 PM