locked
The Windows Event Log Provider is still unable to open the RRS feed

  • Question

  • I am working with a group that has created an event log for their applcation and I am getting an error when trying to read the log via SCOM sp1. I have researched the error and applied the only hotfix, kb959865 that even remotely looks like it may help, with no luck. I have looked at the default action account and it is fine. Any ideas!

    The Windows Event Log Provider is still unable to open the SpecAppLog event log on computer 'Spec-proxy1.Spec.com'. The Provider has been unable to open the SpecAppLog event log for 2160 seconds.

    Most recent error details: There are no more endpoints available from the endpoint mapper.

     

    One or more workflows were affected by this.

    Workflow name: SpecGroup.Atari.TestMonitor.App1

    Instance name: venus.Spec.com

    Instance ID: {C33BB951-D05F-9990-59F7-83A0ADF3F420}

    Management group: scom

    Tuesday, September 8, 2009 7:59 PM

Answers

  • After much work we found the solution, thanks for your reply.
    • Marked as answer by Dethgiver Thursday, September 17, 2009 3:19 PM
    Thursday, September 17, 2009 3:19 PM

All replies

  • when you say the 'default action account is fine', have you changed the action account on the agent from LocalSystem to something else? If you change to a non-privileged domain users, you will have to grant that account rights to the Event Logs. This is mentioned in Low-Privileged Evironments in the MP Guide of many management packs.

    Also, what is the OS of the machine in question?

    Pete Zerger, MVP-OpsMgr and SCE | http://www.systemcentercentral.com
    • Proposed as answer by Marnix WolfMVP Monday, September 14, 2009 5:46 PM
    Saturday, September 12, 2009 10:57 PM
  • After much work we found the solution, thanks for your reply.
    • Marked as answer by Dethgiver Thursday, September 17, 2009 3:19 PM
    Thursday, September 17, 2009 3:19 PM
  • What was the solution to your problem?
    Friday, December 11, 2009 1:11 PM
  • I had made an error in the code. The name of the computer that we were trying to open the log on was incorrect.
    Friday, December 11, 2009 1:59 PM
  • Hi,

    If you can provide the solution which you applied to fix this issue then it would be batter for me,

    as i am also having same issue but my OS is server 2008 R2.

    your responce would be great :) :)


    Regards, Ganesh M <!> Microsoft MPN - Member =========================================================== Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Tuesday, January 31, 2012 4:15 PM
  • The reason it didn't work when I first tested it was there was a typo in my monitor. You have to re-check everything to make sure that you don't miss the problem. This monitor is near bullit proof if done correctly.
    Tuesday, January 31, 2012 11:24 PM
  • Disable the Windows Server 2008 R2 DHCP Descovery for a group (Windows Server 2003 Computer Group)
    1.Open the Operations Console | Monitoring
    2.Management Pack Objects
    3.Object Discoveries
    4.Find "Microsoft.Windows.2008R2.DHCP.Server.Discovery"
    5.Right click the discovery Override for a group "Windows Server 2003 Computer Group" - Enabled false
    6.From Operations Manager shell >> Remove-DisabledMonitoringObject

    Couple of minutes and the warnings will disappear, you might need to restart the HealthService on the affected agents.

    -----------------------------------------------------------------------

    G.R.V

    Remember to click “Mark as Answer” on the post that helps you.
    Monday, May 18, 2015 1:19 PM