locked
Folder permission issue in AppV 5.1 RRS feed

  • Question

  • I have sequenced an application on AppV 5.1 sequencer. It is a .ade file which needs to be copied in the path ProgramFilesX86\ApplicationName\ . I have copied the file and give .\Users  modify permission on the folder 'Application Name', in order for the file to launch and work properly with all rights. But this permission does not get captured in AppV Sequencer 5.1. When i launch the file, it takes up the default "Read" permission. I open the virtual file path in %ProgramData% and the folder ProgramFilesX86\Application Name, to which i had given modify permission to .\Users group, contains no Users group. It only has Administrators,Everyone and System , all of whom take up the default Read permission. 

    Please note I have also checked the three options in the AppV package, under the Advanced tab. But still no help.

    Are file and folder permissions captured at all in AppV Sequencer?? If yes, how? Please suggest and help.


    Tuesday, June 7, 2016 11:41 AM

Answers

  • Permissions are not carried into the bubble as in AppV 4.6. It's only the Full write permissions to VFS Folder option available under Advanced tab that takes care of Permissions.

    Have you tried running the shortcut as an Administrator & see if that helps.


    Posted AS IS with No Warranties. Mark as Answer if this answers your question, It will help other community members.

    • Marked as answer by pallaviseth24 Monday, June 27, 2016 10:01 AM
    Tuesday, June 7, 2016 7:18 PM

All replies

  • Permissions are not carried into the bubble as in AppV 4.6. It's only the Full write permissions to VFS Folder option available under Advanced tab that takes care of Permissions.

    Have you tried running the shortcut as an Administrator & see if that helps.


    Posted AS IS with No Warranties. Mark as Answer if this answers your question, It will help other community members.

    • Marked as answer by pallaviseth24 Monday, June 27, 2016 10:01 AM
    Tuesday, June 7, 2016 7:18 PM
  • Hi. The shortcut on right click contains no option of 'Run As Administrator'. The shortcut points to a .ade file, which has been manually copied in C:/ProgramFiles/ApplicationName by me. It opens via Microsoft Access.


    Wednesday, June 8, 2016 7:16 AM
  • Hold shift & then right click on the shortcut to see if you get Run As Administrator.

    Also, do you see any issue with the functionality of the application when compared to source? Or it's just that you are not able to find full permissions that you have applied.


    Posted AS IS with No Warranties. Mark as Answer if this answers your question, It will help other community members.

    Wednesday, June 8, 2016 10:16 AM
  • Hello....no Run As Admin option after holding Shift +Right click on shortcut.

    The source runs fine. Only when we copy the source file in C:/ProgramFilesX86 location inside the Application folder, it gives the error - This file has been opened in Read only mode. When I give that folder .\Users modify permission, it works perfect again! This thing doesn't get captured in sequencer. The AppV package also gives the error "Read Only".

    Wednesday, June 8, 2016 10:42 AM
  • Also, after publishing the AppV , when I cross check in %programData% AppV file path, the folder I had given permission on, contains no .\Users group only. And all others have Read only permission. Any idea how I can capture this with sequencer 5.1?? 
    Wednesday, June 8, 2016 2:37 PM
  • Has a solution been found for this? We have a number of MSAccess applications that require to be sequenced but all of them are giving the error "Cannot update. Database or object is read-only". 

    I have ticked all the options under the advance tab but it still says that the database is read only.

    Please can someone help?

     

    Wednesday, October 24, 2018 10:54 AM