locked
Personal Folder - how can you hide it? RRS feed

  • Question

  • Is there any way of removing/hiding the "Personal Folder" link?

    We've taken it off the start menu and desktop, but it still appear on the 'desktop' when you view it through open/save dialog boxes.  We redirect all My Documents etc to other location and the "Personal Folder" link is enabling people to save into their roaming profile.

    Thanks

     

    Wednesday, October 20, 2010 2:30 PM

Answers

  • Hi,

     

    Thank for posting in Microsoft TechNet Forum.

     

    As my understanding, you want to hide user folder on desktop, also “open/save desktop”. You could try the following steps:

     

    Note: before this operation, please backup your Registry.

     

    1.      Open the Start Menu and type regedit.exe in start search box, press enter. If prompted by UAC, click Yes.

    2.      Find the location below in Regedit.

    1). If your system is Windows 7 32bit, go to HKEY_CLASSES_ROOT\CLSID\{59031a47-3f72-44a7-89c5-5595fe6b30ee}\ShellFolder

                   2). If your system is Windows 7 64bit, go to HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Classes\CLSID\{59031a47-3f72-44a7-89c5-5595fe6b30ee}\ShellFolder

           3.     Right click on the ShellFolder key and click on Permissions, select the Administrators group, then check the Allow box to the right of Full Control and click OK.

           4.     In the right pane of regedit, right click on Attributes and click on Modify. The default value is f084012d, now change to f094012d.

           5.     Close Regedit.

     

    Now, the personal folder won’t appear at desktop. If you want to add it to desktop, you can repeat the steps above, and change the Attributes value to f084012d.

     

    Hope it helps.

     

    Regards,

    Alex Zhao

    TechNet Subscriber Support in forum.

    If you have any feedback on our support, please contact tngfb@microsoft.com

     


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    • Marked as answer by DJL Thursday, October 21, 2010 10:17 AM
    Thursday, October 21, 2010 7:15 AM

All replies

  • Hi,

     

    Thank for posting in Microsoft TechNet Forum.

     

    As my understanding, you want to hide user folder on desktop, also “open/save desktop”. You could try the following steps:

     

    Note: before this operation, please backup your Registry.

     

    1.      Open the Start Menu and type regedit.exe in start search box, press enter. If prompted by UAC, click Yes.

    2.      Find the location below in Regedit.

    1). If your system is Windows 7 32bit, go to HKEY_CLASSES_ROOT\CLSID\{59031a47-3f72-44a7-89c5-5595fe6b30ee}\ShellFolder

                   2). If your system is Windows 7 64bit, go to HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Classes\CLSID\{59031a47-3f72-44a7-89c5-5595fe6b30ee}\ShellFolder

           3.     Right click on the ShellFolder key and click on Permissions, select the Administrators group, then check the Allow box to the right of Full Control and click OK.

           4.     In the right pane of regedit, right click on Attributes and click on Modify. The default value is f084012d, now change to f094012d.

           5.     Close Regedit.

     

    Now, the personal folder won’t appear at desktop. If you want to add it to desktop, you can repeat the steps above, and change the Attributes value to f084012d.

     

    Hope it helps.

     

    Regards,

    Alex Zhao

    TechNet Subscriber Support in forum.

    If you have any feedback on our support, please contact tngfb@microsoft.com

     


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    • Marked as answer by DJL Thursday, October 21, 2010 10:17 AM
    Thursday, October 21, 2010 7:15 AM
  • Alex - many thanks for your quick response.  Your solution works perfectly.

    For future reference if you are running Windows 7 x64 you need to change the Attibutes key in both HKEY_CLASSES_ROOT and HKEY_LOCAL_MACHINE

    Thursday, October 21, 2010 10:17 AM
  • Perfect! thanks for this solution
    Thursday, December 1, 2011 1:53 PM
  • Hi there,

    Can you do this through group policy using windows server 2008

    Thanks,

    Sean

    Friday, March 16, 2012 2:54 PM
  • I needed the same thing and your solution worked perfectly.

    can the same thing be done for the control panel icon?

    Thanks a lot Alex.


    Mohsen Almassud

    Sunday, May 13, 2012 9:39 PM
  • one of the guys here on the forum prvoded an excellent solution for this with a per user settings:

    [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\NonEnum]
    "{59031a47-3f72-44a7-89c5-5595fe6b30ee}"=dword:00000001

    the thread is here:

    http://social.technet.microsoft.com/Forums/en-US/winserverTS/thread/3291098c-92a5-4bba-8b2e-11bcc16d3ec7


    Mohsen Almassud

    Monday, May 28, 2012 2:15 AM
  • Is there any way the "Personal" folder can be hidden from Office 2010's Save/Open dialog boxes?

    Applying the change to HKEY_CLASSES_ROOT\CLSID\{59031a47-3f72-44a7-89c5-5595fe6b30ee}\ShellFolder works a treat for the Desktop, but not so much for Office.

    Monday, September 2, 2013 12:24 AM
  • I needed the same thing for Open/Save dialog too. I hide the Libraries system folder content but not users Personal Folder.

    EDIT

    Found solution, key and dword value needed:

    [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\CLSID\{59031A47-3F72-44A7-89C5-5595FE6B30EE}\ShellFolder]
    "Attributes"=dword:f094012d



    ----- Lukas -----


    • Edited by lukval Tuesday, January 28, 2014 3:09 PM found solution
    • Proposed as answer by lukval Wednesday, December 3, 2014 9:14 AM
    Monday, January 27, 2014 2:05 PM